VirtualBox

Ticket #15717 (closed defect: fixed)

Opened 8 months ago

Last modified 7 months ago

Ubuntu 14.04 LTS: xcb not found

Reported by: 0x0000.ru Owned by:
Priority: major Component: GUI
Version: VirtualBox 5.1.2 Keywords: ubuntu xcb
Cc: Guest type: other
Host type: other

Description

user@computer ~ $ virtualbox
Qt FATAL: This application failed to start because it could not find or load the Qt platform plugin "xcb".

Available platform plugins are: xcb.

Reinstalling the application may fix this problem.
Aborted

However, this trick helps run the GUI:

P=/usr/lib/virtualbox; sudo LD_LIBRARY_PATH=$P:$P/plugins/platforms $P/VirtualBox

may be related to https://www.virtualbox.org/ticket/15634

Attachments

log.txt Download (245.3 KB) - added by 0x0000.ru 8 months ago.
log_as_root.txt Download (257.6 KB) - added by 0x0000.ru 8 months ago.
log_110225_i386.txt Download (121.3 KB) - added by 0x0000.ru 7 months ago.

Change History

comment:1 Changed 8 months ago by frank

Cannot reproduce. Please do the following as root:

strace -f -s128 -o log.txt /usr/lib/virtualbox/VirtualBox

and attach the resulting file log.txt to this ticket. I guess there is some pending qt.conf file.

comment:2 Changed 8 months ago by fourty

I have the exact same problem on my Mint 17.3 x32 XFCE machine. The above trick does work for me a well. I have QT 5.5 installed for development.

comment:3 Changed 8 months ago by frank

I would rather like to know why it works for me but apparently not for you. So if you want to help, please provide the output which I requsted in comment 1.

Changed 8 months ago by 0x0000.ru

comment:4 Changed 8 months ago by 0x0000.ru

After upgrading to 16.04 I get the same error.

Changed 8 months ago by 0x0000.ru

comment:5 Changed 8 months ago by 0x0000.ru

Sorry, I missed that should be run as root. I have attached a new file.

comment:6 Changed 8 months ago by frank

Thanks for the log. I found one problem which (for some reason) did not trigger on my Ubuntu 14.04 environment, no idea why. Could you test if this test build fixes the problem for you? Thank you!

comment:7 Changed 8 months ago by 0x0000.ru

Is there a test build for i386?

Last edited 8 months ago by 0x0000.ru (previous) (diff)

comment:8 Changed 8 months ago by frank

Yes, see here.

Changed 7 months ago by 0x0000.ru

comment:9 Changed 7 months ago by 0x0000.ru

No, the problem is not solved for the i386. But I found out that the amd64 build works well. I used for the research a fresh install of Ubuntu 14.04.5 LTS

comment:10 Changed 7 months ago by frank

That was it. I thought it's a systematic bug but actually it was a problem specific to 32-bit. Will be fixed in 5.1.4.

comment:11 Changed 7 months ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Fix is part of 5.1.4.

comment:12 Changed 7 months ago by 0x0000.ru

Great! Thanks.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use