VirtualBox

Ticket #1570 (new defect)

Opened 6 years ago

Last modified 4 years ago

Errors using rawdisk access - Vista64 Host, Linux Guest

Reported by: firecat53 Owned by:
Priority: major Component: virtual disk
Version: VirtualBox 1.6.0 Keywords: rawdisk,
Cc: Guest type: Linux
Host type: Windows

Description

Summary:

  1. After creating a rawdisk image either full disk or per-partition, the guest system throws a continuing set of Buffer I/O errors, making the raw partition unusable.

Setup:

  1. Vista Ultimate 64 bit edition, w/ Virtualbox 1.6 amd64 installed. When installing, I installed as administrator (right click and run-as-admin on install file). I also have to run Virtualbox and any command line shells in Vista as administrator to get the rawdisk access at all. Guest is Ubuntu 8.04 server x86.
  2. Intel processor VIIV, 2GB RAM. Primary hard drive SATA, second hard drive IDE. Both were accessible directly from Vista with no problems, and both were also accessible normally from an Ubuntu Live CD (amd64) with no errors. Repartitioned the IDE drive and still got the same results.
  3. To enable rawdisk access, I opened up device manager, selected show devices by connection and show hidden devices, then found the appropriate 'Generic Volume' entries under Volume Manager and selected disable for each partition to unmount them from Vista. Successfully created rawdisk .vmdk file with the following (second partition on my primary SATA drive):
    VBoxManage.exe internalcommands createrawvmdk -filename C:\.VirtualBox\VDI\second.vmdk -rawdisk \.\PhysicalDrive0 -partitions 2 -register
    
    I also used the same command to create full disk access on the second (IDE) drive and received the same end results.

Results:

  1. The drives show up in /proc/partitions correctly. I can mount them and do some file operations, but each time, I get the following errors both on the console and in dmesg:
    [ 1232.134243] ata1.01: exception Emask 0x0 SAct 0x0 SErr 0x0 action 0x0
    [ 1232.134739] ata1.01: BMDMA stat 0x64
    [ 1232.135144] ata1.01: cmd 35/00:08:88:e2:39/00:00:21:00:00/f0 tag 0 dma 4096 out
    [ 1232.135157]          res 41/10:08:88:e2:39/10:00:21:00:00/f0 Emask 0x81 (invalid argument)
    [ 1232.135859] ata1.01: status: { DRDY ERR }
    [ 1232.136349] ata1.01: error: { IDNF }
    [ 1232.138546] ata1.00: configured for MWDMA2
    [ 1232.139200] ata1.01: configured for MWDMA2
    [ 1232.139229] sd 0:0:1:0: [sdb] Result: hostbyte=DID_OK driverbyte=DRIVER_SENSE,SUGGEST_OK
    [ 1232.139248] sd 0:0:1:0: [sdb] Sense Key : Aborted Command [current] [descriptor]
    [ 1232.139270] Descriptor sense data with sense descriptors (in hex):
    [ 1232.139284]         72 0b 14 00 00 00 00 0c 00 0a 80 00 00 00 00 00
    [ 1232.139325]         21 39 e2 88
    [ 1232.139344] sd 0:0:1:0: [sdb] Add. Sense: Recorded entity not found
    [ 1232.139364] end_request: I/O error, dev sdb, sector 557441672
    [ 1232.139429] ata1: EH complete
    [ 1232.139844] sd 0:0:0:0: [sda] Write cache: enabled, read cache: enabled, doesn't support DPO or FUA
    
    
  1. The raw drives are unusable because of the continuing stream of error messages. Also sometimes after the drives are unmounted, any changes I made are not recorded. I've tried recreating the filesystems thinking that the IDE drive had been created a few years ago, but still got the same results.

I've attached several configuration and log files. Let me know if you need more information.

Thanks! Scott

Attachments

VirtualBox.xml Download (2.3 KB) - added by firecat53 6 years ago.
VirtualBox.xml
test.xml Download (3.3 KB) - added by firecat53 6 years ago.
Virutal Machine config test.xml
VBox.log Download (141.3 KB) - added by firecat53 6 years ago.
VBox.log

Change History

Changed 6 years ago by firecat53

Changed 6 years ago by firecat53

Virutal Machine config test.xml

Changed 6 years ago by firecat53

VBox.log

comment:1 Changed 6 years ago by firecat53

I forgot to note above that I tried both IDE adapters on the virtual machine PIIX3 and PIIX4 and got the same result for both.

Scott

comment:2 Changed 6 years ago by frank

  • Host type changed from other to Windows
  • Component changed from other to virtual disk
  • Guest type changed from other to Linux

comment:3 Changed 5 years ago by Marginal

I see similar disk errors - VirtualBox 3.02-3.08, Windows Vista x86 host, Linux Ubuntu 9.04 amd64 guest, raw disk physically attached to a SATA AHCI controller.

Workaround as follows:

  1. Check Settings -> Hard Disks -> Enable Additional Controller -> SATA (AHCI)
  1. Settings -> Hard Disks -> Attachments -> Slot change from "IDE Primary Master" to "SATA Port 0"
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use