VirtualBox

Ticket #15644 (closed defect: fixed)

Opened 14 months ago

Last modified 14 months ago

VBoxManage list usbhost fails to correctly identify USB dongle => Fixed in SVN

Reported by: JsT Owned by:
Priority: major Component: USB
Version: VirtualBox 5.1.0 Keywords:
Cc: Guest type: Windows
Host type: Linux

Description

Here is the output of various commands that might be useful. My report and comments are disclosed below.

$ uname -a
Linux badger 4.6.4-1-ARCH #1 SMP PREEMPT Mon Jul 11 19:12:32 CEST 2016 x86_64 GNU/Linux
$sudo lsusb -vv -d 0658:0200
Bus 001 Device 014: ID 0658:0200 Sigma Designs, Inc. 
Device Descriptor:
  bLength                18
  bDescriptorType         1
  bcdUSB               2.00
  bDeviceClass            2 Communications
  bDeviceSubClass         0 
  bDeviceProtocol         0 
  bMaxPacketSize0         8
  idVendor           0x0658 Sigma Designs, Inc.
  idProduct          0x0200 
  bcdDevice            0.00
  iManufacturer           0 
  iProduct                0 
  iSerial                 0 
  bNumConfigurations      1
  Configuration Descriptor:
    bLength                 9
    bDescriptorType         2
    wTotalLength           67
    bNumInterfaces          2
    bConfigurationValue     1
    iConfiguration          0 
    bmAttributes         0x80
      (Bus Powered)
    MaxPower              100mA
    Interface Descriptor:
      bLength                 9
      bDescriptorType         4
      bInterfaceNumber        0
      bAlternateSetting       0
      bNumEndpoints           1
      bInterfaceClass         2 Communications
      bInterfaceSubClass      2 Abstract (modem)
      bInterfaceProtocol      1 AT-commands (v.25ter)
      iInterface              0 
      CDC Header:
        bcdCDC               1.10
      CDC Call Management:
        bmCapabilities       0x00
        bDataInterface          1
      CDC ACM:
        bmCapabilities       0x00
      CDC Union:
        bMasterInterface        0
        bSlaveInterface         1 
      Endpoint Descriptor:
        bLength                 7
        bDescriptorType         5
        bEndpointAddress     0x81  EP 1 IN
        bmAttributes            3
          Transfer Type            Interrupt
          Synch Type               None
          Usage Type               Data
        wMaxPacketSize     0x0008  1x 8 bytes
        bInterval              32
    Interface Descriptor:
      bLength                 9
      bDescriptorType         4
      bInterfaceNumber        1
      bAlternateSetting       0
      bNumEndpoints           2
      bInterfaceClass        10 CDC Data
      bInterfaceSubClass      0 
      bInterfaceProtocol      0 
      iInterface              0 
      Endpoint Descriptor:
        bLength                 7
        bDescriptorType         5
        bEndpointAddress     0x82  EP 2 IN
        bmAttributes            2
          Transfer Type            Bulk
          Synch Type               None
          Usage Type               Data
        wMaxPacketSize     0x0020  1x 32 bytes
        bInterval               0
      Endpoint Descriptor:
        bLength                 7
        bDescriptorType         5
        bEndpointAddress     0x02  EP 2 OUT
        bmAttributes            2
          Transfer Type            Bulk
          Synch Type               None
          Usage Type               Data
        wMaxPacketSize     0x0020  1x 32 bytes
        bInterval               0
Device Status:     0x0000
  (Bus Powered)
$sudo VBoxManage list -l usbhost
...
UUID:               913ce319-f1b5-479b-af24-7e47a0d15b01
VendorId:           0x0058 (0058)
ProductId:          0x0000 (0000)
Revision:           0.0 (0000)
Port:               6
USB version/speed:  2/Full
Address:            sysfs:/sys/devices/pci0000:00/0000:00:14.0/usb1/1-3/1-3.7//device:/dev/vboxusb/001/014
Current State:      Busy
...
$ dmesg
...
[  617.493077] usb 1-3.7: new full-speed USB device number 14 using xhci_hcd
[  617.588369] cdc_acm 1-3.7:1.0: ttyACM0: USB ACM device

I have properly working Virtualbox and full list of USB devices available inside Windows guest OS. The problem I face is that a specific USB serial device 0658:0200 is not properly exposed by "VBoxManage list -l usbhost" and respectively not properly passed-through to Windows guest. All other devices are properly passed-through.

For some reason the (real id) "0658:0200" is detected by the "usbhost" as 0058:0000 (I can verify this by plugging and unplugging the device - this is the only device that is gone and then come back in the "usbhost" list).

Month ago (with an older version of Virtual Box /5.0.x) I was able to passthrough 0658:0200 successfully inside Windows OS. I don't recall doing something differently back then.

Change History

comment:1 Changed 14 months ago by JsT

I have downgraded the Virtualbox to previous (5.0.24) version to test with:

sudo pacman -U /var/cache/pacman/pkg/virtualbox-bin-5.0.24-1-x86_64.pkg.tar.xz /var/cache/pacman/pkg/virtualbox-ext-oracle-5.0.24-1-any.pkg.tar.xz /var/cache/pacman/pkg/virtualbox-host-dkms-5.0.24-1-x86_64.pkg.tar.xz

And the USB dongle 0658:0200 works now correctly, so I confirm that there is regression in the latest version.

comment:2 Changed 14 months ago by frank

Right, confirmed. This is a 5.1.0 regression which will be fixed in the next 5.1.x maintenance release. Thanks!

comment:3 Changed 14 months ago by frank

Btw, 5.0.26 is not affected.

comment:4 Changed 14 months ago by frank

  • Summary changed from VBoxManage list usbhost fails to correctly identify USB dongle to VBoxManage list usbhost fails to correctly identify USB dongle => Fixed in SVN

Fix in r62343.

comment:5 Changed 14 months ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Fixed in 5.1.2.

comment:6 Changed 14 months ago by JsT

  • Status changed from closed to reopened
  • Resolution fixed deleted

It seems the problem is only partially fixed.

Indeed the Vendor:Product ID pair is shown correctly, BUT the name of the devices are still unknown. What I see right now are three devices with name "Unknown device" with correct vendor/product id.

However that still causes problems, because now the device is detected as "new" one and in my particular case (for Serial USB device) Windows generates new COM port (normally COM4, now COM6) and "thinks" the device is different, based on the name, not only on the IDs.

I guess there is another place where the name is not correctly obtained. Maybe it's worth taking close inspection because I feel there are might be more issues with the USB devices.

comment:7 Changed 14 months ago by frank

  • Status changed from reopened to closed
  • Resolution set to fixed

Let's close this ticket and continue the discussion in #15764. The original problem with cut device/vendor IDs was fixed in 5.1.2.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use