VirtualBox

Ticket #15621 (closed defect: fixed)

Opened 12 months ago

Last modified 10 months ago

X11 does not work "addscreen/screeninit failed for driver 0 after upgrade from 4.0.16" -> presumed fixed in releases higher than 5.1.2

Reported by: aim Owned by:
Priority: major Component: guest additions/x11/graphics
Version: VirtualBox 5.1.0 Keywords:
Cc: Guest type: Linux
Host type: Mac OS X

Description

I have tried the versions 4.0.16-5.1.0 The error is the same in X log "addscreen/screeninit failed for driver"

I have read  https://bbs.archlinux.org/viewtopic.php?id=211331  https://bbs.archlinux.org/viewtopic.php?id=211584  https://wiki.archlinux.org/index.php/VirtualBox#Installation_steps_for_Arch_Linux_guests

Output

[aim@xcart-aim-arch:pts/0][~]$ sudo lsmod|grep -i "vbox\|virt"
vboxvideo              45056  0
ttm                    69632  1 vboxvideo
drm_kms_helper        110592  1 vboxvideo
drm                   249856  3 ttm,drm_kms_helper,vboxvideo
syscopyarea            16384  2 drm_kms_helper,vboxvideo
sysfillrect            16384  2 drm_kms_helper,vboxvideo
sysimgblt              16384  2 drm_kms_helper,vboxvideo
vboxsf                 40960  1
vboxguest             196608  3 vboxsf,vboxvideo
virtio_net             28672  0
virtio_pci             24576  0
virtio_ring            20480  2 virtio_net,virtio_pci
virtio                 16384  2 virtio_net,virtio_pci
[aim@xcart-aim-arch:pts/0][~]$ sudo lspci|grep -i vga         
00:02.0 VGA compatible controller: InnoTek Systemberatung GmbH VirtualBox Graphics Adapter
[aim@xcart-aim-arch:pts/0][~]$ sudo systemctl status -l vboxservice
● vboxservice.service - VirtualBox Guest Service
   Loaded: loaded (/usr/lib/systemd/system/vboxservice.service; enabled; vendor preset: disabled)
   Active: active (running) since Пт 2016-07-15 15:08:15 +04; 14min ago
  Process: 323 ExecStartPre=/usr/bin/modprobe vboxsf (code=exited, status=0/SUCCESS)
  Process: 319 ExecStartPre=/usr/bin/modprobe vboxvideo (code=exited, status=0/SUCCESS)
  Process: 305 ExecStartPre=/usr/bin/modprobe vboxguest (code=exited, status=0/SUCCESS)
 Main PID: 325 (VBoxService)
    Tasks: 8 (limit: 512)
   CGroup: /system.slice/vboxservice.service
           └─325 /usr/bin/VBoxService -f

июл 15 15:08:15 xcart-aim-arch.crtdev.local systemd[1]: Started VirtualBox Guest Service.
июл 15 15:08:15 xcart-aim-arch.crtdev.local VBoxService[325]: VBoxService 5.0.24_OSE r108355 (verbosity: 0) linux.x86 (Jul  6 2016 01:19:46) release log
июл 15 15:08:15 xcart-aim-arch.crtdev.local VBoxService[325]: 00:00:00.000095 main     Log opened 2016-07-15T11:08:15.135564000Z
июл 15 15:08:15 xcart-aim-arch.crtdev.local VBoxService[325]: 00:00:00.000241 main     OS Product: Linux
июл 15 15:08:15 xcart-aim-arch.crtdev.local VBoxService[325]: 00:00:00.000270 main     OS Release: 4.6.3-1-ARCH
июл 15 15:08:15 xcart-aim-arch.crtdev.local VBoxService[325]: 00:00:00.000290 main     OS Version: #1 SMP PREEMPT Fri Jun 24 21:37:08 CEST 2016
июл 15 15:08:15 xcart-aim-arch.crtdev.local VBoxService[325]: 00:00:00.000310 main     Executable: /usr/bin/VBoxService
июл 15 15:08:15 xcart-aim-arch.crtdev.local VBoxService[325]: 00:00:00.000312 main     Process ID: 325
июл 15 15:08:15 xcart-aim-arch.crtdev.local VBoxService[325]: 00:00:00.000313 main     Package type: LINUX_32BITS_GENERIC (OSE)
июл 15 15:08:15 xcart-aim-arch.crtdev.local VBoxService[325]: 00:00:00.007915 main     5.0.24_OSE r108355 started. Verbose level = 0
[aim@xcart-aim-arch:pts/0][~]$ 

Attachments

Xorg.0.log Download (7.4 KB) - added by aim 12 months ago.
VBox.log Download (81.9 KB) - added by aim 12 months ago.
VBox.log.1 Download (118.0 KB) - added by aim 12 months ago.
VBox.log.2 Download (142.8 KB) - added by aim 12 months ago.
VBox.log.3 Download (179.0 KB) - added by aim 12 months ago.
VBox.2.log Download (97.2 KB) - added by aim 11 months ago.
VBox.log.2.1 Download (125.8 KB) - added by aim 11 months ago.
VBox.log.2.2 Download (127.1 KB) - added by aim 11 months ago.
VBox.log.2.3 Download (134.4 KB) - added by aim 11 months ago.
Xorg.0.2.log Download (7.4 KB) - added by aim 11 months ago.
journalctl_log_with_iomem_relaxed.txt Download (85.9 KB) - added by aim 11 months ago.
dmesg_with_iomem_relaxed.txt Download (34.0 KB) - added by aim 11 months ago.
VBox.3.log Download (136.6 KB) - added by aim 11 months ago.
VBox.log.3.1 Download (126.7 KB) - added by aim 11 months ago.
test_arch32.vbox Download (8.4 KB) - added by aim 11 months ago.
test_arch32.vbox-prev Download (7.6 KB) - added by aim 11 months ago.

Change History

Changed 12 months ago by aim

Changed 12 months ago by aim

Changed 12 months ago by aim

Changed 12 months ago by aim

Changed 12 months ago by aim

comment:1 Changed 12 months ago by aim

4.0.16-5.1.0 does not work with

Linux xcart-aim-arch.crtdev.local 4.6.3-1-ARCH #1 SMP PREEMPT Fri Jun 24 21:37:08 CEST 2016 i686 GNU/Linux

as guest and Mac OS X as host

Last edited 12 months ago by aim (previous) (diff)

comment:2 Changed 12 months ago by michael

Could you please try installing the Additions using the official build from our web site<1>? If you use Additions built by someone else then we can't normally accept bug reports.

<1>  http://download.virtualbox.org/virtualbox/5.1.0/VBoxGuestAdditions_5.1.0.iso

comment:3 Changed 11 months ago by aim

I will try the iso this week.

By the way, may be related  https://forums.virtualbox.org/viewtopic.php?f=3&t=78427

Thank you.

Last edited 11 months ago by aim (previous) (diff)

comment:4 Changed 11 months ago by michael

Does the "iomem=relaxed"<1> kernel parameter make a difference for you as described on the forum posting? If so please look at your kernel/system logs to see if there are any relevant messages from the kernel.

<1>  https://lwn.net/Articles/302048/

comment:5 Changed 11 months ago by aim

I have installed the Additions using the official iso build

The result is the same (new logs attached)

[   175.615] (EE) open /dev/dri/card0: No such file or directory
[   175.620] (EE) AddScreen/ScreenInit failed for driver 0
[aim@xcart-aim-arch:pts/0][~]$ sudo ps -aux|grep VB
root       222  0.0  0.0      0     0 ?        S<   11:32   0:00 [iprt-VBoxWQueue]
root       459  0.0  0.0  32544  2540 ?        Sl   11:32   0:00 /usr/sbin/VBoxService --pidfile /var/run/vboxadd-service.sh
aim        590  0.0  0.0  17392  1532 ?        S    11:34   0:00 /usr/bin/VBoxClient --seamless
aim        596  0.0  0.0  17392  1696 ?        S    11:34   0:00 /usr/bin/VBoxClient --draganddrop
aim        705  0.0  0.0   6416  2408 pts/0    S+   11:37   0:00 grep VB
[aim@xcart-aim-arch:pts/0][~]$ sudo lsmod|grep -i "vbox\|virt"
vboxsf                 40960  1
vboxvideo              45056  0
ttm                    69632  1 vboxvideo
drm_kms_helper        110592  1 vboxvideo
drm                   249856  3 ttm,drm_kms_helper,vboxvideo
syscopyarea            16384  2 drm_kms_helper,vboxvideo
sysfillrect            16384  2 drm_kms_helper,vboxvideo
sysimgblt              16384  2 drm_kms_helper,vboxvideo
vboxguest             196608  3 vboxsf,vboxvideo
virtio_net             28672  0
virtio_pci             24576  0
virtio_ring            20480  2 virtio_net,virtio_pci
virtio                 16384  2 virtio_net,virtio_pci
[aim@xcart-aim-arch:pts/0][~]$ sudo lspci|grep -i vga         
00:02.0 VGA compatible controller: InnoTek Systemberatung GmbH VirtualBox Graphics Adapter
[aim@xcart-aim-arch:pts/0][~]$ ls -l /opt/VBoxGuestAdditions-5.1.0 
итого 68
drwxr-xr-x 2 root root  4096 июл 12 18:58 bin
drwxr-xr-x 2 root root  4096 июл 12 18:58 init
drwxr-xr-x 2 root root  4096 июл 19 11:23 installer
drwxr-xr-x 3 root root  4096 июл 12 18:59 lib
-rw-r--r-- 1 root root 20516 июл 12 18:58 LICENSE
-rwxr-xr-x 1 root root 11378 июл 19 11:23 routines.sh
drwxr-xr-x 2 root root  4096 июл 12 18:58 sbin
drwxr-xr-x 3 root root  4096 июл 12 18:58 share
drwxr-xr-x 3 root root  4096 июл 12 18:58 src
-rwxr-xr-x 1 root root  2943 июл 19 11:23 uninstall.sh
[aim@xcart-aim-arch:pts/0][~]$ 

Changed 11 months ago by aim

Changed 11 months ago by aim

Changed 11 months ago by aim

Changed 11 months ago by aim

Changed 11 months ago by aim

comment:6 Changed 11 months ago by aim

iomem=relaxed helps to run X11

I have attached two logs journalctl_log_with_iomem_relaxed.txt and dmesg_with_iomem_relaxed.txt

Changed 11 months ago by aim

Changed 11 months ago by aim

comment:7 Changed 11 months ago by aim

comment:8 Changed 11 months ago by aim

The same problem with 5.0.26 version

comment:9 Changed 11 months ago by michael

As far as I can see this only affects ArchLinux guests. It would be interesting if you could find examples of it happening with other guests (e.g. not the CentOS 7 issue where the user tried that together with a number of other things to fix an issue). If not, or if this is mainly an Arch issue, it would be helpful for me - and probably speed up looking at this - if you could find someone in the Arch community with an idea of what Arch might be doing differently there. Since installing an Arch guest is a bit of a longer process than e.g. Ubuntu it will probably be a while before I find time.

comment:10 Changed 11 months ago by aim

I will try to reproduce the issue on this public ready-to-use virtualbox-archlinux vdi image  http://www.osboxes.org/arch-linux/

Thank you for your help!

comment:11 Changed 11 months ago by aim

Dear Michael,

I have reproduced the problem using the stock ready-to-use public arch-linux VDI image on 5.0.26 Virtualbox

This is step-by-step

1) Download ready-to-use VirtualBox (VDI) 32bit KDE from here  http://www.osboxes.org/arch-linux/

2)Create a new 32-bit arch guest with empty HDD/SATA (config is attached, feel free to use it)

3)Connect the downloaded 'Arch Linux 20160501 (32bit).vdi' to the guest

4)run su; then

pacman -Syu 

in the guest. wait for the update

5)reboot (as you can see the X11 is running properly)

6)run su; then

pacman -S virtualbox-host-modules-arch virtualbox-guest-utils
systemctl enable vboxservice

7)reboot

As result X11 is broken with the same error message in X.org.log file

Should I replicate the problem using this iso  http://download.virtualbox.org/virtualbox/5.0.26/VBoxGuestAdditions_5.0.26.iso ?

Thank you.

Changed 11 months ago by aim

Changed 11 months ago by aim

Changed 11 months ago by aim

Changed 11 months ago by aim

comment:12 Changed 11 months ago by michael

By the way, have you also seen this with a 64-bit guest?

comment:13 Changed 11 months ago by aim

64-bit guest works correctly

comment:14 Changed 11 months ago by michael

  • Status changed from new to closed
  • Resolution set to wontfix
  • Summary changed from X11 does not work "addscreen/screeninit failed for driver 0 after upgrade from 4.0.16" to X11 does not work "addscreen/screeninit failed for driver 0 after upgrade from 4.0.16" -> won't fix

Reproduced it. You set 128MB of video RAM, and that is too much for the 32-bit kernel to cope with since our driver is not loaded in the very early boot process. I should probably fix this, but it is not important enough just now, since chances are you do not need that much.

This worked before because you were using X.Org with the user-space driver, now you have non-root X.Org and the kernel driver.

comment:15 Changed 11 months ago by aim

Thank you Michael.

comment:16 Changed 11 months ago by michael

  • Status changed from closed to reopened
  • Resolution wontfix deleted
  • Summary changed from X11 does not work "addscreen/screeninit failed for driver 0 after upgrade from 4.0.16" -> won't fix to X11 does not work "addscreen/screeninit failed for driver 0 after upgrade from 4.0.16" -> presumed fixed in releases higher than 5.1.2

And having said that... I took a closer look at this, not least because the code did not look all that nice, and I was afraid it might be the cause of other problems. So I hope it is now fixed in any Additions test builds<1> greater than revision 109119.

<1> https://www.virtualbox.org/wiki/Testbuilds

comment:17 Changed 11 months ago by michael

Additions test build revision 109126 contains an additional fix for a problem I found on the same guest with hangs on reboot. Dynamic resizing also fails on this guest...

comment:18 Changed 11 months ago by michael

The resizing was a regression from my previous fix, fixed in test build 109138<1>.

<1> https://www.virtualbox.org/wiki/Testbuilds

comment:19 Changed 10 months ago by frank

  • Status changed from reopened to closed
  • Resolution set to fixed

Fix is part of 5.1.4.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use