VirtualBox

Ticket #1562 (closed defect: fixed)

Opened 6 years ago

Last modified 6 years ago

VBox 1.6 clock goes to Jan 1 1970 and then back to current time. -> fixed in SVN/1.6.2

Reported by: kgardas Owned by:
Priority: major Component: other
Version: VirtualBox 1.6.0 Keywords: Solaris, OpenSolaris, clock
Cc: Guest type: other
Host type: other

Description

Hello, I'm running VBox 1.6 on SXDE 1/08 host. I've installed OpenSolaris 2008.05 guest and found interesting issue with a clock going back to Jan 1 1970 and then forward to the current time again. When I log output of following simple script:

while (true)
do
  date
  sleep 1
done

the output looks:

Fri May 16 20:34:05 CEST 2008
Fri May 16 20:34:06 CEST 2008
Fri May 16 20:34:07 CEST 2008
Fri May 16 20:34:08 CEST 2008
Thu Jan  1 01:00:00 CET 1970
Thu Jan  1 01:00:01 CET 1970
Thu Jan  1 01:00:02 CET 1970
Fri May 16 20:34:13 CEST 2008
Fri May 16 20:34:14 CEST 2008
Fri May 16 20:34:15 CEST 2008
Fri May 16 20:34:16 CEST 2008
Fri May 16 20:34:17 CEST 2008

Please also note that 1 second in guest == 1 second in host, so clock is not slow down.

My guest configuration is attached.

Karel

Attachments

OpenSolaris 2008.05.xml Download (3.0 KB) - added by kgardas 6 years ago.
OpenSolaris 2008.05 guest configuration file
VBox.log Download (31.1 KB) - added by kgardas 6 years ago.

Change History

Changed 6 years ago by kgardas

OpenSolaris 2008.05 guest configuration file

comment:1 Changed 6 years ago by kgardas

I've kept script above running for some time with redirection to file and it seems the clock issue happens quite often:

karel@silence:~$ grep "2008" /tmp/b2.txt |wc -l
     482
karel@silence:~$ grep "1970" /tmp/b2.txt |wc -l
      16
karel@silence:~$ 

this means 482 seconds tick was OK, while 16 was drifted to 1970 year.

Karel

comment:2 Changed 6 years ago by frank

Please attach the VBox.log file of such a VM session.

comment:3 Changed 6 years ago by ramshankar

I tried running the script on SNV_82 host and Indiana RC0 guest and I'm not able to reproduce this behaviour. I ran it with varying CPU loads on host and guest, and still nothing.

As frank mentioned the VBox.log might be useful.

comment:4 Changed 6 years ago by kgardas

Hi, so after first 150 seconds of running of script above I got 3 seconds where it went back to 1970 year. The log from this sessions is attached. Please let me know in case of any further questions.

Thanks, Karel

Changed 6 years ago by kgardas

comment:5 Changed 6 years ago by kgardas

Perhaps important note: I do have ntp running both in host and guest with a config:

$ cat /etc/inet/ntp.conf 
server cz.pool.ntp.org
driftfile /var/ntp/ntp.drift

comment:6 Changed 6 years ago by frank

Please never run ntp on the guest when the guest additions are installed. The additions provide a daemon which periodically synchronizes the guest time with the host time.

comment:7 Changed 6 years ago by kgardas

OK, I disabled ntpd, but the issue is still here. I've kept running testing script for some time (over the night) and it seems I got 68186 good date invocations and 1561 bad date invocations. Also please note that when I booted with ntpd disabled I've seen that time in guest is host time + 1 hour, probably thanks to timezone set in guest (central European summer time). Anyway, now, after running over the night and day, the time in guest and host are different by 1 minute (guest = host + 1 minunte). So it seems guest time is slowing down at least.

Is there anything I shall test or provide for you? Thanks! Karel

comment:8 Changed 6 years ago by kgardas

Small additional info. The host machine is Intel Q6600 + 6GB RAM. It runs besides normal engineering tasks 2 Linux based VirtualBoxes which are computing CPU intensive jobs and 3th virtual box is OpenSolaris which from time to time perform build of 3th party free software. This build usually fails with error probably because of jumping clock. See "karel opensolaris" buildbot here:  http://buildbot.darcs.net/buildbot-darcs/waterfall IIRC, Linux vboxes do not have host addition installed, but OpenSolaris' guest does.

comment:9 Changed 6 years ago by sandervl73

  • Summary changed from VBox 1.6 clock goes to Jan 1 1970 and then back to current time. to VBox 1.6 clock goes to Jan 1 1970 and then back to current time. -> fixed in SVN/1.6.2

Hopefully fixed in SVN.

comment:10 Changed 6 years ago by kgardas

Could you be so kind and point me out where exactly? i.e. I'm not able to find out the changeset in  http://www.virtualbox.org/timeline. Thanks!

comment:11 Changed 6 years ago by frank

Of course. This is changeset r9088 .

comment:12 Changed 6 years ago by davidlee010

This is great! Thanks for the fix. I have experienced my ORACLE server crashing due to invalid time error intermittenly, on OpenSolaris2008.5 and Solaris 10.

How can I get this fix for my 1.6 installation on Mac OSX? Do I need to wait for the next release? Is there a way to patch this fix on 1.6? I'm with the SOA/BI team in California, and I desperately need this to work for demos I'm building. Please help!

comment:13 Changed 6 years ago by sandervl73

  • Status changed from new to closed
  • Resolution set to fixed

Wait a day or two more for 1.6.2.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use