VirtualBox

Ticket #15617 (closed defect: fixed)

Opened 3 years ago

Last modified 11 months ago

VB 5.1.0 File > Preferences crash on Mac OS 10.11 (Karabiner, Qt bug)

Reported by: MatrixNathan Owned by:
Component: GUI Version: VirtualBox 5.1.0
Keywords: crash preferences 5.1.0 5.1 el capitan 10.11 10.11.3 Cc:
Guest type: other Host type: Mac OS X

Description

Hi,

I am running Mac OS 10.11.3 and have upgraded VirtualBox from 5.0.24 to 5.1.0. When trying to open global VirtualBox preferences via VirtualBox.app > File > Preferences, VirtualBox crashes due to a segfault. Emptying ~/Library/VirtualBox and relaunching with a new profile does not help. This issue was not present in VB 5.0.24.

This issue occurs with the old 5.0.24 extension pack installed and the latest version of the extension pack (installed via VBoxManage extpack).

Let me know if you need other information. I've not included VBox.log files as this happens irrespective of if VMs have been running or not.

Thanks,

Nathan

Attachments

VirtualBox_2016-07-17-203921_cacbook.crash.log Download (59.9 KB) - added by chrstphrchvz 3 years ago.
crash log after opening preferences

Change History

Changed 3 years ago by chrstphrchvz

crash log after opening preferences

comment:1 Changed 3 years ago by chrstphrchvz

Hi Nathan,

I had encountered this issue during the prerelease versions of 5.1 as well (posted on the forum, but didn't get any replies:  https://forums.virtualbox.org/viewtopic.php?f=15&t=78315). I am running OS X 10.11.5.

I have attached a crash log for 5.1 RELEASE. From the stack traces, it looks like it might have something to do with the Qt GUI, but I'm not certain. I also tried removing the VirtualBox user preferences, although I haven't yet reproduced the issue using another user account.

comment:2 Changed 3 years ago by MatrixNathan

Thanks for the reply and grabbing the crash log, forgot to include it with my original post (doh!).

I think you are right about it being a Qt issue, I'm seeing flickering when clicking in the manager interface (Details / Snapshots buttons appear next to New / Settings / Discard / Start buttons then jump to the right). There's also problems with the VM settings header icons disappearing when editing settings (e.g. base memory), they become visible on hover with the mouse.

Thanks for the Qt pointer as I've found a fix, saved window states in ~/Library for the VirtualBox manager app are causing the issue. Remove any files / folders named org.virtualbox* from ~/Library -

find $HOME/Library -iname 'org.virtualbox*' -exec rm -rv "{}" +

Happy to mark this as a workaround / for inclusion in some sort of first run code after 5.1 upgrade for other Mac users.

Last edited 3 years ago by MatrixNathan (previous) (diff)

comment:3 Changed 3 years ago by MatrixNathan

P.S. VirtualBox Manager stability is much better with the above (I'm able to get into VirtualBox preferences) but crashes still happen occasionally. Resetting the VirtualBox window state with the above command fixes for the next run. I'm able to use my existing ~/Library/VirtualBox folder, a new folder still suffers with (fewer) sporadic crashes.

comment:4 Changed 3 years ago by MatrixNathan

Seems the crashes are intermittent and the removal of org.virtualbox.* folders is not a fix. VirtualBox Manager crashes when launching preferences and deletion of files / folders and ~/Library/VirtualBox (excluding VirtualBox.xml) does not help.

Removal of global Qt preferences ~/Library/Preferences/com.trolltech.plist does not fix.

Last edited 3 years ago by MatrixNathan (previous) (diff)

comment:5 Changed 3 years ago by Santosh Kumar

I cannot reproduce the issue on OS X 10.11.6, but looking at the crash-log it seems to be a issue with Qt accessibility code. There is a related Qt bug here  https://bugreports.qt.io/browse/QTBUG-49907. Could you please let me know your host accessibility settings (System preferences->Accessibility and Security&privacy->Accessibilty) settings?

comment:6 follow-ups: ↓ 7 ↓ 8 Changed 3 years ago by MatrixNathan

Disabling Karabiner_AXNotifier under Security & Privacy > Accessibility has resolved the issue. Looks like this is an upstream issue with Qt. Thanks for investigating and for finding the workaround!

comment:7 in reply to: ↑ 6 Changed 3 years ago by chrstphrchvz

Replying to MatrixNathan:

Disabling Karabiner_AXNotifier under Security & Privacy > Accessibility has resolved the issue. Looks like this is an upstream issue with Qt. Thanks for investigating and for finding the workaround!

I also have Karabiner installed, so the same workaround applies for me. Thanks Santosh!

comment:8 in reply to: ↑ 6 Changed 3 years ago by wesm

Replying to MatrixNathan:

Disabling Karabiner_AXNotifier under Security & Privacy > Accessibility has resolved the issue. Looks like this is an upstream issue with Qt. Thanks for investigating and for finding the workaround!

I also have Karabiner installed, and I've confirmed this workaround applies. This hardly seems like an issue with AXNotifier. OSX 10.11.6 (15G31) VirtualBox 5.1.2 r108956

comment:9 Changed 3 years ago by m1st0

After I shared the problem with Karabiner developers, a beta version seems to have resolved the issue. Please follow up here to test the beta version 10.21.6 and report any further crashes.

 https://groups.google.com/forum/#!searchin/osx-karabiner/virtualbox%7Csort:relevance/osx-karabiner/vZ2xek9gZpE/wQCTOCB2BwAJ

comment:10 Changed 3 years ago by frank

So will be probably also fixed once we upgrade to Qt 5.6 (currently using 5.5 on Mac OS X).

comment:11 Changed 3 years ago by frank

  • Summary changed from VB 5.1.0 File > Preferences crash on Mac OS 10.11 to VB 5.1.0 File > Preferences crash on Mac OS 10.11 (Karabiner, Qt bug)

comment:12 Changed 3 years ago by DKroot

I had the same issue and can confirm a resolution with Karabiner 10.21.8 (beta)

comment:13 Changed 11 months ago by chrstphrchvz

VirtualBox has been using Qt 5.6(.3?) on Mac for some time. I think this ticket can be closed, though unfortunately this issue was never mentioned as resolved in the changelogs.

Note that the last OS Karabiner worked on (10.11 El Capitan) is now considered unsupported. (macOS 10.12 and later can use Karabiner-Elements instead.)

comment:14 Changed 11 months ago by gombara

  • Status changed from new to closed
  • Resolution set to fixed

It seems like this issue has been long resolved.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use