VirtualBox

Ticket #15611 (closed defect: fixed)

Opened 9 months ago

Last modified 7 months ago

No sound in OSX guests after 5.1

Reported by: socratis Owned by:
Priority: major Component: audio
Version: VirtualBox 5.1.0 Keywords:
Cc: Guest type: OSX Server
Host type: Mac OS X

Description

All OSX clients show that there is no sound output with 5.1.0_RC1 and later (maybe even earlier in the 5.1b series, didn't notice). In the Sound panel of the System Preferences, the following can be seen:

  • 5.1.0 --> Output: Digital Out, Input: Line in, Internal microphone.
  • 5.0.24 --> Output: Internal Speakers, Input: Line in, Internal microphone.

The audio settings for the VM are: CoreAudio, Intel HDA.

Host: MacBookPro 17", early 2011. OSX 10.9.5.

Attachments

VBox-5.0.24.log.zip Download (27.7 KB) - added by socratis 9 months ago.
VBox.log for a session with a 10.9 guest. VBox 5.0.24.
VBox-5.1.0.log.zip Download (30.1 KB) - added by socratis 9 months ago.
VBox.log for a session with a 10.9 guest. VBox 5.1.0.
VBox.log Download (142.6 KB) - added by dinosaur0 8 months ago.

Change History

Changed 9 months ago by socratis

VBox.log for a session with a 10.9 guest. VBox 5.0.24.

Changed 9 months ago by socratis

VBox.log for a session with a 10.9 guest. VBox 5.1.0.

Changed 8 months ago by dinosaur0

comment:1 Changed 8 months ago by dinosaur0

Same problem with HD audio here, but under Linux + OSS HD audio drivers. I just updated to v5.1, and on the systems running Linux + OSSv4 (the true OSS, not the few leftovers in the Linux kernel),VirtualBox reports a failure to initialize the host sound.

I get a dialog on the VM startup, saying:

Some HDA audio streams (PCM Input) could not be opened. Guest applications generating audio output or depending on audio input may hang. Make sure your host audio device is working properly. Check the logfile for error messages of the audio subsystem.

ID de l'erreur : HostAudioNotResponding

Sévérité : Avertissement

I also attached a file corresponding to the log for the above VM error, the relevant lines in that log being, apparently:

00:00:00.851952 OSS: Failed to retrieve buffer length: Opération non supportée (95)

00:00:00.851963 OSS: Closing stream failed: Mauvais descripteur de fichier

Which Translate to "unsupported operation" and "bad file descriptor".

Last edited 8 months ago by dinosaur0 (previous) (diff)

comment:2 Changed 8 months ago by taidoka

Hi there,
I've got (almost) the same issue: Running XP within VBox v5.1.2 on an OSX 10.11.6 host.
When starting the VM I receive exactly the same error.
Audio settings are: Core Audio + ICH AC97
Output: Internal Speakers, Input: Line in, Internal microphone.
Audio used to work on v5.1.0 which was a fresh install on an iMac (Early 2009).
All the best, taidoka

Last edited 8 months ago by taidoka (previous) (diff)

comment:3 Changed 8 months ago by socratis

@dinosaur0, @taidoka

Actually you are both describing of a different bug introduced in 5.1.2. See ticket #15659.

Last edited 8 months ago by socratis (previous) (diff)

comment:4 follow-up: ↓ 5 Changed 8 months ago by josefcarel

I have had the same problem with different linux distros (Opensuse, ubuntu 16.04) and Windows 10. Sound doesn't work at all.

comment:5 in reply to: ↑ 4 Changed 8 months ago by socratis

Replying to josefcarel:

I have had the same problem with different linux distros (Opensuse, ubuntu 16.04) and Windows 10. Sound doesn't work at all.

I'm sorry, but this is a bug about OSX guests on OSX hosts. Not about not having sound, but about the guest showing different output options. My Linux guests are working just fine. Maybe there is a more fitting bug for your problem?

comment:6 Changed 8 months ago by pedelar

I have the same problem using VBox v5.1.3, r109189 on an 15" MBP OS-X 10.11.6 (El Capitan) host with Windows 10Pro. Sound doesn't work at all. No way to solve this issue after doing many changes in more than a week. What to do?.

comment:7 Changed 8 months ago by socratis

@pedelar
No, you do NOT have the same problem. You didn't even read the problem. The only thing in common that you have is no sound. Read comment:3, right above yours. What you most probably have is a case of bug #15659. Maybe you don't get a warning because you elected to not show it again.

comment:8 Changed 8 months ago by frank

The latest 5.1 test builds should re-enable the sound for Mac OS X guests.

comment:9 Changed 8 months ago by socratis

In theory it works, for a couple of builds now. I see "Internal Speakers" as the Output. However due to #15659 I can't actually test it. But all the signs are correct, like the volume control being enabled for example.

comment:10 Changed 8 months ago by dark_sylinc

Ubuntu 16.04 host ANY guest PulseAudio device

I can confirm the problem is not present in VirtualBox-5.1.0-108711-Linux_amd64 but it is present in virtualbox-5.1_5.1.2-108956-Ubuntu-xenial_amd64

This topic has a lot of information  https://forums.virtualbox.org/viewtopic.php?f=7&t=78797

(haven't tested the test build mentioned above. I'm not in a position to use the test build unfortunately)

Last edited 8 months ago by dark_sylinc (previous) (diff)

comment:11 Changed 8 months ago by socratis

@dark_sylinc I'm sorry, but I don't think that this is the bug you're looking for. This is for OSX Guests on OSX Hosts (obviously) mis-identifying the Audio Output options, and it seems to be fixed. Maybe you should look more carefully about a bug that applies to your case?

comment:12 Changed 8 months ago by Mr.T

same problem here
Just to be clear this problem occurs in ALL types of guests (OSX, linux and windows) on a OSX host.

00:00:00.797734 Audio: Initializing Core Audio driver
00:00:00.822266 Audio: Initializing VRDE driver
00:00:00.822292 AC97: Reset
00:00:00.822484 CoreAudio: Using recording device: Built-in Input (UID: AppleHDAEngineInput:1B,0,1,0:4)
00:00:00.831145 CoreAudio: Using recording device: Built-in Input (UID: AppleHDAEngineInput:1B,0,1,0:4)
00:00:00.834218 AC97: WARNING: Unable to open PCM output for LUN #0!
00:00:00.834232 VM: Raising runtime error 'HostAudioNotResponding' (fFlags=0x0)
00:00:00.834246 Console: VM runtime error: fatal=false, errorID=HostAudioNotResponding message="Some AC'97 audio streams (PCM Output) could not be opened. Guest applications generating audio output or depending on audio input may hang. Make sure your host audio device is working properly. Check the logfile for error messages of the audio subsystem"

Last edited 8 months ago by Mr.T (previous) (diff)

comment:13 Changed 8 months ago by socratis

@Mr. T
This is not the problem described in this thread. You're looking for another bug, #15659. Please post your comment there.

comment:14 Changed 7 months ago by socratis

This should be closed per the 5.1.4 release notes.

comment:15 Changed 7 months ago by frank

  • Status changed from new to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use