VirtualBox

Ticket #1545 (closed defect: fixed)

Opened 6 years ago

Last modified 6 years ago

Hardy Heron installs KVM by default, crashes VB 1.6 -> fixed in SVN/1.6.2

Reported by: WildSubnet Owned by:
Priority: major Component: other
Version: VirtualBox 1.6.0 Keywords: kvm system crash
Cc: Guest type: other
Host type: other

Description

VB 1.6 causes Hardy Heron to lock up under Hardy Heron because the kvm module is installed by default in this version of Ubuntu. Even if the virtual machine is not using CPU extensions, running virtualbox hangs the entire system.

At a minimum the program should warn the user that kvm is loaded and refuse to start. Even better would be for the cpu extensions option to greyed out and virtualbox play nice with KVM.

I hand removed the modules a couple of times, but certain updates put them back in. This is expected behavior as KVM is the default virtualization tool in Hardy.

Change History

comment:1 Changed 6 years ago by sandervl73

  • Summary changed from Hardy Heron installs KVM by default, crashes VB 1.6 to Hardy Heron installs KVM by default, crashes VB 1.6 -> fixed in SVN/1.6.2

Already fixed, but it's rather stupid of the Ubuntu folks to enable it by default given that it prevents any other virtualization software from working.

comment:2 Changed 6 years ago by WildSubnet

I don't have enough knowledge to say whether it is "stupid" or not, but I am curious as to why KVM causes so much trouble even if the module is not being used.

comment:3 Changed 6 years ago by michael

The problem is that the kernel module "does things" to the system (i.e. plays around with hardware virtualisation settings in the CPU) as soon as it is loaded, even if it is not used.

comment:4 Changed 6 years ago by sandervl73

  • Status changed from new to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use