VirtualBox

Ticket #15354 (closed defect: fixed)

Opened 19 months ago

Last modified 17 months ago

Xorg doesn't start when User Password is not set on Ubuntu -> fixed in versions greater than 5.0.20

Reported by: Aweman Owned by:
Priority: major Component: other
Version: VirtualBox 5.0.18 Keywords:
Cc: Guest type: other
Host type: other

Description

Host: Windows 10 - 64bit (10586.218) Guest: Ubuntu 16.04 - 64bit Virtualbox: 5.0.18 with 5.0.18_106667 Additions

Hello,

my normal settings for User Accounts in Ubuntu are: I use a password and automatic Login (Screenshot 1.jpg) For test reasons i deleted my password and switched automatic login off (Screenshot 2.jpg)

After a Ubuntu restart with these settings the Xorg Server didn't come up any more. After I uninstalled the Guest Additions from the terminal the Xorg Server started again.

I reproduced the behaviour a few times. With no password and automatic login off and the guest additions installed, I can not start Ubuntu.

Attachments

1.jpg Download (32.7 KB) - added by Aweman 19 months ago.
2.jpg Download (35.3 KB) - added by Aweman 19 months ago.
VBox.log Download (341.7 KB) - added by Aweman 19 months ago.
Xorg.0.log Download (8.7 KB) - added by Aweman 19 months ago.

Change History

Changed 19 months ago by Aweman

Changed 19 months ago by Aweman

Changed 19 months ago by Aweman

Changed 19 months ago by Aweman

comment:1 Changed 19 months ago by michael

I can't reproduce this with the latest<1> Additions - could you give them a try?

<1> Testbuilds

comment:2 Changed 19 months ago by michael

  • Summary changed from Xorg doesn't start when User Password is not set on Ubuntu to Xorg doesn't start when User Password is not set on Ubuntu -> presumed fixed in versions greater than 5.0.20

Reproduced something similar - the latest Additions test build<1> should fix it, though I would appreciate confirmation.

<1> Testbuilds

comment:3 Changed 19 months ago by Aweman

Yes. The thing you fixed, works for me too!!

Thanks a lot

comment:4 Changed 19 months ago by michael

  • Summary changed from Xorg doesn't start when User Password is not set on Ubuntu -> presumed fixed in versions greater than 5.0.20 to Xorg doesn't start when User Password is not set on Ubuntu -> fixed in versions greater than 5.0.20

Thank you for confirming.

comment:5 Changed 17 months ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Fixed in 5.0.22.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use