VirtualBox

Ticket #153 (closed enhancement: duplicate)

Opened 7 years ago

Last modified 5 years ago

Direct3D support

Reported by: nathanmx Owned by:
Priority: major Component: other
Version: VirtualBox 1.3.6 Keywords:
Cc: Guest type: other
Host type: other

Description

The video card driver does not support Direct3D. If, in Windows XP, you goto Start->Run and type in dxdiag.exe You will see that Direct3D is available.

Change History

comment:1 Changed 7 years ago by akrus

Actually it's not implemented anywhere yet :) I think it's not that simple actually... but would be really nice.

comment:2 Changed 7 years ago by Reiner030

Perhaps there is a change to similar pass through the DirectX commands to the native video driver on the host?

In full windows mode it should be easy... in a window it could be a little tricky...

comment:3 Changed 7 years ago by wolfger

Just grabbed VirtualBox yesterday, and discovered this problem today. Without Direct3D support, VirtualBox is worthless to me. With it, I'd be willing to pay quite a bit for it. It's a shame, because you guys have done such a fantastic job with this software. Very user friendly, and *much* faster than qemu.

comment:4 Changed 7 years ago by SauronSLO

If you need Direct3D then you can try VMware Workstation. In VMware you can enable Direct3D, it's not working perfectly, but you can try it and see if it's good for you.

I hope they will add support for DirectDraw and Direct3D in VirtualBox soon.

comment:5 Changed 7 years ago by Technologov

3D Acceleration Support and why it wont happen anytime soon:  http://www.virtualbox.org/discussion/1/615

comment:6 Changed 7 years ago by sandervl73

  • Status changed from new to closed
  • Resolution set to duplicate

Duplicate of #475

comment:7 Changed 5 years ago by rmh

#475 is for OpenGL. More about Direct3D can be found at  http://www.virtualbox.org/ticket/2940

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use