VirtualBox

Ticket #15186 (closed defect: fixed)

Opened 13 months ago

Last modified 13 months ago

Solaris 11.3 - Adobe Flash Player 20 - VM reset/crash

Reported by: Finsterstern Owned by:
Priority: major Component: other
Version: VirtualBox 5.0.14 Keywords: adobe flash player
Cc: Guest type: Windows
Host type: Solaris

Description

Since the update from VirtualBox 5.0.8 to 5.0.10 the VM reboots or crashes immediately, if the Adobe Flash Player starts with video playback in the Firefox web browser (e.g. when calling this site:  http://wwwns.akamai.com/hdnetwork/demo/flash/default.html).

The attached log files are from two different AMD based computers running Oracle Solaris 11.3 as host system and MS Windows 10 Professional 64 Bit running in VirtualBox 5.0.14 + installed Guest Additions as guest system and Firefox 44.0.2 with Adobe Flash Player 20.0.0.306 as participated applications.

Some additional information:

  • With the integrated Flash Player in the MS Edge browser the problem does not occur.
  • The problem occurs with a Windows 7 guest system and with older versions of Firefox and Adobe Flash Player too.

Attachments

VBox.logs.zip Download (43.7 KB) - added by Finsterstern 13 months ago.
VBox.log_working.zip Download (22.4 KB) - added by Finsterstern 13 months ago.
log file of working case (VBox 5.0.8)

Change History

Changed 13 months ago by Finsterstern

comment:1 Changed 13 months ago by frank

Any change if you disable AVX with

VBoxManage setextradata VM_NAME "VBoxInternal/CPUM/IsaExts/AVX" 0

and restart your VM?

comment:2 Changed 13 months ago by Finsterstern

Sadly no change with AVX disabled for the guest system on both of my PCs.

comment:3 Changed 13 months ago by Finsterstern

It seems, my problem is exactly the same as described in the comments of #14831 (and perhaps #15155).

comment:4 Changed 13 months ago by frank

Thanks. Could you also attach a VBox.log file for the working case (VBox 5.0.8)? It seems that the common denominator is

  1. this problem was introduced with VBox 5.0.10
  2. this problem occurs only on AMD CPUs.

comment:5 Changed 13 months ago by frank

Oh, and do you see the same problem if you run VBox 5.0.14 together with installed 5.0.8 Guest Additions?

Changed 13 months ago by Finsterstern

log file of working case (VBox 5.0.8)

comment:6 Changed 13 months ago by Finsterstern

I have added a log file for the working case (VBox.log_working.zip).

I agree with the common denominator (VBox 5.0.10, AMD CPU, Flash Player).

I have tried different VBox/Guest Additions combinations:

VBox Guest Additions Result
5.0.8 5.0.8 ok
5.0.8 5.0.14 ok
5.0.14 5.0.8 error
5.0.14 5.0.14 error

comment:7 Changed 13 months ago by frank

Thank you for these tests! Finally we are able to reproduce the problem. We are investigating...

comment:8 Changed 13 months ago by frank

We think we fixed the problem. The most recent 5.0 Solaris test build includes the fix. Could you confirm that it works for you?

comment:9 Changed 13 months ago by Finsterstern

Successfully tested on both of my AMD PCs with test build 5.0.15 revision 105805.

Thank you very much for fixing this issue!

comment:10 Changed 13 months ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Fix is part of VBox 5.0.16.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use