VirtualBox

Ticket #15055 (closed defect: fixed)

Opened 17 months ago

Last modified 16 months ago

dkms and rcvboxdrv are not working in 5.0.14 -> believed fixed in releases higher than 5.0.14

Reported by: StephaneCharette Owned by:
Priority: major Component: installer
Version: VirtualBox 5.0.14 Keywords:
Cc: Guest type: all
Host type: Linux

Description

Host is 64-bit Ubuntu 15.10. I do have DKMS installed. Upgraded today from VB 5.0.12 to 5.0.14.

Note there was a linux kernel update available in the last 24 hours, so when I upgraded VB, I noticed it upgraded the linux kernel as well.

Now when my host boots back up, VB guests wont start. It pops up a message box saying to run /sbin/rcvboxdrv setup. But when I try to run that command, even with sudo, it exits with Bad argument setup.

Attachments

screenshot.png Download (233.4 KB) - added by StephaneCharette 17 months ago.
screenshot showing the command I'm told to run but which doesn't work

Change History

Changed 17 months ago by StephaneCharette

screenshot showing the command I'm told to run but which doesn't work

comment:1 Changed 17 months ago by StephaneCharette

Found a manual workaround on the forum. Instead of running this as instructed by VB:

sudo /sbin/rcvboxdrv setup

...try this:

sudo /usr/lib/virtualbox/vboxdrv.sh setup

comment:2 Changed 17 months ago by StephaneCharette

Title contains a typo, but I cannot change it. I meant DKMS, not DKRM.

comment:3 Changed 17 months ago by michael

  • Summary changed from dkrm and rcvboxdrv are not working in 5.0.14 to dkms and rcvboxdrv are not working in 5.0.14 -> believed fixed in releases higher than 5.0.14

This should be fixed in the current test builds<1>. And I fixed the mis-type in the title, thank you.

<1> Testbuilds

comment:4 Changed 17 months ago by frank

Someone please confirm the fix, thank you!

comment:5 Changed 17 months ago by adam r

Reverting the previous version of the /sbin/rcvboxdrv fixes this particular the problem, but may introduce other bugs. See  http://askubuntu.com/questions/724184/virtualbox-rcvboxdrv-setup-error-bad-argument-setup for content of this file.

comment:6 Changed 17 months ago by michael

Adam, did you try a test build?

comment:7 Changed 17 months ago by rvelaz

Do you have an ETA on when a fix is going to be released?

comment:8 Changed 17 months ago by frank

The above mentioned test builds contain the fix. And the next 5.0.x maintenance release will contain the fix (no ETA). As furthemore written about, doing

sudo /usr/lib/virtualbox/vboxdrv.sh setup

will work as well, even if you didn't install a test build and the maintenance update is not available yet.

comment:9 Changed 16 months ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Fix is part of VBox 5.0.16.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use