VirtualBox

Ticket #15042 (reopened defect)

Opened 21 months ago

Last modified 21 months ago

Can't attach USB device Microchip MPLAB Real Ice

Reported by: Attylus76 Owned by:
Priority: major Component: USB
Version: VirtualBox 5.0.12 Keywords:
Cc: attylus@… Guest type: Windows
Host type: Windows

Description

Failed to attach Microchip MPLAB Real Ice to the VM Windows XP SP3

USB device 'Microchip Technology, Inc. (www.microchip.com) MPLAB® REAL ICE tm (www.microchip.com)' with UUID {30576387-492f-41fa-862e-c9b593202bde} is busy with a previous request. Please try again later. Codice 'uscita: E_INVALIDARG (0x80070057) Componente: HostUSBDeviceWrap Interfaccia: IHostUSBDevice {c19073dd-cc7b-431b-98b2-951fda8eab89} Chiamante: IConsole {872da645-4a9b-1727-bee2-5585105b9eed}

Change History

comment:1 Changed 21 months ago by frank

This error message means that this USB device is claimed+locked by the host. If a USB device is used by the host, it cannot be used by the guest at the same time.

comment:2 Changed 21 months ago by frank

Manually adding the comment which the OP wrote by e-mail. Please use the web interface to add comments to tickets!

I do not think that's the problem. The error occurs only when the device name is too long. On the web I found a workaround that allows you to use these devices.

The procedure is as follows:

  1. Connect the device to a USB
  2. Enter in the USB settings> Filters USB devices and add the device.
  3. Change the name of the device (eg. MPLAB REAL ICE [100])
  4. Eliminate manufacturer name and product name
  5. Now disconnett the USB device
  6. Starts the machine VM
  7. Connect the USB device and this is now recognized

comment:3 Changed 21 months ago by Attylus76

Good morning Frank,

it is the first time that use the service. Thanks for your advice!

comment:4 Changed 21 months ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Hopefully fixed with VBox 5.0.14. Please re-open this ticket if you still experience problems with VBox 5.0.14.

comment:5 Changed 21 months ago by Attylus76

Good morning Frank,

First I wanted to thank you for having taken charge of my report. This morning I immediately downloaded the new version 5.0.14 but unfortunately it seems that the problem is still present. I state that I have upgraded both the VirtualBox Extension Pack.

I can give you a few more details on the behavior of VirtualBox hoping to help you.

Starting with a clean condition PC 8.1 windows just started and no device attached.

  1. Start the VM with Windows XP
  2. Attack the MPLAB Real ICE
  3. I see that the device appears in the "USB Settings ..." I tell him to capture it tells me that has been captured but not enabled the flag.
  4. If I try again to capture it gives me the error reported.

I also noticed that if ex MPLAB Real ICE the device remains in the list of USB Settings which does not happen with other devices. It is not removed even by restarting the VM.

The only solution is to reboot your machine Host

Greetings

comment:6 Changed 21 months ago by quadrantica

I think we are far from closing this bug!

I have the same ISSUE with VirtualBox 5.0.14 on Windows 10 64bit host and any kind of guest system spanning from linux to windows, but with Microchip ICD3 In Circuit Debugger.

Failed to attach the USB device Microchip Technology, Inc. (www.microchip.com) MPLAB® ICD3 tm (www.microchip.com) [0100] to the virtual machine sauro-xp3.

USB device 'Microchip Technology, Inc. (www.microchip.com) MPLAB® ICD3 tm (www.microchip.com)' with UUID {2a3f82da-206d-4e17-938d-29c9e63ab76d} is busy with a previous request. Please try again later.

Result Code: E_INVALIDARG (0x80070057) Component: HostUSBDeviceWrap Interface: IHostUSBDevice {c19073dd-cc7b-431b-98b2-951fda8eab89} Callee: IConsole {872da645-4a9b-1727-bee2-5585105b9eed}

comment:7 Changed 21 months ago by quadrantica

  • Status changed from closed to reopened
  • Resolution fixed deleted

Sorry, I think also this is to be reopened!

Greetings.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use