VirtualBox

Ticket #14986 (closed defect: duplicate)

Opened 6 years ago

Last modified 6 years ago

VBoxHeadless dumps core on 5.0.12 under fc22 - can't start Win8.1 guest

Reported by: iandekit Owned by:
Component: virtual disk Version: VirtualBox 5.0.12
Keywords: Cc:
Guest type: Windows Host type: Linux

Description (last modified by frank) (diff)

I upgraded from 5.0.8 to 5.0.12 along with an OS dnf update... kernel went from kernel-4.2.3-200.fc22.x86_64 to kernel-4.2.8-200.fc22.x86_64

This is for VirtualBox-5.0-5.0.12_104815_fedora22-1.x86_64

After this my Win8.1 guest OS would not start; showed Aborted in phpvirtualbox window.

Inspection of the kernel logs shows lots of these:

Dec 29 04:08:48 patriots kernel: EMT[9984]: segfault at 18 ip 00007ff6e8c10b41 sp 00007ff710985c60 error 4 in VBoxDD.so[7ff6e8b98000+278000]
Dec 29 04:08:48 patriots kernel: device em1 left promiscuous mode
Dec 29 04:08:48 patriots kernel: vboxnetflt: 0 out of 1 packets were not sent (directed to host)
Dec 29 04:08:55 patriots kernel: vboxdrv: ffffffffa05db020 VMMR0.r0
Dec 29 04:08:55 patriots kernel: vboxdrv: ffffffffa06d6020 VBoxDDR0.r0
Dec 29 04:08:55 patriots kernel: vboxdrv: ffffffffa0272020 VBoxDD2R0.r0
Dec 29 04:08:55 patriots kernel: VBoxNetFlt: attached to 'em1' / 00:21:28:bb:f3:7c
Dec 29 04:08:55 patriots kernel: vboxdrv: ffffffffa025b020 VBoxEhciR0.r0

followed by this (with #012# turned back into newlines)

Dec 29 03:20:35 patriots systemd-coredump: Process 5540 (VBoxHeadless) of user 0 dumped core.
012Stack trace of thread 5552:
0  0x00007f2bc9700b41 _ZL8hdaTimerP9PDMDEVINSP7TMTIMERPv (VBoxDD.so)
1  0x00007f2bfc31557e _ZL17tmR3TimerQueueRunP2VMP12TMTIMERQUEUE (VBoxVMM.so)
2  0x00007f2bfc319200 TMR3TimerQueuesDo (VBoxVMM.so)
3  0x00007f2bfc2b711f emR3ForcedActions (VBoxVMM.so)
4  0x00007f2bfc2bb0b9 emR3HmExecute (VBoxVMM.so)
5  0x00007f2bfc2b814f EMR3ExecuteVM (VBoxVMM.so)
6  0x00007f2bfc32248a _Z25vmR3EmulationThreadWithIdP11RTTHREADINTP6UVMCPUj (VBoxVMM.so)
7  0x00007f2c0466f84c rtThreadMain (VBoxRT.so)
8  0x00007f2c046ea7ac _ZL18rtThreadNativeMainPv (VBoxRT.so)
9  0x0000003798407555 start_thread (libpthread.so.0)
10 0x0000003797d02b9d __clone (libc.so.6)
012Stack trace of thread 5540:
0  0x0000003797cf9063 __select (libc.so.6)
1  0x00007f2bfccb00c7 _ZN3comL20waitForEventsOnXPCOMEP13nsIEventQueuej.constprop.0 (VBoxHeadless.so)
2  0x00007f2bfccb05fc _ZN3com16NativeEventQueue17processEventQueueEj (VBoxHeadless.so)
3  0x00007f2bfccaa741 TrustedMain (VBoxHeadless.so)
4  0x0000003797c20700 __libc_start_main (libc.so.6)
5  0x00000000004010f9 n/a (VBoxHeadless)
012Stack trace of thread 5559:
0  0x000000379840fc7d __nanosleep (libpthread.so.0)
1  0x00007f2c046eaca9 RTThreadSleepNoLog (VBoxRT.so)
2  0x00007f2bfc3df372 _ZL15pdmR3NsTxThreadP2VMP9PDMTHREAD (VBoxVMM.so)
3  0x00007f2bfc2dc30a _ZL15pdmR3ThreadMainP11RTTHREADINTPv (VBoxVMM.so)
4  0x00007f2c0466f84c rtThreadMain (VBoxRT.so)
5  0x00007f2c046ea7ac _ZL18rtThreadNativeMainPv (VBoxRT.so)
6  0x0000003798407555 start_thread (libpthread.so.0)
7  0x0000003797d02b9d __clone (libc.so.6)
012Stack trace of thread 5556:
0  0x000000379840c540 pthread_cond_wait@@GLIBC_2.3.2 (libpthread.so.0)
1  0x00007f2c046ed3b8 RTSemEventWait (VBoxRT.so)
2  0x00007f2c0466d538 RTReqQueueProcess (VBoxRT.so)
3  0x00007f2bf4d0e83e _ZN9guestProp7Service16threadNotifyHostEP11RTTHREADINTPv (VBoxGuestPropSvc.so)
4  0x00007f2c0466f84c rtThreadMain (VBoxRT.so)
5  0x00007f2c046ea7ac _ZL18rtThreadNativeMainPv (VBoxRT.so)
6  0x0000003798407555 start_thread (libpthread.so.0)
7  0x0000003797d02b9d __clone (libc.so.6)
012Stack trace of thread 5545:
0  0x000000379840c8e9 pthread_cond_timedwait@@GLIBC_2.3.2 (libpthread.so.0)
1  0x00007f2c046ed2f5 RTSemEventWait (VBoxRT.so)
2  0x00007f2bf78ed5c8 _ZN16VirtualBoxClient16SVCWatcherThreadEP11RTTHREADINTPv (VBoxC.so)
3  0x00007f2c0466f84c rtThreadMain (VBoxRT.so)
4  0x00007f2c046ea7ac _ZL18rtThreadNativeMainPv (VBoxRT.so)
5  0x0000003798407555 start_thread (libpthread.so.0)
6  0x0000003797d02b9d __clone (libc.so.6)
012Stack trace of thread 5544:
0  0x000000379840c8e9 pthread_cond_timedwait@@GLIBC_2.3.2 (libpthread.so.0)
1  0x00007f2bfca34dd4 pt_TimedWait (VBoxXPCOM.so)
2  0x00007f2bfca351fb VBoxNsprPR_WaitCondVar (VBoxXPCOM.so)
3  0x00007f2bfca35477 VBoxNsprPR_Wait (VBoxXPCOM.so)
4  0x00007f2bfc752985 _ZL10WaitTargetRK4nsIDjPP10ipcMessagePFjPvP13ipcTargetDataPKS2_ES5_ (VBoxXPCOMIPCC.so)
5  0x00007f2bfc752b5f _ZL15MakeIPCMRequestP10ipcMessagePS0_ (VBoxXPCOMIPCC.so)
6  0x00007f2bfc75338d _Z15IPC_SendMessagejRK4nsIDPKhj (VBoxXPCOMIPCC.so)
7  0x00007f2bfc758ff5 _ZN12DConnectStub10CallMethodEtPK15nsXPTMethodInfoP17nsXPTCMiniVariant (VBoxXPCOMIPCC.so)
8  0x00007f2bfca30ac4 PrepareAndDispatch (VBoxXPCOM.so)
9  0x00007f2bfca2ff2d SharedStub (VBoxXPCOM.so)

Tried 'dnf reinstall VirtualBox-5.0-5.0.12_104815_fedora22-1.x86_64' ; no better.

Went back to 5.0.8 on same kernel; all fine.

This hardware is a Sun X2270M2.

I have the same VirtualBox 5.0.12 and kernel 4.2.8-200.fc22.x86_64 running on other hardware (eg: X4-2, X4100M2)but with different (linux) guest OS's and they seem fine.

The appropriate matching extpacks were installed.

Attachments

trace.txt Download (3.3 KB) - added by iandekit 6 years ago.
backtrace, not munged by bug tracker editor

Change History

Changed 6 years ago by iandekit

backtrace, not munged by bug tracker editor

comment:1 Changed 6 years ago by frank

  • Description modified (diff)

comment:2 Changed 6 years ago by frank

The crash is related to HDA audio. Unfortunately you didn't attach the VBox.log file but I guess the initialization of the audio backend failed for some reason. The VBox.log file would tell this. Chose another audio backend or chose the NULL audio backend. And attach the VBox.log file of a crashed VM session.

comment:3 Changed 6 years ago by frank

  • Status changed from new to closed
  • Resolution set to duplicate

I think this is a duplicate of #14960.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use