VirtualBox

Ticket #14979 (new defect)

Opened 5 years ago

Last modified 3 years ago

mouse Lag on newer versions with DirectX games

Reported by: BryceSteiner Owned by:
Component: GUI Version: VirtualBox 5.0.12
Keywords: Cc:
Guest type: Windows Host type: Mac OS X

Description

Hello,

I love Virtualbox. I do use the newest version 5.0.12 for everything except games. My guest is Windows XP SP3 and (I can confirm this is the same for SP2) and in the games Age of Empires II and Medal of Honor (Breakthrough). Problem: Mouse lags a lot in the games. It makes it very difficult to play. I could provide a video if you want. The last version that works right is 4.3.26 and it works quite well (but I have to uncheck the box "Enable 2D acceleration") If there is some way I can help, please let me know. You really have one of the best products out there. If there is a way to donate, let me know too.

Change History

comment:1 Changed 5 years ago by frank

Virtualization of 3D needs quite some resources and a lag hints that the host is a bit overloaded. It often helps to disable the small preview window in the dock icon (use the context menu of the dock icon).

comment:2 Changed 4 years ago by calloc12

I can confirm this. Version 4 works fine, version 5 doesn't. It's definitely not a question of resources.

Environment:

  • Vbox 4.3.30 vs Vbox 5.1.4
  • Win XP guest, Mac OS 10.10.5 host
  • Guest additions installed, with D3D support
  • Baldur's Gate 2, Fallout 2

Until drivers are updated (so it's 5.1.4 host with 4.3.30 additions on guest), mouse lag is medium. When everything is updated to 5.1.4, lag becomes unbearable.

I also tried Win 7 guest with some earlier 5.1.x version (can't recall now), the result was the same.

Last edited 4 years ago by calloc12 (previous) (diff)

comment:3 Changed 3 years ago by Androprise

I can confirm that this is still an issue. I have tested this on the following host systems. In all cases I tried an XP (SP3) guest and a windows 7 (SP1) guest. The windows 7 guest was tried using basic Direct3D and WDDM Direct3D.

Host machine is Dell Precision T5500 with 2x Xeon-E5620, 20GB RAM, Nvidia Geforce Gt 610. The Ubuntu Host had proprietary Nvidia drivers installed, not using Nouveau.

I used to use an XP VM to play older SafeDisk games on Windows 10. I have now self-signed the SafeDisk driver and run them directly on the host due to this issue. There are no problems with the mouse cursor when running the game directly on the host (although there are some other issues).


Tested with following Host OS's and VirtualBox versions

  • Windows 10 Creators Update (15063.540)
  • Ubuntu 16.04.2 with Unity desktop
    • VirtualBox 5.0.18 (From xenial repo) - Problem Exists
    • VirtualBox 5.0.40 (From xenial-updates repo) - Problem Exists
    • VirtualBox 4.3.40 (From virtualbox.org) - No Problem
    • VirtualBox 5.1.26 (From virtualbox.org) - Problem Exists

Issue occurrs in the following games in both Windows 7 and XP:

  • Age of Empires
  • Age of Empires Rise of Rome Expansion
  • Age of Empires II The Age of Kings
  • Age of Empires II The Conquerors Expansion
  • Age of Mythology
  • Age of Mythology The Titans Expansion
  • Age of Empires III
  • Age of Empires III War Chiefs
  • Age of Empires III Asian Dynasties
  • Starfleet Command Orion Pirates (Unless running in windowed mode which uses native cursor)
  • Worms World Party

For each version of virtualbox used the extension pack for the same version was installed. The gues additions always matched the version of virtualbox in all tests and direct 3D support was enabled. The XP VM had 3D and 2D acceleration enabled and 128MB VRAM, the 7 (x64) VM had 3D and 2D acceleration enabled and 256MB VRAM. Both VM's had 2 CPU's and XP 2048MB RAM.Windows 7 had 4090 MB RAM.

NOTE: The issue also exists on my HP Pavilion-p051us on a windows 10 Host using Virtualbox 5.1.26.

Last edited 3 years ago by Androprise (previous) (diff)
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use