VirtualBox

Ticket #1493 (closed defect: fixed)

Opened 6 years ago

Last modified 5 years ago

Laptop problems with Ubuntu (7.10) Guest

Reported by: jc_hans Owned by:
Priority: major Component: other
Version: VirtualBox 1.6.2 Keywords: ubuntu, laptop, guest, frozen, keyboard, mouse,
Cc: Guest type: other
Host type: other

Description

Host System
Fujitsu Siemens Amilo Pa2510
Vista Home Premium (Dutch)
AMD Athlon X2 with an 1,8 GHz
2048 MB Ram
ATI X1200 with 128 MB Ram
Atheros AR5007 WAN
Integrated Mouse
Optional Sitecom Mouse

Problem Discribtion Since a couple of days I have a laptop and want to use it also for this kind of work (Virtualmachines). No problem at all when I'm running Win2k3 or XP, but when I'm starting Ubuntu 7.10 it will freeze at some point.

I can start the Virtualmachine were Ubuntu must start in. But when I pick the choice to go on with installation it will shut down any input device. Keyboard, Mouse and also the optional Sitecom Mouse ! Have this with 1.5.6 as well as 1.6.0. And as said earlier on this ain't a problem on the same system with Windows Guests.


P.S.: The support has become sh. I just took a look at the open tickets and that are many. I stopped with searching in the ticketbox because you can't get an easy overview in it. And the biggest problem of the support is that SUN won't help you at all. They distribute xVM 1.6.0 and there name is on it but no support from them... And just an easy contact mail from Innotek is gone. (Last time I used that I had solid and good support).

Attachments

VBox.log Download (27.5 KB) - added by jc_hans 6 years ago.
log from the machine were Ubuntu must run in
bug.txt Download (380 bytes) - added by jc_hans 6 years ago.
Error message I get when I add mine WAN as USB devince
VBox.2.log Download (24.7 KB) - added by jc_hans 6 years ago.
Ubuntu 7.10 @ xVM 1.6.2
VBox.3.log Download (24.5 KB) - added by jc_hans 6 years ago.
RedHat 9 @ xVM 1.6.2

Change History

comment:1 follow-up: ↓ 2 Changed 6 years ago by frank

Thanks for these charming notes. I like people complaining about bad support though they don't pay for anything.

To help debugging your problem you should attach the VBox.log file to this bugtracker issue. And the problem with input devices you are describing here sounds like you added an empty USB filter which matches to any USB device and therefore passes all your input devices to the guest -- making them unavailable for the host. Is that true? In that case, disable all USB filters at first and see if that changes something.

Changed 6 years ago by jc_hans

log from the machine were Ubuntu must run in

comment:2 in reply to: ↑ 1 ; follow-up: ↓ 3 Changed 6 years ago by jc_hans

Well hello I think I'm more or less in my rights here as customer. Okay I admit it's a bit easy to put on the negative hat. But see it in this way, at Innotek no problem with support or anything. Sun takes over and suddenly the support has been changed, and why ? Because it worked good ?

But over to the problem. I inserted a error message I got from Ubuntu itself when I had added the USB device that he see's (app. mine WAN hardware because my optional mouse is a different type of USB hardware). This message I'm only getting when I add the USB device when I'm not doing that Ubuntu will just get stuck. Besides that error I also added the Log you needed. Hopefully you can help me with having that. I will try it one more time in 1.6.0 tomorrow !

Replying to frank:

Thanks for these charming notes. I like people complaining about bad support though they don't pay for anything.

Changed 6 years ago by jc_hans

Error message I get when I add mine WAN as USB devince

comment:3 in reply to: ↑ 2 Changed 6 years ago by michael

Replying to jc_hans:

Well hello I think I'm more or less in my rights here as customer. Okay I admit it's a bit easy to put on the negative hat. But see it in this way, at Innotek no problem with support or anything. Sun takes over and suddenly the support has been changed, and why ? Because it worked good ?

Just a note: actually VirtualBox support for non-paying customers is still exactly as it was (basically all serious problems are dealt with as soon as possible and other issues as limited developer time permits). The innotek contact address was for sales queries, not for customer support (paying or otherwise). While support requests to it were dealt with on occasion, this was never a part of innotek policy.

Something else which has not changed is the excellent community support which has built up around VirtualBox. This is provided by many volunteers who offer excellent assistance to other VirtualBox users.

comment:4 Changed 6 years ago by jc_hans

Well then, you need to inform you people better because I had several mail messages all trough that same mail adress. But never mind rather or not it was the meaning or not. Let's get back on the problem I have now !

It's still not solved ! Any progress on my issue with Ubuntu in Virtualbox on my laptop !?

comment:5 Changed 6 years ago by frank

Please could you add a VBox.log file of a VM session taken with VirtualBox 1.6.2?

comment:6 Changed 6 years ago by jc_hans

I will do, after making first another comment:

I have the same problem on my laptop with BackTrack 3 and DSL (Linux). All get stuck at some point. Sometimes the OS keeps running but my input is getting stuck. So why don't you give it a try your self on a laptop with a linux distro...

Changed 6 years ago by jc_hans

Ubuntu 7.10 @ xVM 1.6.2

Changed 6 years ago by jc_hans

RedHat 9 @ xVM 1.6.2

comment:7 Changed 6 years ago by frank

You will be surprised but we already did that and we cannot reproduce your freezes here with our hardware. Something is different and we have to find out what. Maybe it's your AMD processor. To make sure: Did you search for BIOS updates in the web? We have several reports which could be fixed with a BIOS update.

comment:8 Changed 6 years ago by frank

  • Cc VirtualBox 1.5.6 removed
  • Version changed from VirtualBox 1.6.0 to VirtualBox 1.6.2

comment:9 Changed 6 years ago by jc_hans

I've updated the BIOS, and it comes further (in case of Ubuntu) but it still will get stuck. A friend of mine says that it has to do with the hardware, that Linux doesn't like it. But my standard desktop also kind off new hardware is no problem. Is it only the processor then that it doesn't like ?

My desktop has an Intel Pentium D, 2.8GHz and my laptop has the AMD Athlon 64 X2 TK-55.

comment:10 Changed 6 years ago by jc_hans

Yippi, I found the answer to the problem. So if anyone has the same troubles as me listen carefully:

First make sure you have tried the following option enabled: Under Virtualbox Preferences, General, Extended Features, Enable VTx / AMD V. This will support your AMD processor. If that doesn't work like it didn't work by me @ version 1.6.0 then take it to the next step: See if there is anything your systems needs to update, espacially BIOS update. (Make sure you have every data save). If then the OS still will not run as it should. Try the first option again. Now it should work 100%.

By me it was a combination of all 3 ! In 1.6.0 the option of VTx / AMD V didn't work. After BIOS update still no running from Ubuntu or any other Linux OS. Now after trying the VTx / AMD V option again it works. I don't know if this should be the case already without BIOS update, but it sure works for me now.

One point of negativity here. Sure Innotek / Virtualbox helped me looking at the BIOS but they should make sure they now the hardware. All the time I had the specs on top. I don't want to be an ass, but I always learned there are more way's towards Rome ! And so it was...

comment:11 Changed 6 years ago by jc_hans

...I sure hope they now there program well. But no hard feelings now please !

comment:12 follow-up: ↓ 13 Changed 6 years ago by frank

Please could you explain me the sentence ... but they should make sure they now the hardware. And what does that mean: I sure hope they now there program well? Please explain.

Regarding your problem: It is still strange that you are not able to install any guest without using hardware virtualization support. But as I said, it is very hard to debug such a problem without being able to reproduce it here ...

comment:13 in reply to: ↑ 12 Changed 6 years ago by jc_hans

Never mind, frustration... well obviously that's the only way I can make it work. Because Ubuntu 7.10 and also RedHat 9 are now no problems anymore and work fine. I guess it's the way it has to be, if you have and AMD 64 x2 TK-55 processor with 1.8GHz

Replying to frank:

Please could you explain me the sentence ... but they should make sure they now the hardware. And what does that mean: I sure hope they now there program well? Please explain.

Regarding your problem: It is still strange that you are not able to install any guest without using hardware virtualization support. But as I said, it is very hard to debug such a problem without being able to reproduce it here ...

comment:14 Changed 5 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Please reopen if this problem does still persist with a recent version of VirtualBox.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use