VirtualBox

Ticket #14915 (closed defect: fixed)

Opened 2 years ago

Last modified 17 months ago

Windows 10 fails to start if multiple CPU's are enabled (IA32_TSC_AUX)

Reported by: MOK Owned by:
Priority: major Component: VMM
Version: VirtualBox 5.0.10 Keywords: windows 10
Cc: Guest type: Windows
Host type: Linux

Description

On Intel Celeron (J1900) windows startup fails if I enable more than one cpu. Virtual machine starts, shows windows boot logo and nothing more happens. If I switch back to one cpu, startup works as normal - but it is desireable to give more power to the guest.

Current setup is: IO-APIC 1 Processor / 100% / PAE Hyper-V + VT-x + Nested Paging

Mem: 3500MB

graphics: 128MB / 3D / 2D

I already tried various settings on disabling 2D/3D, virtualisation features like Hyper-V (to none, minimal)

Attachments

win10-2015-12-10-12-03-31.log Download (144.1 KB) - added by MOK 2 years ago.
log with 1 cpu
VBox- Windows 10- 1 CPU.log Download (136.9 KB) - added by dasdandre 20 months ago.
Logfile- Windows 10 starting up fine with 1 CPU.
VBox - Windows 10-2 CPU stuck.log Download (102.6 KB) - added by dasdandre 20 months ago.
Windows 10 with 2 CPUs stuck at bootlogo. (Stucking starts at Line 1090)

Change History

Changed 2 years ago by MOK

log with 1 cpu

comment:1 Changed 2 years ago by frank

The reason could be: Matched host CPU INTEL 0x6/0x37/0x8 Intel_Atom_Silvermont with CPU DB entry 'Intel Atom 330 1.60GHz' (INTEL 0x6/0x1c/0x2 Intel_Atom_Bonnell)

comment:2 Changed 22 months ago by CosC

I have the same problem, but on Windows host.

CPU: Intel Celeron N2930 quad core 2 GHz. RAM: 4 GB VirtualBox version: 5.0.14 Host OS: Windows 8.1 x64 Guest OS: Windows 10 Pro x64

Same solution: only 1 processor.

If you think I should start a new ticket and/or if you want the logs, just let me know. Anyway, with so many tutorials on internet on how to install W10 in VB, I noticed there are quite a few users with the same problem (not just me or MOK). And this problem was reported 2 months ago...

comment:3 Changed 21 months ago by frank

CosC, please attach the VBox.log file of such a VM session. And please test with VBox 5.0.16.

Changed 20 months ago by dasdandre

Logfile- Windows 10 starting up fine with 1 CPU.

Changed 20 months ago by dasdandre

Windows 10 with 2 CPUs stuck at bootlogo. (Stucking starts at Line 1090)

comment:4 Changed 20 months ago by dasdandre

Same Problem here. Tested with 5.0.16. Windows installed fine with one CPU assigned. Changing to more than one CPU i'm getting stuck at the boot logo.

Linux:

# uname -a
Linux homeserver 4.2.0-34-generic #39-Ubuntu SMP Thu Mar 10 22:13:01 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux

Virtualbox:

# vboxmanage -v
5.0.16r105871

CPU Info (some kind of simmilar to CosC):

# lscpu 
Architecture:          x86_64
CPU op-mode(s):        32-bit, 64-bit
Byte Order:            Little Endian
CPU(s):                4
On-line CPU(s) list:   0-3
Thread(s) per core:    1
Core(s) per socket:    4
Socket(s):             1
NUMA node(s):          1
Vendor ID:             GenuineIntel
CPU family:            6
Model:                 76
Model name:            Intel(R) Celeron(R) CPU  N3150  @ 1.60GHz
Stepping:              3
CPU MHz:               2165.865
CPU max MHz:           2165,8000
CPU min MHz:           499,8000
BogoMIPS:              3198.65
Virtualization:        VT-x
L1d cache:             24K
L1i cache:             32K
L2 cache:              1024K
NUMA node0 CPU(s):     0-3

I've added two log files. The guest locks at Line 1090 (using 2 CPUs). Hopefully this information will help to solve the problem.

comment:5 Changed 19 months ago by frank

  • Summary changed from Windows 10 fails to start if multiple CPU's are enabled to Windows 10 fails to start if multiple CPU's are enabled (IA32_TSC_AUX)

comment:6 Changed 19 months ago by frank

Could you check if this test build fixes your problem? The reason was most likely the access to the IA32_AUX_TSC MSR.

comment:7 Changed 19 months ago by dasdandre

Thank you very much frank.

In the meantime I switched to Ubuntu 16.04, so i had some troubles to get your build running.

But at least I can confirm that the problem is fixed. :-)

comment:8 Changed 19 months ago by frank

Thanks for the feedback! Here is a Ubuntu 16.04 test build.

comment:9 Changed 17 months ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Fixed in 5.0.22.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use