VirtualBox

Ticket #14773 (closed defect: fixed)

Opened 2 years ago

Last modified 2 years ago

Minimal Linux guest on 32-bit Windows 8.1 hits #GP with hwvirtex enabled (Intel Atom)

Reported by: draxie Owned by:
Priority: major Component: VMM/HWACCM
Version: VirtualBox 5.0.8 Keywords:
Cc: Guest type: Linux
Host type: Windows

Description

OK. So, I have this minimal (custom) Linux guest (see attached zip archive, including both the iso image and a batch file), tested and working with VB 5.0.8 on both 32-bit and 64-bit Linux (LinuxMint 17.2), Mac OSX, and 64-bit Windows 7. On 32-bit Windows 8.1 *running on a 64-bit Atom processor*, this same guest hits a General Protection Fault with the same settings I used on all the other platforms. With HW virtualization turned off (--hwvirtex off), everything works as expected...

The same applies to the latest test build (5.0.9), and the previous major version (4.3.32). Logs are attached for all three VB versions, with and without HW virtualization.

I suspect the oddball combination of a 32-bit OS on a 64-bit capable CPU (apparently fairly popular on Atom tablets/laptops) may be causing havoc; but this is just a wild guess.

Attachments

VBox_5.0.8+HWV.log Download (51.7 KB) - added by draxie 2 years ago.
VBox_5.0.8-HWV.log Download (74.6 KB) - added by draxie 2 years ago.
VBox_5.0.9+HWV.log Download (51.7 KB) - added by draxie 2 years ago.
VBox_5.0.9-HWV.log Download (74.6 KB) - added by draxie 2 years ago.
VBox_4.3.32+HWV.log Download (46.2 KB) - added by draxie 2 years ago.
VBox_4.3.32-HWV.log Download (68.3 KB) - added by draxie 2 years ago.

Change History

Changed 2 years ago by draxie

Changed 2 years ago by draxie

Changed 2 years ago by draxie

Changed 2 years ago by draxie

Changed 2 years ago by draxie

Changed 2 years ago by draxie

comment:1 Changed 2 years ago by draxie

Hmm... the guest is "minimal", but -weighing in at 2.71Mb- it's not minimal enough to pass the 512kB limit; so, please disregard the comment about the attached zip archive (which is still available by email on request BTW, assuming a more lenient limit there).

comment:2 Changed 2 years ago by frank

Actually the problem is your slightly misdetected host CPU. VBox assumes its MSR emulation should be done like a Core i5 which is wrong. The log file entry

IEM: rdmsr(0xcd) -> GP(0)

shows that MSR 0xcd is not properly emulated. We need to add an Intel Atom DB to the VBox code. Seems like we can do this here so I can probably provide you a test build soon.

comment:3 Changed 2 years ago by frank

Could you give this build a try? If it still does not work, please attach a new VBox.log file from a VM session with this build.

comment:4 Changed 2 years ago by frank

  • Summary changed from Minimal Linux guest on 32-bit Windows 8.1 hits General Protection Fault with hwvirtex enabled to Minimal Linux guest on 32-bit Windows 8.1 hits #GP with hwvirtex enabled (Intel Atom)

comment:5 Changed 2 years ago by frank

Actually the latest test build from here has another fix which might be relevant for your platform as well.

comment:6 Changed 2 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Fix is part of VBox 5.0.10.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use