VirtualBox

Ticket #14764 (closed defect: fixed)

Opened 2 years ago

Last modified 13 months ago

Virtual disk image variant is not used for snapshots => fixed in SVN/5.1.x

Reported by: bekks77 Owned by:
Priority: minor Component: virtual disk
Version: VirtualBox 5.0.8 Keywords: snapshot, vmdk, split
Cc: Guest type: all
Host type: all

Description

Hi!

When creating snapshots for a VM using split-file VMDK files, the snapshot VMDK files may exceed 2GB, which shows that they arent splitted.

I'd really appreciate this to be "fixed".

Thanks in advance, Eduard

Change History

comment:1 Changed 2 years ago by klaus

  • Priority changed from major to minor

comment:2 Changed 2 years ago by frank

Thanks for the report. This bug will be fixed in the next 5.0.x maintenance release.

comment:3 Changed 23 months ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Fixed in VBox 5.0.10.

comment:4 Changed 13 months ago by skillian

I think this might be the cause of an issue I'm having with mounting a VMDK stream-optimized disk. When the differencing disk is created, it is also a stream-optimized disk and any guest OS I run complains about write errors. I tried to install VirtualBox 5.0.8 and 5.0.6 to confirm, but I'm getting Access Violation (0xc0000005) exceptions trying to start virtualbox.exe. VirtualBox 4.3.36 produces the expected behavior of creating non-compressed differencing VMDKs.

comment:5 Changed 13 months ago by skillian

  • Status changed from closed to reopened
  • Resolution fixed deleted

comment:6 Changed 13 months ago by aeichner

  • Summary changed from Virtual disk image variant is not used for snapshots to Virtual disk image variant is not used for snapshots => fixed in SVN/5.1.x

Thanks for the report, this will be fixed in the next maintenance release.

comment:7 Changed 13 months ago by frank

  • Status changed from reopened to closed
  • Resolution set to fixed

Fixed in 5.1.6.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use