VirtualBox

Ticket #14659 (closed defect: fixed)

Opened 2 years ago

Last modified 2 years ago

Emulated COM1 IRQ reported as 0 to hosts on VBox 5.0.6

Reported by: PeterP Owned by:
Priority: major Component: uart
Version: VirtualBox 5.0.6 Keywords:
Cc: Guest type: all
Host type: Linux

Description

Greetings,

I am running Debian Jessie (AMD64) on my host machines. After upgrading to VirtualBox 5.0.6, my guest OSes started reporting the IRQ of the emulated serial port 1 (COM1 / ttyS0) as 0, see attached screenshots. As a result, Windows hosts are unable to use the serial port - they claim an error that "the device cannot start (code 10)". Linux guests are more lenient and while they also report the IRQ of the serial port 1 to be 0, they nonetheless appear to be able to use it.

Reverting back to VBox 5.0.4 solves the problem entirely, so this appears to be a regression in the 5.0.6 release. I have been able to reproduce this problem reliably on 19 machines (I have discovered it after upgrading an entire classroom ;) ).

Thanks for looking into this issue!

Best regards, Peter

Attachments

Windows.png Download (15.6 KB) - added by PeterP 2 years ago.
Debian.png Download (17.6 KB) - added by PeterP 2 years ago.
VBox.log Download (119.5 KB) - added by PeterP 2 years ago.
VBox.log of a Windows 7 guest machine

Change History

Changed 2 years ago by PeterP

Changed 2 years ago by PeterP

comment:1 Changed 2 years ago by PeterP

I apologize for a misnomer in the ticket heading - I meant to say: "Emulated COM1 IRQ reported as 0 to GUESTS on VBox 5.0.6". It's been a long day... Once again, my apologies for the misleading heading.

Best regards, Peter

comment:2 Changed 2 years ago by aeichner

Please attach the VBox.log

comment:3 Changed 2 years ago by aeichner

We probably found the source of the regression, one of the fixes in the area of the parallel port contained a typo overwriting the first serial port settings. One workaround would be to enable the second serial port instead of the first in case the most recent release is required for another fix or enable the first parallel port for the VM and configure the IRQ value to match the one for the first serial port.

Changed 2 years ago by PeterP

VBox.log of a Windows 7 guest machine

comment:4 Changed 2 years ago by PeterP

Hi,

Thank you for looking into the issue. I am not sure if the VBox.log is still helpful at this point but I have uploaded it. As for the fix, I have remained with 5.0.4 for now as it is not urgent for me at all to move over to newer versions. However, if a test build is available, I will be glad to test out the corrected code and report back.

Best regards, Peter

comment:5 Changed 2 years ago by frank

Here is a Debian 8 package containing the fix.

comment:6 Changed 2 years ago by Buford T. Justice

I have the same problem with Ubuntu MATE 14.04.2 LTS and VirtualBox 5.0.6 with my modem no longer working. Is there a version for Ubuntu?

Last edited 2 years ago by Buford T. Justice (previous) (diff)

comment:7 Changed 2 years ago by frank

Here is an Ubuntu 14.04 package.

comment:8 Changed 2 years ago by Buford T. Justice

Thanks :)

comment:9 Changed 2 years ago by PeterP

Frank,

I am pleased to confirm that the 5.0.7 Debian build successfully resolves the IRQ issue for me. The first serial port now reports correct IRQ in the guest operating system and is usable.

Thank you!

Best regards, Peter

comment:10 Changed 2 years ago by wisewellies

I have experienced the same issue with 5.0.6. I have found that the first serial port will be configured correctly if a parallel port is added - it doesn't need to be connected to any device, just enabled.

comment:11 Changed 2 years ago by frank

Makes sense. r58015 shows the reason.

comment:12 Changed 2 years ago by Bluezeyes

I experience the same issue on ubuntu 14.04 trusty tar with virtualbox 5.0.6 and guest Windows 7 when passing real n working Serial port as first port to the Guest OS. In Windows 7 the serial port is marked with exclamation mark and are unusable. I will try the Ubuntu version which was mentioned above, to see if it fixed the issue for me.

Beside this, when upgrading from 5.0.3 to 5.0.6 the DKMS modules were not created for the recent Linux kernel shipped by Ubuntu. (4.xx.30) so VIRTUALBOX blamed on these failure.

Kind regards,

Jörn-Ingo Weigert

Last edited 2 years ago by Bluezeyes (previous) (diff)

comment:13 Changed 2 years ago by Bluezeyes

Update: The updated Ubuntu version https://www.virtualbox.org/download/testcase/virtualbox-5.0_5.0.7-103072~Ubuntu~trusty_amd64.deb fixed the issue.

Thanks for the quick & good support!

Greets,

Jörn-Ingo Weigert

comment:14 Changed 2 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Fix is part of VBox 5.0.8.

comment:15 Changed 2 years ago by big_lore

I experienced a similar issue on LTP port. The problem is present also on5.08 and 5.10.

comment:16 Changed 2 years ago by frank

What is the output of

VBoxManage showvminfo VM_NAME | grep LPT

?

comment:17 Changed 2 years ago by big_lore

Hi Frank,
thanks for your reply.
The output of VBoxManage showvminfo is

LPT 1: disabled
LPT 2: disabled

In fact I don't use LPT ports. I use a Sentinel USB key that has a service dependace with Windows's parport service, and on Vbox >= 4.06 the parport service fails to start.
On 5.04 Vbox.log I have:

00:00:01.852544 
00:00:01.852544 [/Devices/acpi/0/Config/] (level 4)
00:00:01.852546   CpuHotPlug        <integer> = 0x0000000000000000 (0)
00:00:01.852547   FdcEnabled        <integer> = 0x0000000000000000 (0)
00:00:01.852547   HostBusPciAddress <integer> = 0x0000000000000000 (0)
00:00:01.852548   HpetEnabled       <integer> = 0x0000000000000000 (0)
00:00:01.852549   IOAPIC            <integer> = 0x0000000000000001 (1)
00:00:01.852549   IocPciAddress     <integer> = 0x0000000000010000 (65 536)
00:00:01.852550   NumCPUs           <integer> = 0x0000000000000002 (2)
00:00:01.852551   RamHoleSize       <integer> = 0x0000000020000000 (536 870 912, 512 MB)
00:00:01.852552   RamSize           <integer> = 0x00000000b1900000 (2 979 004 416, 2 GB)
00:00:01.852553   Serial0IoPortBase <integer> = 0x0000000000000000 (0)
00:00:01.852554   Serial0Irq        <integer> = 0x0000000000000000 (0)
00:00:01.852554   Serial1IoPortBase <integer> = 0x0000000000000000 (0)
00:00:01.852555   Serial1Irq        <integer> = 0x0000000000000000 (0)
00:00:01.852556   ShowCpu           <integer> = 0x0000000000000001 (1)
00:00:01.852556   ShowRtc           <integer> = 0x0000000000000000 (0)
00:00:01.852557   SmcEnabled        <integer> = 0x0000000000000000 (0)

On 5.10 Vbox.log I have:

00:00:01.413996 [/Devices/acpi/0/Config/] (level 4)
00:00:01.413998   CpuHotPlug          <integer> = 0x0000000000000000 (0)
00:00:01.413999   FdcEnabled          <integer> = 0x0000000000000000 (0)
00:00:01.413999   HostBusPciAddress   <integer> = 0x0000000000000000 (0)
00:00:01.414000   HpetEnabled         <integer> = 0x0000000000000000 (0)
00:00:01.414001   IOAPIC              <integer> = 0x0000000000000001 (1)
00:00:01.414001   IocPciAddress       <integer> = 0x0000000000010000 (65 536)
00:00:01.414002   NumCPUs             <integer> = 0x0000000000000002 (2)
00:00:01.414003   Parallel0IoPortBase <integer> = 0x0000000000000000 (0)
00:00:01.414004   Parallel0Irq        <integer> = 0x0000000000000000 (0)
00:00:01.414004   Parallel1IoPortBase <integer> = 0x0000000000000000 (0)
00:00:01.414005   Parallel1Irq        <integer> = 0x0000000000000000 (0)
00:00:01.414005   RamHoleSize         <integer> = 0x0000000020000000 (536 870 912, 512 MB)
00:00:01.414007   RamSize             <integer> = 0x00000000b1900000 (2 979 004 416, 2 GB)
00:00:01.414008   Serial0IoPortBase   <integer> = 0x0000000000000000 (0)
00:00:01.414009   Serial0Irq          <integer> = 0x0000000000000000 (0)
00:00:01.414009   Serial1IoPortBase   <integer> = 0x0000000000000000 (0)
00:00:01.414010   Serial1Irq          <integer> = 0x0000000000000000 (0)
00:00:01.414011   ShowCpu             <integer> = 0x0000000000000001 (1)
00:00:01.414011   ShowRtc             <integer> = 0x0000000000000000 (0)
00:00:01.414012   SmcEnabled          <integer> = 0x0000000000000000 (0)

So I Thought that the problem is the same as the Serial IRQ number.

Thanks for looking into this issue!
Kind Regards,
Lorenzo

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use