VirtualBox

Ticket #14549 (closed defect: obsolete)

Opened 5 years ago

Last modified 3 years ago

Guru meditation when reading CD

Reported by: ysangkok Owned by:
Component: virtual disk Version: VirtualBox 5.0.2
Keywords: cd Cc:
Guest type: other Host type: Linux

Description

VDI:  http://lazybrowndog.net/freedos/virtualbox/FreeDOS_1.1beta-network.zip

Using the VDI from above and the default DOS VM config, I get a Guru Meditation when listing the contents of a CD-ROM in DOS. I believe it is independent of the ISO, but I can provide the image if necessary.

When booting, be sure to choose the second option with CD-ROM support.

Attachments

2015-09-06-13-02-17.077-VirtualBox-11393.log Download (76.4 KB) - added by ysangkok 5 years ago.
VBox.log.1 Download (199.8 KB) - added by ysangkok 5 years ago.
vbox log from machien directory
crashingimage.iso.xz Download (101.0 KB) - added by ysangkok 5 years ago.
unxz'ing and then "d:" and then "dir" with this image in the virtual cd-drive causes guru meditation (CAUTION: executing "dir d:" works)

Change History

Changed 5 years ago by ysangkok

comment:1 Changed 5 years ago by frank

Cannot reproduce. Please attach the VBox.log release log file which you can found in the VM machines directory.

Changed 5 years ago by ysangkok

vbox log from machien directory

comment:2 Changed 5 years ago by frank

Thanks for the log. I adapted a few VM settings to be closer to your VM configuration but unfortunately I'm still not able to reproduce this problem.

Changed 5 years ago by ysangkok

unxz'ing and then "d:" and then "dir" with this image in the virtual cd-drive causes guru meditation (CAUTION: executing "dir d:" works)

comment:3 Changed 5 years ago by ysangkok

Thanks for the quick reply frank. I tested with another ISO image, and it did not crash. I produced an ISO image that causes the crash (when executing "dir"). The crash does not happen with QEMU. I think it may be a problem between FreeDOS 1.1 and VirtualBox, as the crash happens when executing "dir".

comment:4 Changed 5 years ago by ysangkok

If there is anything else that I can do to help you reproduce the problem, I would very much like to help you. I may be able to prepare a Docker image that contains a VirtualBox build, config, VM and all necessary files. Please tell me if this would be helpful to you.

comment:5 Changed 5 years ago by frank

With the latest 5.0.x build the guest just hangs (no Guru Meditation). Are you sure this setup works on real hardware?

comment:6 Changed 3 years ago by frank

  • Status changed from new to closed
  • Resolution set to obsolete
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use