VirtualBox

Ticket #1453 (closed defect: worksforme)

Opened 6 years ago

Last modified 6 years ago

/etc/init.d/vboxdrv and /etc/init.d/vboxnet not in Ubuntu-Hardy .deb Package (1.6.0)

Reported by: rfolkerts Owned by:
Priority: minor Component: other
Version: VirtualBox 1.6.0 Keywords: vboxdrv script missing
Cc: Guest type: other
Host type: other

Description

I installed VirtualBox 1.6.0 "fresh" onto my Ubuntu-Hardy x86 System, i.e. I deinstalled the previous Installation and then installed 1.6.0 from the File

virtualbox_1.6.0-30421_Ubuntu_hardy_i386.deb

Install went thru fine; a Kernel-Module was created (last few lines from /var/log/vbox-install.log:

Building modules, stage 2.

make -f /usr/src/linux-headers-2.6.24-17-generic/scripts/Makefile.modpost

scripts/mod/modpost -m -a -i /usr/src/linux-headers-2.6.24-17-generic/Module.symvers -I /tmp/vbox.0/Module.symvers -o /tmp/vbox.0/Module.symvers -w -s gcc -m32 -Wp,-MD,/tmp/vbox.0/.vboxdrv.mod.o.d -nostdinc -isystem /usr/lib/gcc/i486-linux-gnu/4.2.3/include -DKERNEL -Iinclude -include include/linux/autoconf.h -Wall -Wundef -Wstrict-prototypes -Wno-trigraphs -fno-strict-aliasing -fno-common -Werror-implicit-function-declaration -O2 -pipe -msoft-float -mregparm=3 -freg-struct-return -mpreferred-stack-boundary=2 -march=i586 -mtune=generic -ffreestanding -maccumulate-outgoing-args -Iinclude/asm-x86/mach-default -fomit-frame-pointer -g -fno-stack-protector -Wdeclaration-after-statement -Wno-pointer-sign -D"KBUILD_STR(s)=#s" -D"KBUILD_BASENAME=KBUILD_STR(vboxdrv.mod)" -D"KBUILD_MODNAME=KBUILD_STR(vboxdrv)" -DMODULE -c -o /tmp/vbox.0/vboxdrv.mod.o /tmp/vbox.0/vboxdrv.mod.c ld -m elf_i386 -r -m elf_i386 --build-id -o /tmp/vbox.0/vboxdrv.ko /tmp/vbox.0/vboxdrv.o /tmp/vbox.0/vboxdrv.mod.o

make[1]: Verlasse Verzeichnis '/usr/src/linux-headers-2.6.24-17-generic'

However, when I tried to start VirtualBox I got a message that the Kernel-Module was not loaded and I was asked to run /etc/init.dvboxdrv setup.

However:

ralf@flounder:~$ ls -l /etc/init.d/vbox* ls: Zugriff auf /etc/init.d/vbox* nicht möglich: No such file or directory

i.e. there is no /etc/init.d/vboxdrv not a /etc/init.d/vboxnet Script.

When running dpkg -L virtualbox I see, amongst other Files:

/etc /etc/init.d /etc/init.d/vboxnet /etc/init.d/vboxdrv

However, when checking in aptitude I saw, these Files (vboxnet and vboxdrv) have a size of 0 bytes.

I tried to "install over" the 1.6, but that didn't change the Status of the vboxdrv/vboxnet Scripts. Also I tried dpkg --configure -a but that didn't perform any actions.

My System:

Ubuntu 8.04, Hardy

ralf@flounder:~$ dpkg -l virtualbox Desired=Unknown/Install/Remove/Purge/Hold | Status=Not/Installed/Config-f/Unpacked/Failed-cfg/Half-inst/t-aWait/T-pend |/ Err?=(none)/Hold/Reinst-required/X=both-problems (Status,Err: uppercase=bad)

/ Name Version Beschreibung

+++-==============-==============-============================================ ii virtualbox 1.6.0-30421_Ub Sun xVM VirtualBox

ralf@flounder:~$ uname -r 2.6.24-17-generic

There is still space in /etc ralf@flounder:~$ df /etc Dateisystem 1K‐Blöcke Benutzt Verfügbar Ben% Eingehängt auf /dev/mapper/systemvg-rootlv

1965459 320975 1539627 18% /

Cheers, _ralf_

Change History

comment:1 Changed 6 years ago by rfolkerts

Hi,

just ran a dpkg -x on the virtualbox-.deb (into ~/Dokumente/work) and found

ralf@flounder:~/Dokumente/work/etc/init.d$ ls -la insgesamt 28 drwxr-xr-x 2 ralf ralf 4096 2008-05-01 00:14 . drwxr-xr-x 4 ralf ralf 4096 2008-05-01 00:14 .. -rwxr-xr-x 1 ralf ralf 8136 2008-05-01 00:14 vboxdrv -rwxr-xr-x 1 ralf ralf 10380 2008-05-01 00:14 vboxnet

so, the Scripts are into the Package, but it seems they don't get installed or will be removed after Installation??

I copied these two Scripts over to /etc/init.d -- and now VirtualBox starts 1a!

I also checked the Install-Scripts extracted with dpkg -c but didn't find anything that looked as if it would remove /etc/init.d/vboxdrv and /etc/init.d/vboxnet.

Cheers, _ralf_

comment:2 follow-up: ↓ 3 Changed 6 years ago by frank

Do you have an old version of VirtualBox installed? Or VirtualBox-OSE? What happens if you install this package and then type

dpkg -L virtualbox|grep etc?

comment:3 in reply to: ↑ 2 Changed 6 years ago by rfolkerts

Hi Frank,

I did have VBox 1.5.6 installed, however, I deinstalled that before I installed VBox 1.6.0. I never tried the OSE-Edition on Kubuntu.

As for the dpkg -L-Info; I have some in my Original-Post (unfortunately not neatly formated I must admit):

ralf@flounder:~$ dpkg -L virtualbox|grep etc
/etc
/etc/init.d
/etc/init.d/vboxnet
/etc/init.d/vboxdrv
/etc/vbox
/etc/vbox/vbox.cfg

Please note, however, that in Adept the vboxnet and vboxdrv are shown with a size of 0 Bytes.

Cheers, _ralf_

comment:4 Changed 6 years ago by frank

  • Status changed from new to closed
  • Resolution set to worksforme

Please upgrade to 1.6.2. Reopen this bug if you still observe problems.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use