VirtualBox

Ticket #1452 (closed defect: fixed)

Opened 6 years ago

Last modified 6 years ago

Error on guest additions error on debian guest => Fixed in 1.6.2

Reported by: seblu Owned by:
Priority: major Component: other
Version: VirtualBox 1.5.6 Keywords:
Cc: Guest type: other
Host type: other

Description

My host : gentoo linux 2.6.24 with vbox 1.5.6 and vbox-modules 1.5.7 My guest : debian lenny (testing) 2.6.24 with vbox-modules 1.5.7

on my other guest, mouse integration and vfs is ok. But on this guest i cannot mount vboxfs and i don't have mouse integration.

Attachments

Xorg.0.log Download (17.1 KB) - added by seblu 6 years ago.
X log
dmesg Download (10.1 KB) - added by seblu 6 years ago.
dmesg errors
xorg.conf Download (1.6 KB) - added by seblu 6 years ago.
Xorg conf file

Change History

Changed 6 years ago by seblu

X log

Changed 6 years ago by seblu

dmesg errors

Changed 6 years ago by seblu

Xorg conf file

comment:1 Changed 6 years ago by frank

How did you install the guest additions? This is a permission problem, the guest drivers cannot access /dev/vboxadd which is kind of strange as the guest additions installer should take care of this.

comment:2 Changed 6 years ago by seblu

dev-web ~ # lsmod|grep vbox vboxvfs 38240 1 vboxadd 21512 1 vboxvfs dev-web ~ # ll /dev/vbox* ls: cannot access /dev/vbox*: No such file or directory dev-web ~ #

Effectively they are no /dev/vboxdrv file

To install i click on Devices -> Install Guest Additions... and then

dev-web ~ # mount /mnt/cdrom mount: block device /dev/hdc is write-protected, mounting read-only dev-web ~ # cd /mnt/cdrom dev-web /mnt/cdrom # ls . .. AMD_PCnet AUTORUN.INF driver gina os2 VBoxGuestAdditions.exe VBoxLinuxAdditions.run dev-web /mnt/cdrom # sh VBoxLinuxAdditions.run Verifying archive integrity... All good. Uncompressing VirtualBox 1.5.7 Guest Additions for Linux installation................................................................................................................................................. VirtualBox 1.5.7 Guest Additions installation Building the VirtualBox Guest Additions kernel module... Building the shared folder support kernel module... Installing the VirtualBox Guest Additions...

Successfully installed the VirtualBox Guest Additions. You must restart your guest system in order to complete the installation. dev-web /mnt/cdrom # uname -a Linux dev-web 2.6.24-1-686 #1 SMP Sat Apr 19 00:37:55 UTC 2008 i686 GNU/Linux dev-web /mnt/cdrom # reboot

comment:3 Changed 6 years ago by seblu

the same with right formating

dev-web ~ # ll /dev/vbox*                                                                                                               (14:43)[0]
ls: cannot access /dev/vbox*: No such file or directory
dev-web ~ # mount /mnt/cdrom
mount: block device /dev/hdc is write-protected, mounting read-only
dev-web ~ # cd /mnt/cdrom
dev-web /mnt/cdrom # ls
.  ..  AMD_PCnet  AUTORUN.INF  driver  gina  os2  VBoxGuestAdditions.exe  VBoxLinuxAdditions.run
dev-web /mnt/cdrom # sh VBoxLinuxAdditions.run 
Verifying archive integrity... All good.
Uncompressing VirtualBox 1.5.7 Guest Additions for Linux installation.................................................................................................................................................
VirtualBox 1.5.7 Guest Additions installation
Building the VirtualBox Guest Additions kernel module...
Building the shared folder support kernel module...
Installing the VirtualBox Guest Additions...

Successfully installed the VirtualBox Guest Additions.
You must restart your guest system in order to complete the installation.
dev-web /mnt/cdrom # uname -a
Linux dev-web 2.6.24-1-686 #1 SMP Sat Apr 19 00:37:55 UTC 2008 i686 GNU/Linux
dev-web /mnt/cdrom # reboot

comment:4 Changed 6 years ago by seblu

after restart :

dev-web /home/dev # ls /dev/vb*                                                                                                         
ls: cannot access /dev/vb*: No such file or directory

Yesterday, i have try at work with my debian host to re-install a debian lenny guest and i have the same problem. But on this same host i have and debian etch and they don't suffer of this bug.

comment:5 Changed 6 years ago by frank

Hmm, What if you are executing

/etc/init.d/vboxadd start

manually? Does the device exist then?

comment:6 Changed 6 years ago by seblu

dev-web /home/dev # /etc/init.d/vboxadd start                                                                                          
Starting VirtualBox Additions ...done.
dev-web /home/dev # ll /dev/vboxadd                                                                                                    
crw-rw-r-- 1 root root 253, 0 2008-05-08 15:11 /dev/vboxadd
dev-web /home/dev # /etc/init.d/vboxvfs start                                                                                           
Starting VirtualBox Additions shared folder support ...done.
dev-web /home/dev # ll /etc/rc3.d/                                                                                                      
total 12K
drwxr-xr-x  2 root root 4.0K 2008-05-08 14:46 .
drwxr-xr-x 90 root root 4.0K 2008-05-08 14:54 ..
-rw-r--r--  1 root root  556 2008-04-12 09:38 README
lrwxrwxrwx  1 root root   17 2008-05-08 14:46 S01vboxadd -> ../init.d/vboxadd
lrwxrwxrwx  1 root root   26 2008-05-08 14:46 S02vboxadd-timesync -> ../init.d/vboxadd-timesync
lrwxrwxrwx  1 root root   17 2008-05-08 14:46 S02vboxvfs -> ../init.d/vboxvfs
lrwxrwxrwx  1 root root   18 2008-03-15 18:19 S10sysklogd -> ../init.d/sysklogd
lrwxrwxrwx  1 root root   15 2008-03-15 18:19 S11klogd -> ../init.d/klogd
lrwxrwxrwx  1 root root   14 2008-05-02 22:22 S12dbus -> ../init.d/dbus
lrwxrwxrwx  1 root root   23 2008-03-16 20:08 S17mysql-ndb-mgm -> ../init.d/mysql-ndb-mgm
lrwxrwxrwx  1 root root   19 2008-03-16 20:08 S18mysql-ndb -> ../init.d/mysql-ndb
lrwxrwxrwx  1 root root   15 2008-03-16 20:08 S19mysql -> ../init.d/mysql
lrwxrwxrwx  1 root root   16 2008-05-02 22:56 S20cupsys -> ../init.d/cupsys
lrwxrwxrwx  1 root root   13 2008-05-02 22:47 S21fam -> ../init.d/fam
lrwxrwxrwx  1 root root   22 2008-05-02 22:55 S24avahi-daemon -> ../init.d/avahi-daemon
lrwxrwxrwx  1 root root   13 2008-05-02 22:47 S24hal -> ../init.d/hal
lrwxrwxrwx  1 root root   13 2008-03-16 20:26 S30gdm -> ../init.d/gdm
lrwxrwxrwx  1 root root   31 2008-05-02 22:55 S30system-tools-backends -> ../init.d/system-tools-backends
lrwxrwxrwx  1 root root   14 2008-03-15 18:18 S89cron -> ../init.d/cron
lrwxrwxrwx  1 root root   17 2008-03-16 20:08 S91apache2 -> ../init.d/apache2
lrwxrwxrwx  1 root root   18 2008-03-15 18:18 S99rc.local -> ../init.d/rc.local
lrwxrwxrwx  1 root root   19 2008-03-15 18:18 S99rmnologin -> ../init.d/rmnologin
lrwxrwxrwx  1 root root   23 2008-03-15 18:18 S99stop-bootlogd -> ../init.d/stop-bootlogd

ok all is right after a manual starting. Ok the problem is so simple :)

dev-web /home/dev # cat /etc/inittab|grep default
# The default runlevel.
id:2:initdefault:

and vbox rc scripts links are only added to the runlevel 3. when i manually create this links with debian tools

dev-web /home/dev # update-rc.d vboxadd defaults 01 99]
 Adding system startup for /etc/init.d/vboxadd ...
   /etc/rc0.d/K99vboxadd -> ../init.d/vboxadd
   /etc/rc1.d/K99vboxadd -> ../init.d/vboxadd
   /etc/rc6.d/K99vboxadd -> ../init.d/vboxadd
   /etc/rc3.d/S01vboxadd -> ../init.d/vboxadd
   /etc/rc5.d/S01vboxadd -> ../init.d/vboxadd
dev-web /home/dev # update-rc.d vboxadd-timesync defaults 02 98
 Adding system startup for /etc/init.d/vboxadd-timesync ...
   /etc/rc0.d/K98vboxadd-timesync -> ../init.d/vboxadd-timesync
   /etc/rc1.d/K98vboxadd-timesync -> ../init.d/vboxadd-timesync
   /etc/rc6.d/K98vboxadd-timesync -> ../init.d/vboxadd-timesync
   /etc/rc3.d/S02vboxadd-timesync -> ../init.d/vboxadd-timesync
   /etc/rc5.d/S02vboxadd-timesync -> ../init.d/vboxadd-timesync
dev-web /home/dev # update-rc.d vboxvfs defaults 03 97
 Adding system startup for /etc/init.d/vboxvfs ...
   /etc/rc0.d/K97vboxvfs -> ../init.d/vboxvfs
   /etc/rc1.d/K97vboxvfs -> ../init.d/vboxvfs
   /etc/rc6.d/K97vboxvfs -> ../init.d/vboxvfs
   /etc/rc3.d/S03vboxvfs -> ../init.d/vboxvfs
   /etc/rc5.d/S03vboxvfs -> ../init.d/vboxvfs
dev-web /home/dev #          

We seeing the problem....

if you use update-rc.d to add theses scripts, this is a bug of debian teem.

Tanks you.

comment:7 Changed 6 years ago by seblu

in fact, it's not a bug in update-rc.d. It's a probleme on your debian vboxadd* rc scripts

if i do something like this

dev-web /home/dev # touch /etc/init.d/test
dev-web /home/dev # update-rc.d test defaults 30
update-rc.d: warning: /etc/init.d/test missing LSB style header
 Adding system startup for /etc/init.d/test ...
   /etc/rc0.d/K30test -> ../init.d/test
   /etc/rc1.d/K30test -> ../init.d/test
   /etc/rc6.d/K30test -> ../init.d/test
   /etc/rc2.d/S30test -> ../init.d/test
   /etc/rc3.d/S30test -> ../init.d/test
   /etc/rc4.d/S30test -> ../init.d/test
   /etc/rc5.d/S30test -> ../init.d/test

no problem !

The problem come from this lines in the vbox* rc scripts

### BEGIN INIT INFO
# Provides:       vboxadd
# Required-Start:
# Required-Stop:
# Default-Start:  3 5
# Default-Stop:
# Description:    VirtualBox Linux Additions kernel module
### END INIT INFO

because you hard write the default start ! I my opinion, you can safely remove this header (Default-Start, Default-stop) and trust debian update-rc.d utility to create theses links correctly.

This fix the bug with update-rc.d.

comment:8 Changed 6 years ago by seblu

remove this header is not a good solution. use theses of skel file is better (no warning message)

# Default-Start:     2 3 4 5
# Default-Stop:      0 1 6

have a good day.

comment:9 Changed 6 years ago by frank

  • Summary changed from Error on guest additions error on debian guest to Error on guest additions error on debian guest => Fixed in 1.6.2

Thanks for this report and for finding the problem.

comment:10 Changed 6 years ago by sandervl73

  • Status changed from new to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use