VirtualBox

Ticket #14503 (closed enhancement: wontfix)

Opened 7 years ago

Last modified 7 years ago

Plymouth Splash screen does not work for Debian Jessie in Virtual Box -> won't fix for now

Reported by: Tejendra Owned by:
Component: other Version: VirtualBox 5.0.2
Keywords: Cc:
Guest type: Linux Host type: Windows

Description

I am using Virtual Box version 4.3.30. I have this weird problem while using Debian Jessie (8.1.0) as my guest OS and I think this problem is with everybody using Virtual Box and running Jessie as guest OS.

Problem: Instead of proper splash screen at boot log time, three squares are displayed in centre of screen

Description: While I configure my Debian Jessie OS to show Plymouth Splash screen on bootup, It should show plymouth splash screen while bootup. This issue was also observed with latest plymouth package (0.9.0-9) in wheezy.

Exceptions: Plymouth Splash screen is working properly if I install Debian Jessie in dual boot environment or on physical machine

Probable Problem: Looks like there is some problem/Limitations with "Emulation of Graphics Card in Virtial Box", as I have tested this thing on both Intel and Nvidia Graphics cards but it doesn't work on Virtual Box, However it does work when installed in dual boot environment ( As real graphics card would be available )

I am configuring plymouth using instructions on debian's plymouth page.  https://wiki.debian.org/plymouth

Attachments

VBox.log Download (95.4 KB) - added by Tejendra 7 years ago.
virtual box logs
VBoxStartup.7z Download (26.6 KB) - added by Tejendra 7 years ago.

Change History

Changed 7 years ago by Tejendra

virtual box logs

Changed 7 years ago by Tejendra

comment:1 Changed 7 years ago by Tejendra

added virtual box logs

comment:2 Changed 7 years ago by michael

Are you sure that this is not expected? The VirtualBox Guest Additions do not provide a KMS driver for the boot splash at this point, and this is probably Jessie's behaviour by design if no KMS driver is present. If you are not sure, please ask Debian.

comment:3 Changed 7 years ago by Tejendra

plymouth version in wheezy was working fine, but this is the problem which is only occurring in jessie, i am still to get answer from debian folks, however if there is the dependency on KMS driver being available for boot splash in virtual box, are Virtual Box developers going to integrate this change in future releases?

Last edited 7 years ago by Tejendra (previous) (diff)

comment:4 Changed 7 years ago by michael

  • Status changed from new to closed
  • Resolution set to wontfix
  • Summary changed from Plymouth Splash screen does not work for Debian Jessie in Virtual Box to Plymouth Splash screen does not work for Debian Jessie in Virtual Box -> won't fix for now

It might happen, but we don't have concrete plans there. For now I will close this as "wont't fix", although it probably will at some unspecified time.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use