VirtualBox

Ticket #14326 (closed defect: fixed)

Opened 2 years ago

Last modified 2 years ago

5.0 NDIS6 Bridged Driver kills host network

Reported by: Kiran Otter Owned by:
Priority: major Component: network
Version: VirtualBox 5.0.0 Keywords: lan bridged driver network
Cc: Guest type: Windows
Host type: Windows

Description

After installing Vbox 5.0 on Windows 7 x64, the host LAN stops functioning. Tried both 5.0.0-101573 and 5.0.1-101778. If I unbind the bridged adapter in the LAN network adapter properties, the LAN immediately begins to work again. Without it bound, Vbox guests can't use bridged networking.

See  https://forums.virtualbox.org/viewtopic.php?f=6&t=68980

Change History

comment:1 Changed 2 years ago by frank

Any improvement with VBox 5.0.4?

comment:2 Changed 2 years ago by mroshaw

I was a contributor to that forum thread and still have the same problem with 5.0.4. Now have a Windows 10 host but same problem of host network connectivity being lost when the "Bridged" (and / or "Host Only) adapter is selected in the installer.

Last edited 2 years ago by mroshaw (previous) (diff)

comment:3 Changed 2 years ago by vushakov

  • Component changed from network/hostif to network

comment:4 Changed 2 years ago by demortes

I'm having this issue on Windows 10. Not knowing what it was at first I:
Rebooted the machine.
Verified network settings were right ( 192.168.1.1 with DNS. Other devices worked on network)
Changed DNS
Uninstalled the network adapter.
Reinstalled network adapter
Unchecked IPv6
Disabled the NDIS6 Bridged Driver IT WORKED
Removed NDIS driver
Reinstalled NDIS driver STOPPED WORKING
Now I sit here without a driver, and I'm expecting VirtualBox to not allow Bridged network.

comment:5 Changed 2 years ago by demortes

Forgot to mention, using 5.0.4. No update available.

comment:6 Changed 2 years ago by frank

demortes, please try the latest Windows test build. There was a fix for NDIS6.

comment:7 Changed 2 years ago by Kiran Otter

I tried the latest build (Version 5.0.5 r102814) and it works!

Thank you,

Kiran

comment:8 Changed 2 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Fix is part of VBox 5.0.6.

comment:9 Changed 2 years ago by GabeF

@Kiran - is this still fixed for you?

I am able to reproduce exactly this in 5.0.6 after going to sleep/resume.

I think we might be seeing false-positive fixes due to this issue not being present when a Host adapter is newly created or Bridging Driver is newly installed.

comment:10 Changed 2 years ago by Kiran Otter

Gabe, I tested this and I too have the issue where the NIC doesn't connect after the host has been asleep. If I click the icon at the bottom to disconnect, and then connect the network adapter, it does work.

Kiran

comment:11 Changed 2 years ago by GabeF

Issues Duplicated here: https://www.virtualbox.org/ticket/14676

  • In which I discovered this appeared to begin starting with version 4.3.30.

I can reliably reproduce on my laptop with sleep/resume.

My best workaround is to disable power management on the network interface.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use