VirtualBox

Ticket #14296 (assigned defect)

Opened 4 years ago

Last modified 23 months ago

Failed to create COM object - 0x80040154

Reported by: Circa Owned by: pentagonik
Component: other Version: VirtualBox 5.0.0
Keywords: 0x80040154 Cc:
Guest type: other Host type: Windows

Description

When I try to run a Virtual Machine I get this error:

Failed to create the VirtualBoxClient COM object.
The application will now terminate.
Details:
Callee RC: 
REGDB_E_CLASSNOTREG (0x80040154)

After the error the Virtual Machine will not start. The current virtual machine is a newly created Windows 8.1, but nothing has been installed yet because it won't launch. Host is Windows 7 x64 and I am running VirtualBox 5.0.0

I've tried repairing my .net with dotNETfx. I have also tried re-registering the VBoxSvc. I did a full reinstall and deleted the virtual box folders in C:\Users\UserName\

This error was occurring in the most recent stable 4.x version.

I have a forum thread open here:  https://forums.virtualbox.org/viewtopic.php?f=6&t=68992

I will keep trying to fix it on my own, but any help is appreciated.

Attachments

VBox_Logs.zip Download (200.8 KB) - added by kirsche40 4 years ago.
Logs from update to v5.0.12
VBox_Logs2.zip Download (203.3 KB) - added by kirsche40 4 years ago.
new Log files
VBoxHardening.log Download (224.3 KB) - added by JCZ 3 years ago.

Change History

comment:1 Changed 4 years ago by Circa

I reinstalled virtualbox and now the program won't launch without an error. In order to have the program open, I have to set it to Windows Vista (SP2) compatibility mode. Even after using compatibility mode, the virtual machine still give the(0x80040154)error and won't open.

I tried removing all dotNet framwork, leaving me at 3.5 built in to Windows 7. Then reinstalling dotNET 4.5.2. It still didn't fix the problem.

I am so lost as how to fix this.

comment:2 Changed 4 years ago by Circa

Well, I did an In-Place/Upgrade install of Windows.

The problem was resolved after that.

I can't close this ticket but the in place upgrade resolved the issue.

comment:3 Changed 4 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

comment:4 Changed 4 years ago by Wickwicky

How do i fix the COM object error? I can't open ViritualBox and i don't know how to fix it. Can someone help me? I'm using the latest version of Viritualbox.

Wickwicky

Last edited 4 years ago by Wickwicky (previous) (diff)

comment:5 Changed 4 years ago by PasseMoiL'Thé

  • Status changed from closed to reopened
  • Resolution fixed deleted

I reopened the ticket since no clear solution has been proposed yet (how to make a free in-place/upgrade install of Windows?)

comment:6 Changed 4 years ago by PasseMoiL'Thé

I managed to use VirtualBox by launching the app as an admin.

comment:7 Changed 4 years ago by kirsche40

I am affected by the same issue. I did not change anything on my installed windows host. The last change was done by Linux Guest installing a new kernel.

I fixed this Show Stopper by starting VBox on Windows with administrator rights. After that the issue vanished.

I got an idea of what went wrong reading following article:

 http://www.kirtrainford.co.uk/fix-failed-create-virtualbox-com-object-regdb_e_classnotreg-0x80040154/

 https://superuser.com/questions/155999/virtual-box-portable-will-not-start

Why is VBox trying to re-register an already registered COM object?

Last edited 4 years ago by kirsche40 (previous) (diff)

comment:8 Changed 4 years ago by frank

VirtualBox should not be started as Admin for security reasons. Unfortunately the reason for this problem is still unknown. VirtualBox registers it's COM server once during installation and then never again (unless it is re-installed or upgraded). I also want to underline that we do NOT support VirtualBox portable.

comment:9 Changed 4 years ago by kirsche40

Neither do I use VBox Portable nor did I re-install/update VBox.

Today unfortunately I am not able to use my workaround anymore. Regardless administrator rights I still get the Error-Message:

Das COM-Objekt für VirtualBox konnte nicht erzeugt werden. Die Anwendung wird nun beendet. Callee RC:REGDB_E_CLASSNOTREG (0x80040154)

I have no idea why this error occurs because I did not change anything since yesterday.

This is now a show stopper!

comment:10 Changed 4 years ago by frank

Which version of VBox are you using? VBox 5.0.12 contains a fix which could help here.

If you still have problems with 5.0.12, do the instructions in comment:41:ticket:12087 help?

comment:11 Changed 4 years ago by kirsche40

Uh, I forget to mention the version. Currently I am on VBox 5.0.10.104061. I will try 5.0.12 now.

The instruction in your link does not apply to me because my first CLSID at this path in registry is HKEY_CURRENT_USER\Software\Classes\CLSID\{3560575F-7C2D-48AE-AB45-DAD430A95EBE}.

[Update]

I uninstalled v5.0.10 which takes a very long time. 30 minutes are much to long! I have a SSD and no other program ever takes such a long time even if I had an HDD before switching to an SDD. Installation of v5.0.12 did also need a very long time. The progress bar stucks at the very first beginning and did show the first progress after nearly 10 minutes. Windows eventmgr shows me following errors:

Fehler beim Erstellen des Wiederherstellungspunkts (Prozess = C:\windows\system32\msiexec.exe /V; Beschreibung = Removed Oracle VM VirtualBox 5.0.10; Fehler = 0x81000101).

Fehler beim Erstellen des Wiederherstellungspunkts (Prozess = C:\windows\system32\msiexec.exe /V; Beschreibung = Installed Oracle VM VirtualBox 5.0.12; Fehler = 0x81000101).

Nevertheless VBox 5.0.12 started once. After closing it does not start anymore. I did a reboot and now I get the same error even when starting with administrator rights!

Das COM-Objekt für VirtualBox konnte nicht erzeugt werden. Die Anwendung wird nun beendet. Callee RC:REGDB_E_CLASSNOTREG (0x80040154)

Even https://www.virtualbox.org/ticket/12087#comment:52 does not apply to me because I have no garbaged InprocServer32 entry.

Last edited 4 years ago by kirsche40 (previous) (diff)

Changed 4 years ago by kirsche40

Logs from update to v5.0.12

comment:12 Changed 4 years ago by kirsche40

What the heck... I was searching for a workaround for this issue. After nearly 20 minutes without changing anything on my host system I tried again to start VBox Manager and it started approximately after 5 seconds.

My further investigations are showing that the issue returns after reboot of my Windows-host.

comment:13 Changed 4 years ago by kirsche40

The following forum entry does not apply to me. Are these keys necessary?

 https://forums.virtualbox.org/viewtopic.php?f=6&t=69446&p=345769&hilit=0x80040154#p345769

comment:14 Changed 4 years ago by kirsche40

And another update. The issue vanishes again when running the freshly booted system for some time.

Update: The time between Windows start, first unsuccessful try and successful retry to run VBox is round about 10 minutes.

Last edited 4 years ago by kirsche40 (previous) (diff)

comment:15 Changed 4 years ago by kirsche40

Another Update. I found following entry in eventmgr:

<System>

<Provider Name="Microsoft-Windows-DistributedCOM" Guid="{1B562E86-B7AA-4131-BADC-B6F3A001407E}" EventSourceName="DCOM" /> <EventID Qualifiers="49152">10010</EventID> <Version>0</Version> <Level>2</Level> <Task>0</Task> <Opcode>0</Opcode> <Keywords>0x80000000000000</Keywords> <TimeCreated SystemTime="2016-01-14T14:29:50.000000000Z" /> <EventRecordID>39176</EventRecordID> <Correlation /> <Execution ProcessID="0" ThreadID="0" />

...

</System>

  • <EventData> <Data Name="param1">{B1A7A4F2-47B9-4A1E-82B2-07CCD5323C3F}</Data> </EventData> </Event>

The registry entry links to "c:\Program Files\Oracle\VirtualBox\VBoxSVC.exe"

IMHO the final question is: who is trying and why is VBoxSVC.exe registered again?

comment:16 Changed 4 years ago by kirsche40

New additional information:

1) I become aware, that my system has high CPU load on startup which comes from svchost.exe.

2) I detected that I am unable to see properties of VBox Host-Only-Network adapter. This is only possible after some time (round about 5 minutes after system start). Oh, and the VBox Host-Only-Network adapter is only shown under Adapters. I remember a VBox-connection in Network manager when using VBox 4.3.12.

3) CPU Load shrinks to 25% when I am able to see properties of VBox Host-Only-Network adapter.

4) I deactiated IPv6 for VBox Host-Only-Network adapter but the behavior does not change.

5) Cleaning temp folders according to  https://forums.virtualbox.org/viewtopic.php?f=8&t=65838&hilit=0x80040154&start=30#p325468 does not fix the issue.

Last edited 4 years ago by kirsche40 (previous) (diff)

Changed 4 years ago by kirsche40

new Log files

comment:17 Changed 4 years ago by kirsche40

According to my new logs it seems VBox has a critical error in its Wrapper.

First I got an unknown exception:

ERROR [COM]: aRC=E_FAIL (0x80004005) aIID={4afe423b-43e0-e9d0-82e8-ceb307940dda} aComponent={MediumWrap} aText={Unknown exception

Then VBox tries to Wrap a Media with drive letter F: which holds currently nothing. But if I I attach my usb stick to the system it will be connected as drive letter F:.

F:\tinderbox\win-5.0\out\win.amd64\release\obj\VBoxAPIWrap\MediumWrap.cpp[2245] (long __cdecl MediumWrap::GetEncryptionSettings(unsigned short **,unsigned short **))}, preserve=false aResultDetail=0

A second try?

ERROR [COM]: aRC=E_FAIL (0x80004005) aIID={4afe423b-43e0-e9d0-82e8-ceb307940dda} aComponent={MediumWrap} aText={Unknown exception
F:\tinderbox\win-5.0\out\win.amd64\release\obj\VBoxAPIWrap\MediumWrap.cpp[2245] (long __cdecl MediumWrap::GetEncryptionSettings(unsigned short **,unsigned short **))}, preserve=false aResultDetail=0

This one is a bogus error. This comes from the fact that I have 2 VMs with only one difference - an additional or missing USB2Ethernet Device. The VM itself is the same.

ERROR [COM]: aRC=VBOX_E_OBJECT_IN_USE (0x80bb000c) aIID={4afe423b-43e0-e9d0-82e8-ceb307940dda} aComponent={MediumWrap} aText={Medium 'C:\JD_CZJ\virtualBox\Debian 6\Debian\Debian_40GB.vdi' cannot be closed because it is still attached to 2 virtual machines}, preserve=false aResultDetail=0

Same as above but Debian 7 instead of Debian 6.

ERROR [COM]: aRC=VBOX_E_OBJECT_IN_USE (0x80bb000c) aIID={4afe423b-43e0-e9d0-82e8-ceb307940dda} aComponent={MediumWrap} aText={Medium 'C:\JD_CZJ\virtualBox\Debian 7\Debian7\Debian7.vdi' cannot be closed because it is still attached to 2 virtual machines}, preserve=false aResultDetail=0

Final Error which prevents VBox from startup.

ERROR [COM]: aRC=E_ACCESSDENIED (0x80070005) aIID={0169423f-46b4-cde9-91af-1e9d5b6cd945} aComponent={VirtualBoxWrap} aText={The object is not ready}, preserve=false aResultDetail=0

comment:18 Changed 4 years ago by kirsche40

I recommend setting references to following issues as I can see the same behavior on my machine:

https://www.virtualbox.org/ticket/14218
https://www.virtualbox.org/ticket/11767

and maybe

https://www.virtualbox.org/ticket/11325

I am currently investigating the latter...

comment:19 Changed 4 years ago by kirsche40

The issue vanished after receiving a bunch of MS Office 2013 updates triggered by our IT-department and repairing my current configuration by using

C:\Windows\SysWOW64\CCM\SMSCFGRC.cpl > Components > Repair

I have no idea if this tool is available on regular Win7.

comment:20 Changed 4 years ago by pentagonik

When upgrading to latest 5.0.18 (or even just to 5.0.16), did the issue happen again?

comment:21 Changed 3 years ago by vad

I installed VirtualBox 5.1.18, upgrade over 4.x and the error happened right away when I started a virtual machine.

I was able to fix it by the renaming (or removing) two values in the registry:

HKEY_CLASSES_ROOT\CLSID\{00020420-0000-0000-C000-000000000046}\InprocServer32\InprocServer32

and

HKEY_CLASSES_ROOT\CLSID\{00020424-0000-0000-C000-000000000046}\InprocServer32\InprocServer32

These values contained so called Darwin descriptors, which is Windows Installer-related advertising information that tells that this registry key is part of a product whose feature (in my case called "gx3fullclient") is encoded in the value, and can be self-repaired by running repair installation of that product (more at  https://msdn.microsoft.com/en-us/library/aa302344.aspx). Removing Darwin descriptor does not do any damage, just removes self-repair possibility, which for a core Windows COM library such as this one probably should not be specified anyways.

In case Virtualbox developers are still working on this problem - even if Darwin descriptor (put in by some installed product) is excessive, it should not be causing failures.

comment:22 Changed 3 years ago by GeWe

just uninstalled and reinstalled virtualbox 5.0.18. uninstalled removed Users/<username>/.Virtualbox reinstalled

still the same error

Callee RC: REGDB_E_CLASSNOTREG (0x80040154)

host windows 10, x64

and as mentioned elsewhere, it started either after virtualbox upgrade, but more likely, after some windows update

comment:23 Changed 3 years ago by pentagonik

@vad Interesting finding! Yes, we're still working on the issue, but unfortunately we're unable to reproduce this locally so far. I'll also have a look at this.

@GeWe Could you please try vad's workaround, whether this also helps in your case? Thanks!

comment:24 follow-up: ↓ 25 Changed 3 years ago by pentagonik

  • Owner set to pentagonik
  • Status changed from reopened to assigned

comment:25 in reply to: ↑ 24 Changed 3 years ago by GeWe

Replying to pentagonik: I have tried @vad solution of removing the InProcServer32-entries, but unfortunately no luck. Still the same error from vb 5.0.18.

Last edited 3 years ago by GeWe (previous) (diff)

comment:26 Changed 3 years ago by pentagonik

@GeWe You did re-install 5.0.18 after removing those entries, correct?

comment:27 Changed 3 years ago by ulysses Fonseca

I'm also with this problem, since desisntalei virtualbox completely blacked out all I could respect him, I installed previous versions that were running and yet could not solve. one thing I noticed is that stopped working after I needed to use com2 of my machine, I know it has to do. The worst is that I have several jobs that require the virtual machine so that I can develop, and now I'm stuck. This problem is causing me a lot of headaches. I need a solution as soon as possible.

When I put in compatibility mode with windows xp or vista virtualbox opens, but the machine does not. The worst is that it seems a problem already identified prior to version 5.0, but with no solution so far.

comment:28 Changed 3 years ago by ulysses Fonseca

One more thing the operation to clear the records and reinstall vbox did not work on my.

comment:29 Changed 3 years ago by wardow

After days of research I have finally found the cause of the issue, it is described here:  https://blogs.technet.microsoft.com/askperf/2009/04/13/wmi-rebuilding-the-wmi-repository/

I have debugged VirtualBox and analysed the objects it was waiting for and finally found it was related to the WMI database being corrupted.

I have then followed this tutorial to repair the WMI database  https://support.software.dell.com/vworkspace/kb/88861

if you're stuck at the last command with the for thingy, just replace en-US with your locale language identifier, just lookup the folder C:\Windows\System32\Wbem and there should be a folder with alot of .mfl files just adapt the command.

It is not neccessarry to process the last instruction, restart the Data Collector.

Trust me I had an hassle finding this out.

comment:30 Changed 3 years ago by QCesarJr

Hello All,

I've tried ALL of these suggestions, and none of them work.

I've gone back to version 4.3, still the same issue.

If I start VIrtualBox in Compatibility mode for Vista SP2, I can get the GUI to run, but I can't get a VM to start. This is on 2, freshly imaged machines here at work. Driving me crazy!

Any additional possible solutions?

Thanks.

comment:31 in reply to: ↑ description ; follow-up: ↓ 32 Changed 3 years ago by Kc sams

Replying to Circa:

I was able to fix my error by renaming vboxsvc.exe file in main directory of virtualbox to vboxsvc-.exe

comment:32 in reply to: ↑ 31 Changed 3 years ago by QCesarJr

Replying to Kc sams:

Replying to Circa:

I was able to fix my error by renaming vboxsvc.exe file in main directory of virtualbox to vboxsvc-.exe

I'm not quite sure how that would fix it. In fact, I assumed that it would not even try starting because there are probably hard-coded references to vboxsvc.exe. That's exactly what happened when I tried renaming it. It's not even starting up to throw the error now.

If this is really how you fixed it, can you elaborate on what exactly you did?

comment:33 Changed 3 years ago by zacmarco

Hi everyone,

I join the vast community of people who have this problem, and I've had it with any VBox release I've tried in the past two years.

We definitely need some of the Oracle engineers to find out a reasonable solution, as I can see there are plenty of people who couldn't actually even run it (including myself), and this is a serious issue. Why no real analysis coming from Oracle in 10 months?

If you have anything you want us to try, please let us know, I'd be very happy to help you in the analysis, but I would avoid trying all the experiments made by other people, this is systematic Vbox issue that is very easy to replicate (outside Oracle), and so we really expect Oracle engineers to work on it.

@pentagonik: I am definitely OK to share with you all the logs or registry keys that are needed to debug, but please formulate exactly what you need. Also, could you please do an extensive analysis of the proposed suggestions? I wouldn't do any experiment that might disrupt the system, so I need to be very careful of what I do here.

Just to let you know, I'm on Win7 SP1, any VBOX release (4.x and 5.x) have the same problem. It appeared the first time after a Vbox upgrade (both old and new releases in the 4.x train).

Thanks in advance for your help, and sorry for the pressure, but I'm getting very frustrated by this very old problem (and I guess it's the same for the other guys).

Kind Regards

Marco

comment:34 Changed 3 years ago by pentagonik

@Marco: We still are unable to reproduce this error on the systems locally here. What really would help is getting hands on a system where this error actually occurs. Would you be able to provide a VM from your system so that we can have a look at this?

It would be nice if you could provide us the system as a "VHD image", which can be created with a tool from Microsoft and be downloaded from [1]. On that website you'll also find the instructions about how to create such an image. Once created, please let me know if you have an appropriate location where you can put it for me to download, or if you need assistance in that case.

[1]  https://technet.microsoft.com/en-us/library/ee656415.aspx

comment:35 Changed 3 years ago by insooth

You can reproduce this error in the way I have reproduced it in my Windows 7 this morning: zero bytes left on my C drive, so that after reboot C:\Users\%USERNAME%.%USERDOMAIN%\.VirtualBox\VirtualBox.xml was empty. I did a copy of VirtualBox.xml-prev into VirtualBox.xml and everything has started to work as it should. No more CLASSNOTREG error!

comment:36 Changed 3 years ago by zacmarco

@Pentagonik: thanks for the offer, the problem is that due to sensible data being on this PC (that is not my property anyway), I cannot offer you remote access or HD copy, sorry about that. But if you want me to collect data related to VBox just feel free to ask, I'd be more than happy to help.

Thanks!

Marco

comment:37 Changed 3 years ago by zacmarco

@insooth: please read the rest of the discussion, we have already tried several times to completely uninstall and clean-up all the user data prior to reinstalling (including removing everything that is in .Virtualbox), the issue is not that simple, what you are seeing is not the same problem.

Thanks

Marco

comment:38 Changed 3 years ago by verenion

I too am getting this issue, after deleting my .virtualbox folder, registry entries, rebuilding MS database, and literally, anything else I can find to try and solve this.I now have no logs files I can even send / post. I think the only way of solving this, is to completely re-install my windows installation, and as this is a work machine, that's not ideal.

Not really sure how I can help with this issue, without any logs or anything?

comment:39 Changed 3 years ago by pentagonik

@Marco: Too bad, but absolutely understandable!

As we still cannot reproduce this locally here, we're still seeking for a P2V image where this error actually occurs. Anyone else who can provide us that image?

comment:40 Changed 3 years ago by pentagonik

We're still seeking for a P2V image so that we can reproduce (and fix) this bug. Anyone else willing to help out here?

comment:41 Changed 3 years ago by alee

The issue seems to be a corruption of the VirtualBox.xml file in the ~/.homestead folder. Go to this folder delete the VirtualBox.xml file, copy and rename the VirtualBox.xml-prev to VirtualBox.xml-prev and save. Try running VB again and this should resolve the issue. At least it has for me on 2 separate occasions. FYI this happened after I deleted a box and restarted my computer. VirtualBox.xml is just completely blank. .xml file locked while trying to write to it?

Last edited 3 years ago by alee (previous) (diff)

comment:42 Changed 3 years ago by zacmarco

Hi Alee,

sorry but I tried this several times, I've also uninstalled VBOX, then deleted the file, and finally re-installed it. Nothing changes, it doesn't seem to be related to that file.

Thanks

Marco

comment:43 Changed 3 years ago by JCZ

I havent used VBox for a couple months but did upgrade to the 5.1.2 version. I had no previous issues with VBox but when I try to start VBox it wouldnt even start, the program just gave the error posted for this ticket. I tried unisntalling and reinstalling Vbox using the 5.1.2 and still no luck launching the program. I fully uninstalled VBox 5.1.2, rebooted my computer and reinstalled using 5.0.4. After installation the program boots and loads but my VM's were not available. After adding the VM's and trying to start one I get the following error..


Failed to create the VirtualBoxClient COM object.

The application will now terminate.

Callee RC: REGDB_E_CLASSNOTREG (0x80040154)


after clicking on "Ok" the following error pops up.


Failed to open a session for the virtual machine Ubuntu 12.04.

The virtual machine 'Ubuntu 12.04' has terminated unexpectedly during startup with exit code 1 (0x1). More details may be available in 'C:\Users\jzajicek\VirtualBox VMs\Ubuntu 12.04\Logs\VBoxHardening.log'.

Result Code: E_FAIL (0x80004005) Component: MachineWrap Interface: IMachine {f30138d4-e5ea-4b3a-8858-a059de4c93fd}


I have tried with all of the OS VM's I have used previously witht the same 2 errors. I have attached the hardening log.

Last edited 3 years ago by JCZ (previous) (diff)

Changed 3 years ago by JCZ

comment:44 Changed 3 years ago by larkin

Same problem after upgrade to 5.1.2

--8<-- Failed to create the VirtualBoxClient COM object. The application will now terminate.

Callee RC: NS_ERROR_ABORT (0x80004004) --8<--

Host: Ubuntu 16.04.1 LTS

comment:45 Changed 3 years ago by UNIXSPOD

Same here, OpenSuse 13.1

Failed to create the VirtualBoxClient COM object. The application will now terminate.

Callee RC: NS_ERROR_ABORT (0x80004004)

This was after a failed update to 5.1-5.1.4 (which had unresolved symbols in the main shared library) and a subsequent roll back to 5.0-5.0.26, DKMS worked, kernel modules loaded, but the binary fails with the same error regardless.

comment:46 Changed 3 years ago by frank

For all users who experience this behavior on a Linux host: I would like to see a core dump because I'm pretty sure that some process, perhaps VBoxSVC, is crashing.

comment:47 Changed 3 years ago by UNIXSPOD

I don't have a core file, it's not crashing, it doesn't even run:

sh -x virtualbox
+ PATH=/usr/bin:/bin:/usr/sbin:/sbin
+ CONFIG=/etc/vbox/vbox.cfg
+ test -r /etc/vbox/vbox.cfg
+ test -z ''
+ test -f /usr/lib/virtualbox/VirtualBox
+ test -x /usr/lib/virtualbox/VirtualBox
+ INSTALL_DIR=/usr/lib/virtualbox
+ '[' '' = shutdown ']'
+ lsmod
+ grep -q vboxdrv
+ '[' '!' -c /dev/vboxdrv ']'
+ '[' -f /etc/vbox/module_not_compiled ']'
++ grep VBoxSVC
++ awk '{ print $1 }'
+++ whoami
++ ps -U root
+ SERVER_PID=
+ '[' -z '' ']'
+ '[' -n root ']'
+ rm -rf /tmp/.vbox-root-ipc
+ '[' '' = true ']'
++ basename virtualbox
+ APP=virtualbox
+ case "$APP" in
+ exec /usr/lib/virtualbox/VirtualBox

at this point it puts up a message box with the error

# lsmod |grep -i vbox
vboxpci                28672  0 
vboxnetadp             28672  0 
vboxnetflt             32768  0 
vboxdrv               479232  3 vboxpci,vboxnetadp,vboxnetflt
# service --status-all |grep -i vbox
vboxautostart-service.service                                                         loaded active exited  vboxautostart-service.service
vboxballoonctrl-service.service                                                       loaded active exited  vboxballoonctrl-service.service
vboxdrv.service                                                                       loaded active exited  VirtualBox Linux kernel module
vboxweb-service.service                                                               loaded active exited  vboxweb-service.service

Experimenting with running VBoxSVC manually does this:

# /usr/lib/virtualbox/VBoxSVC
************************************************
Oracle VM VirtualBox XPCOM Server Version 5.0.26
(C) 2004-2016 Oracle Corporation
All rights reserved.

Starting event loop....
[press Ctrl-C to quit]

The moment I run virtualbox in another window, the foreground VBoxSVC segfaults:

# /usr/lib/virtualbox/VBoxSVC
************************************************
Oracle VM VirtualBox XPCOM Server Version 5.0.26
(C) 2004-2016 Oracle Corporation
All rights reserved.

Starting event loop....
[press Ctrl-C to quit]
Segmentation fault

So this appears to be a fundamental programming error on your part as the program is trying to access memory across a byte boundary, (always a no no, no matter what architecture)

Last edited 3 years ago by UNIXSPOD (previous) (diff)

comment:48 Changed 3 years ago by frank

Did you check the output of 'dmesg' at this time? When /usr/lib/virtualbox/VirtualBox is started, this application automatically starts VBoxXPCOMIPCD and VBoxSVC. I suspect that one of these two binaries is crashing and that crash is most likely logged in the kernel log.

comment:49 Changed 3 years ago by UNIXSPOD

[332096.640023] nspr-2[5702]: segfault at 7f9be6a10228 ip 00000000005c9a91 sp 00007f95c44ac300 error 6 in VBoxSVC[400000+45d000]
[332766.209943] nspr-2[5803]: segfault at 7f07e92cc228 ip 00000000005c9a91 sp 00007f0719e88300 error 6 in VBoxSVC[400000+45d000]
[332766.326071] nspr-2[5835]: segfault at 7f5aba54a228 ip 00000000005c9a91 sp 00007f576a096300 error 6 in VBoxSVC[400000+45d000]

comment:50 Changed 3 years ago by frank

As I said above, I'm interested in such core dumps. One core dump of VBoxSVC would be sufficient for the beginning. To enable core dumps, you probably need to raise the 'ulimit -c' value to 'unlimited', see here.

comment:51 Changed 3 years ago by UNIXSPOD

My ulimit is unlimited by default, but running both procedures, on the linked page returns no core file, either by starting virtualbox on its own, or trying to manually start the VM directly. There is no core file. Even running a find on my filesystem I can find no active core file. Lots of C headers and Source code, etc, A few devices, lost of proc entries but no named core file

 # find / -name "core*" -print

comment:52 Changed 3 years ago by aeichner

Does Ubuntu employ systemd? In this case the coredump service might be active collecting the coredump. "coredumpctl list" should list all available core dumps.

comment:53 Changed 3 years ago by UNIXSPOD

I'm not running Ubuntu I'm using OpenSuse 13.1 I tried this:  https://www.novell.com/support/kb/doc.php?id=3054866 but still no core file in /var or the local directory.

# /usr/bin/systemd-coredumpctl
No coredumps found

Last edited 3 years ago by UNIXSPOD (previous) (diff)

comment:54 Changed 3 years ago by UNIXSPOD

Tried to install 5.1 via zypper/Yast and it offered two dependencies:

LibQt5OpenGL5
libQt5PrintSupport5

Which I installed.

Same error.

Remove 5.0 & 5.1, reinstalled 5.1 same error

Callee RC:
NS_ERROR_ABORT (0x80004004)

With VBoxSVC segfaulting thus:

Oracle VM VirtualBox XPCOM Server Version 5.1.4
(C) 2004-2016 Oracle Corporation
All rights reserved.

Starting event loop....
[press Ctrl-C to quit]
Segmentation fault

I tried to run it through gdb, but cannot find debugging symbols for my system. Do you have debugging symbols to match: VirtualBox-5.1-5.1.4_110228_openSUSE132-1.x86_64 ??

comment:55 follow-up: ↓ 56 Changed 3 years ago by aeichner

Use the generate-core-file command for gdb to write a core file and provide us the dump please. We can then investigate where the crash happens.

comment:56 in reply to: ↑ 55 Changed 3 years ago by UNIXSPOD

Replying to aeichner:

Use the generate-core-file command for gdb to write a core file and provide us the dump please. We can then investigate where the crash happens.

I need debuginfo:

# gdb /usr/lib/virtualbox/VirtualBox
GNU gdb (GDB; devel:gcc) 7.11.1
Copyright (C) 2016 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.  Type "show copying"
and "show warranty" for details.
This GDB was configured as "x86_64-suse-linux".
Type "show configuration" for configuration details.
For bug reporting instructions, please see:
<http://bugs.opensuse.org/>.
Find the GDB manual and other documentation resources online at:
<http://www.gnu.org/software/gdb/documentation/>.
For help, type "help".
Type "apropos word" to search for commands related to "word"...
Reading symbols from /usr/lib/virtualbox/VirtualBox...(no debugging symbols found)...done.
Missing separate debuginfos, use: zypper install VirtualBox-5.1-debuginfo-5.1.4_110228_openSUSE132-1.x86_64
(gdb) generate-core-file
You can't do that without a process to debug.

Last edited 3 years ago by UNIXSPOD (previous) (diff)

comment:57 follow-up: ↓ 58 Changed 3 years ago by frank

You can download the corresponding debuginfo package here.

comment:58 in reply to: ↑ 57 Changed 3 years ago by UNIXSPOD

Replying to frank:

You can download the corresponding debuginfo package here.

Cheers will install and let you know.

comment:59 Changed 3 years ago by UNIXSPOD

I tried to upload the file but it's 150MB, got an FTP server?

comment:60 follow-up: ↓ 62 Changed 3 years ago by frank

I cannot provide an FTP server. Please contact me via private mail at frank _dot_ mehnert _at_ oracle _dot_ com. You could upload the core dump to a server of your choice and provide me the URL so I can fetch it.

comment:61 Changed 3 years ago by UNIXSPOD

OK, we have a transfer system here, I'll use that, you should get email. Once the Windows people return from Lunch :)

comment:62 in reply to: ↑ 60 Changed 3 years ago by UNIXSPOD

Replying to frank:

I cannot provide an FTP server. Please contact me via private mail at frank _dot_ mehnert _at_ oracle _dot_ com. You could upload the core dump to a server of your choice and provide me the URL so I can fetch it.

You should get an email :)

comment:63 Changed 3 years ago by frank

Got an email but I cannot connect to the provided URL, it times out. The URL is not invalid but there is just no response...

comment:64 Changed 3 years ago by UNIXSPOD

OK, I'll look for another solution, cheers!

comment:65 Changed 3 years ago by UNIXSPOD

Frank, you should get more email, hopefully this one will work, let me know :)

comment:66 follow-up: ↓ 67 Changed 3 years ago by frank

UNIXSPOD, first, your core dump is quite big but after using a compression tool it's quite small. Using 'xz' I compressed it to 320K. How did you create this core dump -- did VBoxSVC really crash or did you force it to terminate? gdb does not show any SEGFAULT and it seems that it was just aborted during a select() syscall. I also wonder why you installed the openSUSE 13.2 package on openSUSE 13.1 (we also provide an openSUSE 13.1 package for 5.0.26).

comment:67 in reply to: ↑ 66 Changed 3 years ago by UNIXSPOD

Replying to frank:

UNIXSPOD, first, your core dump is quite big but after using a compression tool it's quite small. Using 'xz' I compressed it to 320K. How did you create this core dump -- did VBoxSVC really crash or did you force it to terminate? gdb does not show any SEGFAULT and it seems that it was just aborted during a select() syscall. I also wonder why you installed the openSUSE 13.2 package on openSUSE 13.1 (we also provide an openSUSE 13.1 package for 5.0.26).

It was odd, I launched VboxSVC manually, then attached to it with gdb using it's pid, told gdb to generate-core-file, then I stared virtualbox manually, nothing happened. I waited. I restarted it a few times, still nothing happened. when I quit out of gdb then VboxSVC segfaulted.

Any idea on how to do this differently gratefully received.

I got the new update on doing "zypper up" After hand installing the latest update which simply gave me a URL, then uninstalling it. It may have updated Yast.

comment:68 Changed 3 years ago by frank

Too bad that no core dump is automatically generated on your system. You should find out how this can be enabled. Unfortuntely I don't have time to investigate how this can be done on you openSUSE system.

comment:69 Changed 3 years ago by frank

Back to the original problem of this ticket (REGDB_E_CLASSNOTREG on Windows hosts): The most recent 5.0 and 5.1 test builds for Windows contains code to detect a possible reason for this problem. All users who are affected by this problem, please install the latest 5.0.x or 5.1.x test build from above and try to start a VM. In case this still does not work there should be a more detailed error message.

comment:70 Changed 3 years ago by Susi.42

Error 0x80040154 solved by installing libpng12 on my System.

Host: leap 42.2 (Suse Linux 13+) Guest: ecs (IBM OS/2)

History:

) System-partition (disk) full, home on another partition/disk

) New disk, installation of same system there - but home untouched

) home mounted on new system - to say: home shared for old and new system

) actual VirtualBox (5.1.14) installed from rpm - i.e. copy of all files/dirs

) VirtualBox is running in old system (/usr/lib/virtualbox pp unchanged)

) VirtualBox in new system: SUPR3HardendMain-error

) set userid attribut with chmod 47xx VirtualBox pp - solved

) next compile & mod kernel-module VBoxDRV with vboxsetup(?)

) clear all locks in tempfiles (/tmp/.virt-userNN)

) nethertheless COM-error:

Das COM-Objekt für VirtualBox konnte nicht erzeugt werden. Die Anwendung wird nun beendet. Callee RC:NS_ERROR_FACTORY_NOT_REGISTERED (0x80040154)

) looking here (https://www.virtualbox.org/ticket/14296) and executing COM-file

manfred@Susi:/usr/lib/virtualbox> ./VBoxSVC ./VBoxSVC: error while loading shared libraries: libpng12.so.0: cannot open shared object file: No such file or directory

) installing libpng12 and executing again

manfred@Susi:/usr/lib/virtualbox> ./VBoxSVC Oracle VM VirtualBox XPCOM Server Version 5.1.14 (C) 2004-2017 Oracle Corporation All rights reserved. Starting event loop.... [press Ctrl-C to quit]

) now VirtualBox is running on new system and old virtual installation OS/2 on NN.vbox and all snapshots NN.vdi too.

Informational: VirtualBox object created (rc=NS_OK). Informational: VirtualBox object deleted.

Whatever grafix concern : 2 shades of gray ...

comment:71 Changed 3 years ago by socratis

@Susi.42: You posted on a Windows-only problem. You do NOT have the same problem.

So, if you can, please open a new thread in the  VirtualBox on Linux Hosts section of the forums.

comment:72 Changed 3 years ago by frank

comment:70 is IMO a user error. If you copied stuff manually around then you don't need to be surprised that VirtualBox does not start. Just check the output of

ldd /usr/lib/virtualbox/components/VBoxC.so

and you will most likely observe a missing library. An error which will not happen if you install everything properly using the RPM packaging system.

comment:73 Changed 3 years ago by Erika Neri

Hi I´m Erika Neri and I solved…

In "C:\Users\UserName\.VirtualBox", Delete the archive "VirtualBox.xml", Copy and Paste the archive "VirtualBox.xml-prev" And Change the name to "VirtualBox.xml"

Ready

==

Last edited 3 years ago by Erika Neri (previous) (diff)

comment:74 Changed 3 years ago by Erika Neri

Hi I´m Erika Neri and I solved...

In "C:\Users\UserName\.VirtualBox", Delete the archive "VirtualBox.xml", Copy and Paste the archive "VirtualBox.xml-prev" And Change the name to "VirtualBox.xml"

Ready

comment:75 Changed 3 years ago by socratis

@Erika Neri

What you did has absolutely nothing to do with the Windows registry. There is no way on earth that re-creating the VirtualBox.xml fixed this specific error. This error is due to a misconfigured Windows registry key, either bad class, bad bindings or incorrectly set security access (most probably the last). The specific registry key is created/updated only during the VirtualBox installation. Re-creating the VirtualBox.xml file, I repeat, has absolutely nothing to do with that. It may have fixed/corrected other issues with your VirtualBox installation, just not this one.

comment:76 Changed 3 years ago by klaus

Socratis, this time you're underestimating the powers of VBoxSVC when it comes to producing misleading error messages. It is possible (but it should not happen!) that a broken VirtualBox.xml has this effect. In the past (up to 4.3 IIRC) any kind of VirtualBox.xml corruption caused a failure to start it, leading to such cryptic errors. Since 5.0 we totally revamped, hopefully preventing such issues, but unless we know what corruption actually can fool our improvement it's impossible to say...

comment:77 Changed 3 years ago by socratis

@Erika Neri: in light of these new "clues", I'd have to say I might have jumped the gun on this one. I'm sorry for that. My apologies...

@klaus: Wait... what??? A corrupt VirtualBox.xml could potentially produce a COM error? With the correct CLSID? Seriously? If that was the case, the least I can say is that the total revamp took a long time to materialize! Man, that can throw someone way, way off... ;)

comment:78 Changed 3 years ago by klaus

Yes, it's a sad fact. It took us a long time to realize that there's a surprising difference between COM (which VirtualBox uses on Windows) and it's partial clone XPCOM (used on all other host OSes): if the construction of the initial IVirtualBox object instance fails (and it used to fail if the config file contained rubbish), then XPCOM happily passes the detailed error description along to the user. COM loses this error information entirely (there is no technical reason whatsoever for this, there must be some place in that big black box which explicitly clears it) and simply says REGDB_E_CLASSNOTREG.

It's an error code used for all sorts of issues related to the inability to create the instance, ranging from registry screwups which means that the COM server can't be found over all sorts of VBoxSVC process start failures to this failure in the code which creates the instance.

comment:79 Changed 3 years ago by socratis

Excellent!!! The description of the problem I mean, not the problem itself. ;)

So, just to make it clear, if this error appears in VirtualBox >= 5.x.x it *is* due to COM errors in Windows, but if it's in VirtualBox < 5.x.x it can be a lot of things, including (but not limited to), a bad/rogue VirtualBox.xml, and it is cross-platform.

If that sums it up, that information will help a great deal in the triage of the reports in the forums. I'll update  the thread that @Erika posted with your response, so that it gets a more widespread audience. Thanks!

comment:80 Changed 3 years ago by klaus

There's never a clear cut black/white distinction in the real world unfortunately.

I suspect that Erika's broken VirtualBox.xml somehow made VBoxSVC crash during the initial IVirtualBox object instance construction. It may or may not be a cross-platform issue, but it makes our improved code (which intends to eliminate this error, as long as it's caused by our code) not work the way it was intended.

If there's someone out there who has a VirtualBox.xml file which makes the 5.x GUI (or anything else) fail to start with this error, we'd really appreciate if we could get the file. It is easy to test: rename VirtualBox.xml to some other name and start VirtualBox. If that works then terminate VirtualBox again and check in Task Manager that there's no process called VBoxSVC running any more. After that one can e.g. try Erika's hint of using VirtualBox.xml-prev (keeping in mind hat it's not guaranteed to be the current state of the VM registry).

Until we have an idea what's going on we can't do much.

comment:81 Changed 3 years ago by socratis

Thanks again klaus for the explanation and the instructions to keep in mind.

comment:82 follow-up: ↓ 83 Changed 3 years ago by Dagamier

So I have had this issue more than once and usually have to rip VirtualBox out, including all its directories before I can get it working. This time, working off of @Erika's post, I did two things to get it working right away:

1) Copy VirtualBox.xml-prev to VirtualBox.xml in the .VirtualBox directory in Windows 2) Copy "Ubuntu Linux.vbox-prev" to "Ubuntu Linux.vbox" in the VirtualBox VMs\Ubuntu Linux directory.

While this will be different depending on what VM you're running, I have been able to fix this for a couple of us who have had the same problem.

The important thing to note for our failures which seems a little different, is that our VM had a hard-crash (or was forced to hard crash through a Task Manager kill). Both those files were a zero byte file and replacing them allowed the machine to start up right away.

Based on this, it would be nice if VirtualBox application could do a sanity check when it was starting up and if these files are 0 byte, ask the user if they could be replaced. I don't think there are any other xml files that deal with the startup, but it could go a long way to at least providing a temporary solution until a more permanent fix is done.

Last edited 3 years ago by Dagamier (previous) (diff)

comment:83 in reply to: ↑ 82 Changed 3 years ago by socratis

Replying to Dagamier:

Based on this, it would be nice if VirtualBox application could do a sanity check when it was starting up and if these files are 0 byte, ask the user if they could be replaced.

I already opened ticket #12838 (2014-03-18) about this one, which was a workaround for #10851 (2012-08-22), which seems to be what you're talking about. Add your voice... ;)

comment:84 in reply to: ↑ description Changed 23 months ago by VirtualGuts

Solution:

REF:
 https://stopbyte.com/t/how-to-solve-virtualbox-error-callee-rc-regdb-e-classnotreg-0x80040154/17

I used Admin privileges or else I got another error:
The module VBoxC.dll was loaded but the call to DLLRegisterServer failed with error code 0x80070005.

Note: I have been copying my VirtualBox around to other drives and didn't want to keep reinstalling and this solution works fine every time.

Solution using Batch files:
Create the batch file then right click and Run as Administrator. Don't forget to change to respective paths; I'm using the D: drive. I created one for installed and another for portable version, so two different batch files but you can combine them or just use one.

First Batch file:
REM Installed-VirtualBox
D:
CD D:\Program Files\Oracle\VirtualBox
VBoxSVC /ReRegServer
regsvr32 VBoxC.dll
Exit

Second Batch file:
REM Portable-VirtualBox
D:
CD D:\VM\Virtual Box Installation\Windows 10\Portable-VirtualBox\app64
VBoxSVC /ReRegServer
regsvr32 VBoxC.dll
Exit

Replying to Circa:

When I try to run a Virtual Machine I get this error:

Failed to create the VirtualBoxClient COM object.
The application will now terminate.
Details:
Callee RC: 
REGDB_E_CLASSNOTREG (0x80040154)

After the error the Virtual Machine will not start. The current virtual machine is a newly created Windows 8.1, but nothing has been installed yet because it won't launch. Host is Windows 7 x64 and I am running VirtualBox 5.0.0

I've tried repairing my .net with dotNETfx. I have also tried re-registering the VBoxSvc. I did a full reinstall and deleted the virtual box folders in C:\Users\UserName\

This error was occurring in the most recent stable 4.x version.

I have a forum thread open here:  https://forums.virtualbox.org/viewtopic.php?f=6&t=68992

I will keep trying to fix it on my own, but any help is appreciated.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use