VirtualBox

Ticket #14292 (closed defect: invalid)

Opened 7 years ago

Last modified 3 years ago

USB 3.0 not working on Windows 7 host and CentOS guest

Reported by: ReinerB Owned by:
Component: USB Version: VirtualBox 5.0.0
Keywords: Cc:
Guest type: Linux Host type: Windows

Description

Trying to connect an ext4 formatted to a CentOS VM on a Windows 7 host does not work. The behaviour ist quite the same as already seen on VirtuaBox 4.3:

When connecting the drive to the VM there is no reaction. After waiting some minutes, do a second try. This creates the error message

Das USB-Gerät Intenso External USB 3.0 [0107] konnte nicht an die virtuelle Maschine AMHS-testvm gebunden werden.

USB device 'Intenso External USB 3.0' with UUID {b612ec21-f7a1-437a-aa73-ef251787231a} is busy with a previous request. Please try again later.

Fehlercode:E_INVALIDARG (0x80070057)
Komponente:HostUSBDeviceWrap[[BR]] Interface:IHostUSBDevice {c19073dd-cc7b-431b-98b2-951fda8eab89}
Callee:IConsole {872da645-4a9b-1727-bee2-5585105b9eed}

There are no related entries in VBox.log. VBoxSVC.log is attached. Related entries are with starting at time stamp 00:08:14

Attachments

VBoxSVC.log Download (16.9 KB) - added by ReinerB 7 years ago.

Change History

Changed 7 years ago by ReinerB

comment:1 Changed 7 years ago by Ziginox

I have the exact same problem happening on 5.0.10 r104061 with a Windows 7 64-bit host and a Windows 8.1 64-bit Virtual machine, however this only happens on my desktop. There no problem whatsoever on my laptop with the same host and guest operating systems. There is one difference in hardware, though. The laptop, a Latitude E6430, has the QM77's inbuilt USB3 XHCI host controller. I can capture USB3 and USB2 devices plugged into the USB3 ports. My desktop, an HP Z800, has an add in PCIe card with a VLI VL800 chipset. USB3 and USB2 devices won't capture when plugged into the ports on the addin card, but I can capture USB3 and USB2 devices plugged into the Z800's onboard USB2 ports.

comment:2 Changed 6 years ago by Ziginox

This still seems to be an issue with 5.0.20 r106931.

comment:3 follow-up: ↓ 4 Changed 3 years ago by fbatschu

is that still an issue with 6.0.12 ?

thanks!

comment:4 in reply to: ↑ 3 ; follow-up: ↓ 5 Changed 3 years ago by socratis

Replying to fbatschu:

is that still an issue with 6.0.12 ?

fbatschu, this has nothing to do with VirtualBox, this is 100% a host issue, independent of VirtualBox. Windows 7 does not have native support for USB3. You need to install special drivers to get it going.

As for the OP's "Busy with a previous request", that's a completely different issue; the HD was already captured by the host, and since you can't have shared USB devices, you're getting that message.

For all things USB, please read the following thread:  USB basics and troubleshooting, the answer is most probably already there. And if it's not, I'll make sure that I get it in there! :)

comment:5 in reply to: ↑ 4 Changed 3 years ago by fbatschu

Replying to socratis:

Replying to fbatschu:

is that still an issue with 6.0.12 ?

fbatschu, this has nothing to do with VirtualBox, this is 100% a host issue, independent of VirtualBox. Windows 7 does not have native support for USB3. You need to install special drivers to get it going.

As for the OP's "Busy with a previous request", that's a completely different issue; the HD was already captured by the host, and since you can't have shared USB devices, you're getting that message.

For all things USB, please read the following thread:  USB basics and troubleshooting, the answer is most probably already there. And if it's not, I'll make sure that I get it in there! :)

Thanks a lot socratis! For the reply here and the USB compendium! you created in the forum.

I'll close as not a bug.

comment:6 Changed 3 years ago by fbatschu

  • Status changed from new to closed
  • Resolution set to invalid
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use