VirtualBox

Ticket #14281 (new defect)

Opened 7 years ago

Last modified 7 years ago

Mac OS X Installer can't install because VirtualBox is running

Reported by: damnhandy Owned by:
Component: installer Version: VirtualBox 4.3.30
Keywords: Cc:
Guest type: all Host type: Mac OS X

Description

In trying to upgrade Boot2Docker this morning, I ran into an issue where the installer would not proceed as it claimed VirtualBox was still running. I then tried to install VirtualBox 4.3.30, upgrading from 4.3.28, and the VirtualBox installer was gated on the same issue asking me to stop all VMs and processes. A quick process check showed the following:

mbp:~ me$ ps aux | grep VB
me             1135   0.2  0.0  2451240   7088   ??  S     7:10AM   0:00.05 /Applications/VirtualBox.app/Contents/MacOS/VBoxXPCOMIPCD
me             1137   0.2  0.1  2532164  11260   ??  S     7:10AM   0:00.13 /Applications/VirtualBox.app/Contents/MacOS/VBoxSVC --auto-shutdown
me             1147   0.0  0.0  2450180    684 s000  S+    7:10AM   0:00.00 grep VB

If I kill the processes using kill -9, the installer then works. I am running on Mac OS X 10.10.4. I am not sure if this is an issue with the 4.3.30 installer or if it's an issue with 4.3.28 with lingering processes?

Change History

comment:1 Changed 7 years ago by klaus

Is there any API client running, like something which manages your Boot2Docker VMs? There's no easy way to find them (they have an open local domain socket to VBoxXPCOMIPCD), but going over the processes running as "me" should usually bring up some suspects already.

There's no known VBoxSVC shutdown hang in 4.3.28 - the check happens before anything new gets installed.

comment:2 Changed 7 years ago by frank

  • priority changed from blocker to major
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use