VirtualBox

Ticket #14269 (reopened defect)

Opened 5 years ago

Last modified 7 weeks ago

Error relaunching VirtualBox VM process: 5

Reported by: sombra Owned by:
Component: other Version: VirtualBox 5.1.8
Keywords: supR3HardenedWinRepSpawn Error relaunching process: 5 Cc: socaltom10
Guest type: Linux Host type: Windows

Description

Unable to run guest VM using latest OVM 5.0 release. See attached screenshot for details.

Attachments

error.PNG Download (14.5 KB) - added by sombra 5 years ago.
error in supR3HardenedWinReSpawn
error2.png Download (19.3 KB) - added by michael 4 years ago.
Error image from ticket #16125
VBoxHardening.log Download (174.7 KB) - added by narendra 7 weeks ago.

Change History

Changed 5 years ago by sombra

error in supR3HardenedWinReSpawn

comment:1 Changed 5 years ago by sombra

I rolled back all the way to VirtualBox-4.3.12-93733-Win.exe. Note that this bug traces the problem to AntiVirus related issues. Granted, *dos machines will certainly have AV at the workplace. Therefore, this bug is not only annoying but also makes VirtualBox useless at the corporate level because a) corporate users cannot disable AV nor b) even if we could disable AV, most users with a bit of brain won't disable AV.

comment:2 Changed 4 years ago by frank

  • Status changed from new to closed
  • Resolution set to obsolete

comment:3 Changed 4 years ago by michael

  • Status changed from closed to reopened
  • Version changed from VirtualBox 5.0.0 to VirtualBox 5.1.8
  • Resolution obsolete deleted

From ticket #16125, opened by socaltom10:

I am experiencing the exact same problem with VirtualBox 5.1.8 I just downloaded from your site. I loaded VB tried to initiate a Linux MINT client and got the error. Have tried other LINUX version all with same result. I removed VB and re-loaded it. Same problem. I downloaded VB again. Loaded it and got the same problem. I run VMware V8.04 workstation successfully on this computer. My OS is Windows 7. My Antivirus is Symantec Endpoint Protection 12.1. Hard drive is encrypted via Symantec Endpoint Encryption client. CPU is Intel i5 with 8 GB RAM. Is there a fix or work around? Thanks

Last edited 4 years ago by michael (previous) (diff)

Changed 4 years ago by michael

Error image from ticket #16125

comment:4 Changed 4 years ago by michael

  • Cc socaltom10 added

Added socaltom10 to CC list.

comment:5 Changed 2 years ago by Vbox-User

I am experiencing the same problem with Virtualbox ver 5.2.12 running on Windows 7 and having Kaspersky antivirus ver 19.0.0.1088. Any guest vm does not run and display the error described in this ticket.

comment:6 Changed 2 years ago by socratis

Please read really carefully the following FAQ:  Diagnosing VirtualBox Hardening Issues for some generic guidelines/ideas. Remember, these are guidelines, not the exact solution, you have to use your judgement...

Again, this is your *host's* installed application interfering with VirtualBox. VirtualBox can do nothing but simply indicate that you have deeper issues with the installed programs *on your host*. You got to address them, by either uninstalling them, or (in the case of antivirus) tell your antivirus to keep their nose out of other processes' business, until they're properly signed.

Changed 7 weeks ago by narendra

comment:7 follow-up: ↓ 8 Changed 7 weeks ago by narendra

Hi All,

You all doing well, I am getting the same issue in 6.1.4 version and already tried the above solutions but the issue is still the same. for now, I need to reinstall the VM every time. please suggest me some permanent solution. windows: 10 kindly refer to the log file.

Regards, Narendra Kumar

comment:8 in reply to: ↑ 7 Changed 7 weeks ago by fbatschu

Replying to narendra:

Hi All,

You all doing well, I am getting the same issue in 6.1.4 version and already tried the above solutions but the issue is still the same. for now, I need to reinstall the VM every time. please suggest me some permanent solution. windows: 10 kindly refer to the log file.

Regards, Narendra Kumar


So the specific hardening error in your case is from your log:
https://www.virtualbox.org/attachment/ticket/14269/VBoxHardening.log

760.4d0: '\Device\HarddiskVolume3\Windows\System32\ntdll.dll' has no imports
760.4d0: supHardenedWinVerifyImageByHandle: -> 0 (\Device\HarddiskVolume3\Windows\System32\ntdll.dll)
760.4d0: supR3HardenedWinVerifyCacheInsert: \Device\HarddiskVolume3\Windows\System32\ntdll.dll
760.4d0: supR3HardenedMonitor_LdrLoadDll: pName=C:\windows\System32\ntdll.dll (Input=ntdll.dll, rcNtResolve=0xc0150008) 
*pfFlags=0x0 pwszSearchPath=0000000000000801:<flags> [calling]
760.4d0: supR3HardenedMonitor_LdrLoadDll: returns rcNt=0x0 hMod=00007ffc82980000 'C:\windows\System32\ntdll.dll'
760.4d0: Error -104 in supR3HardenedWinReSpawn! (enmWhat=5)
760.4d0: Error relaunching VirtualBox VM process: 5
Command line: '60eaff78-4bdd-042d-2e72-669728efd737-suplib-3rdchild --comment ORCL-2020x 
--startvm 355bc22c-9596-422a-8a8e-1e6cd6672aa9 --no-startvm-errormsgbox "--sup-hardening-log=C:\Users\naku01\VirtualBox 
VMs\cloud\ORCL-2020x\Logs\VBoxHardening.log"'
...
4e0.2bb0: supR3HardNtChildWaitFor[1]: Quitting: ExitCode=0x1 (rcNtWait=0x0, rcNt1=0x0, rcNt2=0x103, rcNt3=0x103, 8468 ms, the end);

though I don't know either what we should do with and about it.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use