VirtualBox

Ticket #14088 (closed defect: obsolete)

Opened 5 years ago

Last modified 7 months ago

Guru Meditation after running a few hours

Reported by: AdrianPeterSmith Owned by:
Component: other Version: VirtualBox 4.3.26
Keywords: Cc:
Guest type: other Host type: other

Description

See attached log file

Attachments

VBox.log Download (292.9 KB) - added by AdrianPeterSmith 5 years ago.
VBox.2.log Download (292.3 KB) - added by AdrianPeterSmith 5 years ago.
another example
VBox.3.log Download (292.3 KB) - added by AdrianPeterSmith 5 years ago.
and another
tasks.png Download (121.9 KB) - added by AdrianPeterSmith 5 years ago.
VBox.4.log Download (488.0 KB) - added by Raster 5 years ago.
Log from 4.3.28 crash
VBox.log.gz Download (82.1 KB) - added by Raster 5 years ago.
Another crash of 4.3.28 with possibly more info.

Change History

Changed 5 years ago by AdrianPeterSmith

Changed 5 years ago by AdrianPeterSmith

another example

comment:1 Changed 5 years ago by AdrianPeterSmith

have also tried 4.3.27 test build

Changed 5 years ago by AdrianPeterSmith

and another

comment:2 Changed 5 years ago by frank

Thanks for the log files. We saw very rare reports like this in the past (VERR_VMX_INVALID_VMXON_PTR Gurus) but were never able to reproduce this. Do you have any software running on the host worth to mention which could interfere with VirtualBox, like another virtualization application?

comment:3 Changed 5 years ago by AdrianPeterSmith

Not knowingly. My host is a corporate build of 64bit Windows 7. In task manager I can see some Microsoft Virtualisation stuff: I have attached screenshot.

Changed 5 years ago by AdrianPeterSmith

comment:4 Changed 5 years ago by AdrianPeterSmith

I tried stopping all those processes, but still got the crash.

comment:5 Changed 5 years ago by frank

One further question: Did you use any version of VirtualBox before where this didn't happen, i.e. is this problem a (recent?) regression?

comment:6 Changed 5 years ago by Clemi

Hi,

This sounds like an issue I was having.

When we were getting Guru meditation, within a second of a Meditation, Windows Event Viewer was making comments about adjusting VM settings, and starting new VMs. Which is interesting as these messages were attached to ‘Windows Virtual PC’. I think I had had a windows update which reactivated my old Windows Virtual PC.

To disable Windows Virtual PC on Windows 7 Control Panel > Programs and Features > Turn Windows features on or off > untick Windows Virtual PC (third from the bottom) then restart

Me and 5+ people were getting this issue in our office, and since we have disabled Windows Virtual PC, we stopped getting guru meditations :D

Hope this is useful, if not good luck.

comment:7 Changed 5 years ago by ramshankar

The next maintenance version of VirtualBox should contain some extra bits of diagnostic information when the guru happens. At the moment, we cannot see anything wrong with our code and I strongly suspect this is due to some other programs on the host OS that interferes with our VT-x usage.

Changed 5 years ago by Raster

Log from 4.3.28 crash

Changed 5 years ago by Raster

Another crash of 4.3.28 with possibly more info.

comment:8 Changed 5 years ago by Raster

Can confirm that disabling the Windows Virtual PC fixes the issue.

comment:9 Changed 5 years ago by AndrewFenton

I had been experiencing the same problem with my virtual machines going into guru mediation. I therefore followed the instruction to uninstall the Windows Virtual PC software as stated by the user Clemi and the issue has now stopped. Hence, I can confirm that uninstalling the Windows Virtual PC software resolved the issue for me.

comment:10 Changed 7 months ago by aeichner

  • Status changed from new to closed
  • Resolution set to obsolete
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use