VirtualBox

Ticket #13987 (closed defect: fixed)

Opened 6 years ago

Last modified 5 years ago

VBox 4.3.26 NAT Network unstable

Reported by: tkvb Owned by:
Component: network/NAT Version: VirtualBox 4.3.26
Keywords: NAT Network Cc:
Guest type: Linux Host type: Windows

Description

VBox 4.3.26 running on Windows 8.1 x64 host 2 Ubuntu 14.04.2 VMs configured to use a NAT network

After a while (maybe under heavy network load between the 2 VMs?) the NAT network stops passing traffic to the outside world. The 2 VMs can still talk to each other but not with the outside world until they are both rebooted.

This started with the upgrade to 4.3.26, the same setup worked OK before.

Attachments

NAT_10.0.5.0.log Download (934 bytes) - added by tkvb 6 years ago.
VBoxNATCrash.jpg Download (20.5 KB) - added by tkvb 6 years ago.
VBoxSVC.log.1 Download (2.1 KB) - added by GoodGodd 5 years ago.
VBoxSVC.log.2 Download (670 bytes) - added by GoodGodd 5 years ago.
VBoxSVC.log.3 Download (3.9 KB) - added by GoodGodd 5 years ago.
vbox.PNG Download (10.1 KB) - added by GoodGodd 5 years ago.
NatNetwork.leases Download (199 bytes) - added by GoodGodd 5 years ago.
NatNetwork.leases-prev Download (199 bytes) - added by GoodGodd 5 years ago.
error.PNG Download (17.3 KB) - added by GoodGodd 5 years ago.
Vbox error

Change History

comment:1 Changed 6 years ago by vushakov

Please, can you attach the log file for the NAT Network (.VirtualBox/$netname.log).

Changed 6 years ago by tkvb

comment:2 Changed 6 years ago by tkvb

I attached the log file with the VMs in the broken state, but there isn't much in the log file to go by. Is there a way to bump up the log level to get more info?

comment:3 Changed 6 years ago by tkvb

I just got the following VBoxNetNAT.exe crash, but there isn't any more info in the log file than before.

Changed 6 years ago by tkvb

comment:4 in reply to: ↑ description Changed 6 years ago by vushakov

This started with the upgrade to 4.3.26, the same setup worked OK before.

What was the previous release that you used. I don't think NAT Network had any non-trivial changes on 4.3 branch since last August.

Is there a way to bump up the log level to get more info?

Not without using a debug build.

I just got the following VBoxNetNAT.exe crash

Is this reproducible? If it is, please, could you provide a minidump?

comment:5 follow-up: ↓ 9 Changed 6 years ago by tkvb

I used 4.3.22 and NAT worked fine (though that version had other issues non-NAT related). Then I upgraded to 4.3.24 and NAT also worked but DNS was broken (see ticket #13915). Now this problem in .26

I'm sorry but I disagree with the statement that only trivial changes are made in minor releases. It's more like 1 step forward, 2 backwards. I haven't been able to find a stable version of VBox in a long time, where the features I use just work.

(As a side note, another non-trivial change that was made in a patch release, I believe from .20 to .22, was to completely ignore %HOME% on Windows -- you simply don't make such changes in a patch release. See  http://semver.org/)

As for the crash, I haven't found a pattern to reproduce it. The error window is very rare, but the NAT network stops working often and there's no new info added to the log file.

If you can provide a debug build or a build with a way to turn on/off verbose NAT logging, I'm more than willing to run it and help you find the issue.

comment:6 Changed 6 years ago by vushakov

  • Keywords NAT Network added; nat removed
  • Summary changed from VBox 4.3.26 NAT unstable to VBox 4.3.26 NAT Network unstable

comment:7 follow-up: ↓ 8 Changed 6 years ago by ReinerB

I also experience NATnetwork stop working in VBox 4.3.26

I use a Win7 SP1 host. I have a total of 7 VMs configured into two different NATnetworks. It seems that, if after stopping a VM there is no VM left in one of the NATnetworks, both NATnetworks stop working, i.e. a ping to the router (usually address x.x.x.1) does no longer work.

After stopping all VMs and restarting them all works fine again.

This configuration worked without any problem in VBox 4.3.22. I did not use 4.3.24 because of the DNS problem.

comment:8 in reply to: ↑ 7 Changed 6 years ago by vushakov

Replying to ReinerB:

I also experience NATnetwork stop working in VBox 4.3.26

It seems that, if after stopping a VM there is no VM left in one of the NATnetworks, both NATnetworks stop working, i.e. a ping to the router (usually address x.x.x.1) does no longer work.

Please, can you file this as a separate bug report? I can reproduce this issue, but this bug report is about VBoxNetNAT.exe crash. Thanks.

comment:9 in reply to: ↑ 5 Changed 6 years ago by vushakov

Replying to tkvb:

If you can provide a debug build or a build with a way to turn on/off verbose NAT logging, I'm more than willing to run it and help you find the issue.

Any luck with getting a minidump?

Having at least the first idea about where the crash might be would be helpful. Carpet-bombing with full debug logs is a bit of an overkill.

comment:10 follow-ups: ↓ 11 ↓ 16 Changed 6 years ago by tkvb

I have not seen the crash lately, as mentioned before it's rare, but NAT networking still stops frequently. When it does I looked at the running processes and there are still 3 VBoxNetNAT processes running, so they have not crashed.

comment:11 in reply to: ↑ 10 Changed 6 years ago by vushakov

Replying to tkvb:

I have not seen the crash lately, as mentioned before it's rare, but NAT networking still stops frequently. When it does I looked at the running processes and there are still 3 VBoxNetNAT processes running, so they have not crashed.

May be you can use task manager or  Process Explorer to forcibly obtain a dump of the NAT network process that appears stuck like that? Of the 3 processes you want the grandchild, the one with the largest memory.

comment:12 Changed 5 years ago by tkvb

I created a full dump of the process in the state where it's not passing any traffic to the outside world, but it's 84MB big, can you please contact me for a way to get it to you? Not sure I want to post it in the public, I don't know what private info there may be in there.

comment:13 Changed 5 years ago by vushakov

Thanks. You can reach me at valery dot ushakov at oracle dot com

comment:14 Changed 5 years ago by tkvb

Sent you an email, thanks.

comment:15 Changed 5 years ago by GoodGodd

Hi there, Virtualbox 5.0 im using, host Windows 7 64bit and guest Windows server 2003. Im getting problem with my natnetwork its give me an error every 2 or last time 4 days, than its crash and people can't login to my server witch im running in VM. People who did'd logout they can still play but new players can't login to server.

I did use this option VBoxManage setextradata global VBoxInternal2/HostDNSSuffixesIgnore 1 from https://www.virtualbox.org/ticket/13839 its stop crashes for now. but it's for NAT so will have to go back now to previous setting. It's removed Natnetwork crash but now disconnecting players. Logs for it are NatNetwork.leases. There is also error im getting in w7 host machine vbox.pmg file attached. If you can have a look in this please. I know there is a lot of this but its form many months i try fix it my self and i give up for now. Many thanks in advance.

Last edited 5 years ago by GoodGodd (previous) (diff)

Changed 5 years ago by GoodGodd

Changed 5 years ago by GoodGodd

Changed 5 years ago by GoodGodd

Changed 5 years ago by GoodGodd

Changed 5 years ago by GoodGodd

Changed 5 years ago by GoodGodd

comment:16 in reply to: ↑ 10 Changed 5 years ago by vushakov

Replying to tkvb:

I have not seen the crash lately, as mentioned before it's rare, but NAT networking still stops frequently. When it does I looked at the running processes and there are still 3 VBoxNetNAT processes running, so they have not crashed.

When your NAT Netowrk is stuck, please, can you do netstat -n -A inet -A inet6 in all your guests connected to that network?

I suspect you are exceeding the limit of simultaneous TCP connections. E.g. gvfsd-http apparently likes to keep around a lot of connections in CLOSE_WAIT (launchpad bugs  571970 and  760344).

Changed 5 years ago by GoodGodd

Vbox error

comment:17 Changed 5 years ago by GoodGodd

Hi, hope anyone can help! We having this error few months now.

I'm getting same error, my Nat Network crash every 2 or 7 days. It's like this. We running game server on VBox 5, Host Windows 7 and guest Win Server 2003 and one of our software is for connection players to the server (gate soft - only for login to game using credentials). When we have 20+ people connected in one time NAT crashes every up to 7 days but when we having 40+ people connected in one time it crashes every 2 days. Please have a look on attached file error.png

So i wonder if we can fix it somehow. Many thanks in advance.

Regards Maciej

Last edited 5 years ago by GoodGodd (previous) (diff)

comment:18 Changed 5 years ago by vushakov

Please, can you give a recent test build a try? Revision 103571+ for 5.0, 103575+ for 4.3.

comment:19 Changed 5 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

No response, closing.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use