VirtualBox

Ticket #13902 (closed defect: fixed)

Opened 7 years ago

Last modified 7 years ago

Win 8.1 x32 on Intel Atom Z3735F - BSOD 9F during standby (sleep)

Reported by: f3flight Owned by:
Component: WDDM Version: VirtualBox 4.3.22
Keywords: BSOD 9F sleep standby Cc:
Guest type: Linux Host type: Windows

Description

I get BSOD 9F (DRIVER_POWER_STATE_FAILURE) very often when I put my tablet Acer Switch 10 into sleep (basically just turn the screen off with the power button). It can happen in several minutes or hours in sleep mode, or when I try to turn the screen back on.Initially I thought I have a broken tablet and I even got it replaced under warranty but now that I have received a replacement and the issue reappeared I can finally see it is caused by VirtualBox. I have uninstalled VirtualBox and BSODs do not happen again. However I would like to have a hyperviser and my Windows version does not have Hyper-V so I'd like to continue using VirtualBox. Please help me fix this issue. Minidumps are attached. All drivers in Windows are latest available for my hardware.

Attachments

bsod-9f-minidumps.zip Download (263.5 KB) - added by f3flight 7 years ago.
VBoxLogs.zip Download (98.6 KB) - added by f3flight 7 years ago.
not sure this is useful since BSOD happens on the Host machine

Change History

Changed 7 years ago by f3flight

Changed 7 years ago by f3flight

not sure this is useful since BSOD happens on the Host machine

comment:1 Changed 7 years ago by f3flight

Peculiarity of this tablet/laptop and similar models is that they cannot go to deep sleep (S1-S3), they only have connected standby  https://msdn.microsoft.com/en-us/library/windows/hardware/dn481238(v=vs.85).aspx. Not sure if it makes any difference though.

comment:2 Changed 7 years ago by mhanor

The crash dumps do not indicate a VirtualBox issue. The crashes look identical and are related to a Microsoft driver (sdbus) and to a Realtek WLAN driver (rtwlans). You should make sure that your Windows has received all updates from Microsoft Update and that your WLAN card is using the latest driver, from Acer or from Realtek.

comment:3 Changed 7 years ago by f3flight

SD Host driver is built into Windows and provided by Microsoft, it is dated 2006 and I was not able to find a newer version. WiFi module is SDIO type, it is connected via that bus. The module itself is Realtek RTL8723BS. Acer provides a driver for it on their support website, v.3007.2, dated mid July 2014. I was able to find and install a newer driver for the same chip - found it on HP support website here  http://h10025.www1.hp.com/ewfrf/wc/softwareDownloadIndex?cc=ru&lc=ru&dlc=ru&softwareitem=ob-140101-1. This one is v.3007.6 dated 2014-10-01. I will install VirtualBox again and check if the issue is resolved with this newer driver.

comment:4 Changed 7 years ago by f3flight

Dear developers,

Seems that with the newer Realtek WiFi driver 3007.6 downloaded from HP website the problem does not appear anymore. Please close this ticket. Thank you very much for your help.

comment:5 Changed 7 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use