VirtualBox

Ticket #13886 (closed defect: duplicate)

Opened 2 years ago

Last modified 5 months ago

Triple fault/guru meditiation with 64-bit guest OS

Reported by: Andrew Henle Owned by:
Priority: major Component: other
Version: VirtualBox 4.3.22 Keywords: triple fault
Cc: Guest type: all
Host type: Solaris

Description

Running VirtualBox 4.3.22 r98236 on a Solaris 11.2 host, hardware is an older IBM x366 (8863) with four Intel Xeon 7040 CPUs and 48GB of RAM.

All 64-bit guest operating systems quickly fail with a triple fault/guru meditation error.

The problem I'm having seems different enough from all the other triple fault bugs I've looked at that I think it warrants a look.

I've tried backrev'ing to an earlier version of VirtualBox, and instead of the guest OS failing with a triple fault, the error was propagated to the host OS and the entire box panic'd. I can't try a test build for a Solaris host because the link at https://www.virtualbox.org/wiki/Testbuilds is broken and is a link to a build older than the current stable 4.3.22 98236 build.

Attachments

TripleFaultWith64-bitGuest.tgz Download (60.3 KB) - added by Andrew Henle 2 years ago.
Tarball of entire virtual machine directory after triple fault w/ Centos install ISO boot

Change History

Changed 2 years ago by Andrew Henle

Tarball of entire virtual machine directory after triple fault w/ Centos install ISO boot

comment:1 Changed 2 years ago by michaln

You have an antique CPU which has orders of magnitude worse virtualization performance than modern gear (the CPU itself is perhaps not that much slower, but it has very slow and limited hardware virtualization implementation). But that shouldn't cause crashes.

For whatever reason, your host system doesn't support the NX/XD bit. I don't know if that's a limitation of the hardware or if it's something disabled in the BIOS. That could be a problem.

Does at least one of the operating systems you tried in a VM run on the host hardware? In other words, did you verify that whatever CentOS release you're trying to use in a VM actually boots on the host, or did you try installing Solaris 11.2 in a VM?

For example 64-bit Windows 8.1 will definitely crash on your system, either on the host or in a VM.

comment:2 Changed 5 months ago by michaln

  • Status changed from new to closed
  • Resolution set to duplicate

The guest triple fault is a duplicate of #16375.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use