VirtualBox

Ticket #13874 (reopened defect)

Opened 3 years ago

Last modified 2 months ago

On host sleep/resume, guest becomes "aborted"

Reported by: atombender Owned by:
Priority: major Component: VM control
Version: VirtualBox 4.3.22 Keywords: sleep, resume
Cc: Guest type: Linux
Host type: Mac OS X

Description

Ubuntu 12.04 with up-to-date guest additions. Did not happen in 4.1.

00:00:23.836304 Guest Additions capability report: (0x0 -> 0x0) seamless: no, hostWindowMapping: no, graphics: no
00:00:24.049241 Guest Additions capability report: (0x0 -> 0x0) seamless: no, hostWindowMapping: no, graphics: no
00:00:25.603698 Guest Additions capability report: (0x0 -> 0x0) seamless: no, hostWindowMapping: no, graphics: no
00:00:25.783293 Guest Additions capability report: (0x0 -> 0x0) seamless: no, hostWindowMapping: no, graphics: no
00:00:43.873102 Guest Log: VBoxService 4.3.22 r98236 (verbosity: 0) linux.amd64 (Feb 12 2015 16:53:43) release log
00:00:43.873123 Guest Log: 00:00:00.000103 main     Log opened 2015-02-21T04:21:53.707725000Z
00:00:43.873193 Guest Log: 00:00:00.000219 main     OS Product: Linux
00:00:43.873234 Guest Log: 00:00:00.000263 main     OS Release: 3.2.0-23-generic
00:00:43.873273 Guest Log: 00:00:00.000301 main     OS Version: #36-Ubuntu SMP Tue Apr 10 20:39:51 UTC 2012
00:00:43.873311 Guest Log: 00:00:00.000337 main     OS Service Pack: #36-Ubuntu SMP Tue Apr 10 20:39:51 UTC 2012
00:00:43.873356 Guest Log: 00:00:00.000377 main     Executable: /opt/VBoxGuestAdditions-4.3.22/sbin/VBoxService
00:00:43.873363 Guest Log: 00:00:00.000382 main     Process ID: 2505
00:00:43.873369 Guest Log: 00:00:00.000385 main     Package type: LINUX_64BITS_GENERIC
00:00:43.877150 Guest Log: 00:00:00.004170 main     4.3.22 r98236 started. Verbose level = 0
00:00:43.978632 NAT: DHCP offered IP address 10.0.2.15
00:00:47.310609 Pausing VM execution, reason "host suspend"
00:00:47.311013 Changing the VM state from 'RUNNING' to 'SUSPENDING'.
00:00:47.313057 AIOMgr: Endpoint for file '/Users/alex/VirtualBox VMs/t11e-vm1/box-disk1.vmdk' (flags 000c0781) created successfully
00:00:47.372196 PDMR3Suspend: 61 135 737 ns run time
00:00:47.372214 Changing the VM state from 'SUSPENDING' to 'SUSPENDED'.
00:00:49.747565 Resuming VM execution, reason "host resume"
00:00:49.748181 Changing the VM state from 'SUSPENDED' to 'RESUMING'.
00:00:49.748329 AIOMgr: Endpoint for file '/Users/alex/VirtualBox VMs/t11e-vm1/box-disk1.vmdk' (flags 000c0723) created successfully

Attachments

screenshot.jpeg Download (296.0 KB) - added by atombender 3 years ago.
Screenshot
VBox.log Download (117.9 KB) - added by Alx 3 years ago.
Log showing my VM crashing with 4.3.22
VBox.log.1 Download (118.2 KB) - added by Alx 3 years ago.
Log showing exact same VM working fine with 4.3.20
VBox.2.log Download (63.1 KB) - added by jpotterm 3 years ago.
Ubuntu Crash on DNS Server Change
Vbox.log Download (66.9 KB) - added by joemsak 5 months ago.
VBox.log.2.1 Download (104.8 KB) - added by joemsak 5 months ago.
VBox.log.2 Download (75.8 KB) - added by joemsak 5 months ago.
VBox.log.3 Download (69.3 KB) - added by joemsak 5 months ago.
VBox.log.3.1 Download (104.8 KB) - added by joemsak 5 months ago.
VBox2.log Download (72.6 KB) - added by joemsak 5 months ago.
VBox2.log.1 Download (69.1 KB) - added by joemsak 5 months ago.
VBox2.log.2 Download (66.9 KB) - added by joemsak 5 months ago.
VBox2.log.3 Download (104.8 KB) - added by joemsak 5 months ago.
VBoxHeadless_2017-08-15-103514_Josephs-MacBook-Pro.crash Download (67.7 KB) - added by joemsak 4 months ago.
VBoxDetails.log Download (89.5 KB) - added by Zorgum 4 months ago.
Problem Details and System Configuration

Change History

Changed 3 years ago by atombender

Screenshot

comment:1 Changed 3 years ago by squeegee

The same thing happens to me every time I sleep/wake my macbook air with version 4.3.22. It does not happen with version 4.3.20. I have reverted to avoid the problem.

Changed 3 years ago by Alx

Log showing my VM crashing with 4.3.22

Changed 3 years ago by Alx

Log showing exact same VM working fine with 4.3.20

comment:2 Changed 3 years ago by Alx

I am experiencing the exact same behavior and have downgraded to 4.3.20 which doesn't exhibit this problem. I initially posted on the forum, here:  https://forums.virtualbox.org/viewtopic.php?f=8&t=66222

I have attached logs from the same VM, showing 4.3.22 crashing on resume and 4.3.20 working fine after resume.

comment:3 Changed 3 years ago by frank

To all users who are affected by this problem: We did some tests and cannot reproduce this problem but perhaps this happens only rarely. According to the logs from Alx it seems that this crash happens during waking up (remember, during host suspend the VM is usually paused and after host resume, the VM is resumed as well).

What we are interested in is a crash dump of VBox. See the remarks about Mac OS X here.

comment:4 Changed 3 years ago by frank

If you cannot provide crash files, would other users than Alx provide VBox.log files of such VM sessions?

comment:5 Changed 3 years ago by frank

Oh, and does the VM crash as well if you just pause + resume the VM (without going the host into sleep)?

comment:6 Changed 3 years ago by jpotterm

I'm seeing similar behavior that might be the same bug. When I change DNS servers on my host while the VM is running, it crashes immediately showing a status of "Aborted". This is on a Mac OS 10.10.2 host with an Ubuntu Server 14.04 VM.

The last line in the log file from the crashed VM is:

NAT: DNS servers changed, triggering reconnect

I also have a Windows 8.1 VM that does not exhibit this behavior.

I have a core dump but it's about 1 GB and I can't connect to ftp.oracle.com.

comment:7 Changed 3 years ago by frank

jpotterm, unfortunately I cannot provide you a server. Could you attach the VBox.log of the crashing VM session?

comment:8 Changed 3 years ago by klaus

Do you have the textual crash information? Thought that OSX happily shows it when pushing the right button in the window which appears after VirtualBox crashed. It would help us investigating what the exact cause is. Not a full substitite for a core, but with some luck it's enough information.

comment:9 Changed 3 years ago by Alx

Hello,

I can confirm that user jpotternm's issue seems to be related or even the same: I ran the VM and then opened OS X's system preferences, went to network preferences DNS tab, and changed my DNS to 8.8.8.8 (instead of the home router's). The VM crashed immediately.

It seems like indeed suspend/resume works and the crash I reported is a side-effect of the DNS being re-set during resume?

Anyway, I am enabling core dumps now and hope to post one soon.

Last edited 3 years ago by Alx (previous) (diff)

Changed 3 years ago by jpotterm

Ubuntu Crash on DNS Server Change

comment:10 Changed 3 years ago by jpotterm

I've uploaded the log file. There is no window that appears when the VM crashes.

comment:11 Changed 3 years ago by Alx

Some more of information:

1) Run VM 2) Pause VM 3) Unpause VM

It works fine. No crash.

4) Pause VM 5) Change DNS address using OS X system preferences --> PAUSED VM crashes immediately.

So the pause/resume seems to have nothing to do with this. Even when paused the VM will crash.

Finally, OS X does not come up with a window about the crash at all. No idea why. I do get that when other applications crash...

Also, I changed the network adapter to PCnet and Paravirtualized, but it did not help (same crash).

UPDATE: with BRIDGED networking instead of NAT, the problem no longer occurs. So the problem is consistently reproducible when both of these hold:

1) The network adapter is in NAT mode 2) You change the DNS of the host

If you give me instructions about how to deliver the core dump, I'm happy to do it.

Last edited 3 years ago by Alx (previous) (diff)

comment:12 Changed 3 years ago by Alx

Hmmm... core upload failed with message:

Maximum attachment size: 524288 bytes

I don't think I can produce that small a core dump even if I set the guest RAM size to the minimum...

Also, ftp.oracle.com seems to not be working so wasn't able to upload there either...

Last edited 3 years ago by Alx (previous) (diff)

comment:13 follow-up: ↓ 14 Changed 3 years ago by frank

Could you send me the core dumps in multiple parts by e-mail? Compress it and split it to chunks of 10MB and send the mail directly to frank _dot_ mehnert _at_ oracle _dot_ com. Thank you!

Unfortunately we are still not able to reproduce this crash, even by following your instructions. A core dump should shed some more light into the issue.

comment:14 in reply to: ↑ 13 Changed 3 years ago by Alx

Replying to frank:

Could you send me the core dumps in multiple parts by e-mail? Compress it and split it to chunks of 10MB and send the mail directly to frank _dot_ mehnert _at_ oracle _dot_ com. Thank you!

Unfortunately we are still not able to reproduce this crash, even by following your instructions. A core dump should shed some more light into the issue.

I will do this tonight (am at work).

Meanwhile one more piece of information to record: this is related to the guest VM code as well. I did a fresh Ubuntu 14.04.02 install and it works fine. This probably explains why it is not easily reproducible. It is something to do with the combination of:

  • Using NAT network adapter
  • Changing the DNS of the host
  • Having an Ubuntu Linux with specific packages installed

In case you feel like it, I have a public box on atlas here:  https://atlas.hashicorp.com/karypid/boxes/devbox

If you have vagrant installed then you should be able to reproduce the issue with this box. The difference is that this box is based on ubuntu-gnome (instead of default ubuntu install). I created is as follows:

  • minimal install of Ubuntu 14.04 using mini iso
  • Add the following packages afterward:
    • build-essential
    • dkms
    • openssh-server
    • gnome 3
    • installed VirtualBox guest additions
    • auto-tools, JDK 7, JDK 8, Maven
    • updated everything to latest version

I can't do this now but I suspect that if you do a minimal ubuntu install using the mini iso you might be able to reproduce this. I feel that all of the packages I added on top of the minimal install are too "userspace" to cause this.

The minimal install is here:  http://archive.ubuntu.com/ubuntu/dists/trusty/main/installer-amd64/current/images/netboot/mini.iso

Just use defaults for everything and when prompted for package selection leave everything unchecked. My feeling is you will get it to crash.

comment:15 Changed 3 years ago by frank

My local setup satisfies most of your above hints. I'm also using an Ubuntu Trusty guest with GNOME3. An SSH server is running and port-forwarding is in place. Still no luck to reproduce so a core dump would be really welcome.

comment:16 Changed 3 years ago by atombender

I can confirm that DNS changes also causes the crash. Frank: I've emailed you a core dump.

comment:17 follow-up: ↓ 18 Changed 3 years ago by bigredsun

There's a workaround for the sleep crash: Open terminal, type "screen" to start a screen session. Then run the vm from the command line as described here: https://www.virtualbox.org/wiki/Core_dump

comment:18 in reply to: ↑ 17 Changed 3 years ago by Alx

Replying to bigredsun:

There's a workaround for the sleep crash: Open terminal, type "screen" to start a screen session. Then run the vm from the command line as described here: https://www.virtualbox.org/wiki/Core_dump

This doesn't seem to work for me. The VM crashed and the screen terminal showed "Segmentation fault" error.

My workaround (as mentioned above) is to use Bridged instead of NAT adapter.

comment:19 Changed 3 years ago by frank

Thanks for all the info. I hope we found and fixed the problem. Please could you try the latest Mac OS X 4.3.x test build (or the Windows test build if applicable) from here and confirm that the crash is gone? Many thanks!

comment:20 Changed 3 years ago by Alx

I can confirm this new build works fine in my case. (I tried the Mac OS X build)

Last edited 3 years ago by Alx (previous) (diff)

comment:21 Changed 3 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Thanks! The fix is part of the VBox 4.3.24 release.

comment:22 Changed 3 years ago by jpotterm

Version 4.3.24 fixes things for me as well. Thanks!

Changed 5 months ago by joemsak

Changed 5 months ago by joemsak

Changed 5 months ago by joemsak

Changed 5 months ago by joemsak

Changed 5 months ago by joemsak

comment:23 Changed 5 months ago by joemsak

  • Status changed from closed to reopened
  • Resolution fixed deleted

I'm using Vbox 5.1.26 r117224 (Qt5.6.2) and having this exact issue as described. I know this ticket is 2 years old but all I can find on google is old issues

Host: OS X Sierra 10.12.6

VM: Ubuntu Server 16.04.2 LTS

Network: NAT

It was working perfectly fine until I upgraded yesterday.

Please see my uploaded logfiles if needed.

Thanks!

Last edited 5 months ago by joemsak (previous) (diff)

comment:24 Changed 5 months ago by joemsak

Hi again -- this has happened again, only this time my computer did not go to sleep. I was just using another application.

Specifically I was using Chrome / liceCAP to make an animated gif screen recording. The VM was running in detached GUI mode with myself logged in through SSH in the terminal. This is how I have always ran and connected to my VM. The terminal was in the background, not being used.

See the next batch of uploaded logs.

Changed 5 months ago by joemsak

Changed 5 months ago by joemsak

Changed 5 months ago by joemsak

Changed 5 months ago by joemsak

comment:25 follow-up: ↓ 26 Changed 4 months ago by aeichner

Do you have an OS X crash report you can upload?

comment:26 in reply to: ↑ 25 Changed 4 months ago by joemsak

Replying to aeichner:

Do you have an OS X crash report you can upload?

So, this just happened again now, came here to check on this ticket.

I've opened Console but I'm not sure where I should look for logs related to virtualbox. Can you help me? Thanks!

comment:27 Changed 4 months ago by joemsak

By the way, my mac has also been kernel panic'ing alongside the VM aborting itself, and another kernel panic just happened.

For now I am not using my VM at all, until I can get support for these issues.

I have attached the log dated for today at the time of the crash, from ~/Library/Logs/DiagnosticReports

Changed 4 months ago by joemsak

comment:28 Changed 4 months ago by Dave415

I'm having exactly the same problems as @joemsak

Same versions of all software:

Vbox 5.1.26 
Host: OS X Sierra 10.12.6
VM: Ubuntu Server 16.04.2 LTS
Network: NAT
Using Vagrant 1.9.7 with box (bento/ubuntu-16.04)

In addtion, my mac is working absolutely fine, with no crashes. It's a new one, fresh install of everything.

Last edited 4 months ago by Dave415 (previous) (diff)

Changed 4 months ago by Zorgum

Problem Details and System Configuration

comment:29 Changed 4 months ago by Zorgum

I am having this problem as well: VBoxDetails.log

comment:30 Changed 4 months ago by Dave415

I've downgraded from 5.1.26 to 5.1.14, and have not encountered the issue since.

I have worked around the issue by downgrading. Version 5.1.14 works perfectly.

Last edited 4 months ago by Dave415 (previous) (diff)

comment:31 Changed 4 months ago by RobCIQ

Same here: Version 5.1.26 r117224 (Qt5.6.2) Ubuntu 64 bit (16.04) Bridged adapter

It aborts when I switch networks.

I had opened the another ticket (#14898) for the same issue almost 2 years ago, looks like it might be a dup of this one.

comment:32 Changed 3 months ago by jblecanard

Same problem here. Behavior is exactly as described by joemsak

Vbox 5.1.26 
Host: OS X Sierra 10.12.6
VM: CentOS Linux release 7.3.1611
Network: NAT
Using Vagrant 2.0.0 with box (centos/7)

comment:33 Changed 3 months ago by symentis

Same here on macOS Sierra.

comment:34 Changed 3 months ago by klaus

Are you really sure that this is related in any way to networking and what not, and isn't the by now the all too well known issue with audio device change which crept into 5.1.26 and is long fixed in the current Testbuilds, making some percentage of the issues reported in this ticket a duplicate of #16969?

At least the timing of many reports is suspicious. It wouldn't explain kernel panics, at least not obviously.

comment:35 Changed 3 months ago by tcm-natera

same issue with 5.1.26 on Sierra 10.12.6 with centos-7.3 guests

Last edited 3 months ago by tcm-natera (previous) (diff)

comment:36 Changed 2 months ago by zvovu

I have the same issue... Seemed to start around 5.1.24 for me. Before that, was fine but I don't remember how old a version I was using beforehand. I was hoping subsequent updates would fix it but they have not.

Last edited 2 months ago by zvovu (previous) (diff)
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use