VirtualBox

Ticket #13833 (closed defect: obsolete)

Opened 8 years ago

Last modified 6 years ago

Digitial Guardian Agent + VirtualBox = BSOD

Reported by: Suo Owned by:
Component: host support Version: VirtualBox 4.3.22
Keywords: Digital Guardian Agent DGAgent dgmaster.sys BSOD Blue Screen SUPHardenedVerifyProcess-win SUPR3HardenedMain-win Cc:
Guest type: all Host type: Windows

Description

I can start the VirtualBox Manager, but when I attempt to start a VM, the Windows host blue screens. An attempt to fix this crash with dgmaster.sys was made in changeset 53021 ( https://www.virtualbox.org/changeset/53021/vbox ) but I am still seeing issues in VirtualBox 4.3.22 on Windows 7 x64. The only workaround I have found is to revert to 4.3.12. Unfortunately, VBox.log is not written before the system halts.

Attachments

VBox 4.3.22 DG BSOD.jpg Download (469.0 KB) - added by Suo 8 years ago.
Photo of the BSOD
021315-22869-01.dmp Download (286.7 KB) - added by Suo 8 years ago.
Windows Minidump from the crash
VirtualBox-4.3.27-99267-Win with DG Whitelist VBoxStartup.log Download (268.2 KB) - added by Suo 8 years ago.
VirtualBox-4.3.27-99267-Win with DG Whitelist.png Download (10.6 KB) - added by Suo 8 years ago.
VirtualBox-4.3.27-99267-Win with DG Active VBoxStartup.log Download (14.9 KB) - added by Suo 8 years ago.
video-1428341470.mp4 Download (485.9 KB) - added by mozzie 8 years ago.
DG BSoD
VBoxStartup.log VirtualBox-5.0.0_RC1-100731-Win.zip Download (2.4 KB) - added by Suo 8 years ago.
VBoxStartup.log from VirtualBox-5.0.0_RC1-100731-Win with VirtualBox whitelisted in Digital Guardian

Change History

Changed 8 years ago by Suo

Photo of the BSOD

Changed 8 years ago by Suo

Windows Minidump from the crash

comment:1 Changed 8 years ago by mhanor

The crash occurs in a Digital Guardian driver, you should contact them. Read  this

comment:2 Changed 8 years ago by bird

I've made some improvements to the code I suspect triggers the dgmaster.sys crash. Could you try out this build and see if it helps, or at least produces a VBoxStartup.log file: https://www.virtualbox.org/download/testcase/VirtualBox-4.3.27-99267-Win.exe

Changed 8 years ago by Suo

comment:3 Changed 8 years ago by Suo

I currently have a whitelist in place so Digital Guardian will not interfere with VirtualBox. I will test again on Monday without the whitelist. Normally Digital Guardian is not detectable, but, as a result of having VirtualBox whitelisted in Digital Guardian, VirtualBox can see that Digital Guardian is installed, so it triggers VB's DG workaround, which appears to have a bug in it that causes the hardening check to fail.

Failed to open a session for the virtual machine Ubuntu 14.04.

The virtual machine 'Ubuntu 14.04' has terminated unexpectedly during startup with exit code 1 (0x1).  More details may be available in 'D:\VirtualBox VMs\Ubuntu 14.04\Logs\VBoxStartup.log'.

Result Code: E_FAIL (0x80004005)
Component: Machine
Interface: IMachine {480cf695-2d8d-4256-9c7c-cce4184fa048}

comment:4 Changed 8 years ago by Suo

We took out the whitelist and get the dgmaster.sys BSOD with VirtualBox build 99267.

Last edited 8 years ago by Suo (previous) (diff)

comment:5 Changed 8 years ago by Suo

No VBoxStartup.log is written due to the BSOD.

Last edited 8 years ago by Suo (previous) (diff)

comment:6 Changed 8 years ago by mozzie

I am also experiencing this exact issue with Digital Guardian. Let me know what might be useful, if anything. When I reproduced the issue, it was difficult to recover from the BSoD because the system faltered such that the screen was flashing and the power button did not interrupt the "seizure". I'll see if I can attach a video of it because it's at least entertaining.

Changed 8 years ago by mozzie

DG BSoD

Changed 8 years ago by Suo

VBoxStartup.log from VirtualBox-5.0.0_RC1-100731-Win with VirtualBox whitelisted in Digital Guardian

comment:7 Changed 8 years ago by Suo

I tried again with the latest build (VirtualBox-5.0.0_RC1-100731-Win) and the verification still fails:

Error -5673 in supR3HardNtChildPurify! (enmWhat=5) supHardenedWinVerifyProcess failed with Unknown Status -5673 (0xffffe9d7): NtAllocateVirtualMemory

comment:8 Changed 6 years ago by Suo

We received an update from Digital Guardian, version 6.23.0835, that resolves the problem. I am now able to run VirtualBox 5.1.4 with this new version of Digital Guardian.

comment:9 Changed 6 years ago by bird

  • Status changed from new to closed
  • Resolution set to obsolete

Closing as Digital Guardian seems to have sorted out the problem.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use