VirtualBox

Ticket #13791 (closed defect: invalid)

Opened 5 years ago

Last modified 5 years ago

Solaris guest crashes when cpumod initializes (Guru Meditation 1155 (VINF_EM_TRIPLE_FAULT))

Reported by: attila75 Owned by:
Component: VMM Version: VirtualBox 4.3.20
Keywords: VINF_EM_TRIPLE_FAULT, guru, cpumod init, solaris Cc:
Guest type: Solaris Host type: Windows

Description

I would like to move a fairly old Solaris 10u2 install from a Dell server to a Virtualbox instance. I don't necessarily want to upgrade the (to-be-)guest OS as it has some custom built software that cannot be recompiled. I did a flash archive of the original system, restored the image. There might be one caveat: /, var, opt, usr, export/home are all on separate slices on the original system and I gave them a smaller slice on the virtual machine as they don't need that much free space. I set up a virtual machine, a 64 bit one with x64 5/09 and earlier. The original machine is Dell Poweredge 1800 with two 8.8GHz Xeons and 16GB of RAM. The host system is a Win7 x64 with a Core i7 2600 and 32GB of RAM. I gave the guest 2GB (it ran fine for years with 1GB, it was upgraded for other reasons) The restore process itself is successful.

When I try to boot the guest, it fails in 64bit mode. The Failsafe mode works fine, so it might be the problem of the 64 bit mode but the software we'd like to run (to be precise: archive and still be able to access) is compiled 64 bits.

I was able to go to the kernel debugger and the process fails at the mentioned point (cpumod init)

See also the attached screenshot and the logs.

Attachments

VBox.log Download (218.1 KB) - added by attila75 5 years ago.
VBoxStartup.log Download (369.9 KB) - added by attila75 5 years ago.
VBox.png Download (12.1 KB) - added by attila75 5 years ago.

Change History

Changed 5 years ago by attila75

Changed 5 years ago by attila75

Changed 5 years ago by attila75

comment:1 Changed 5 years ago by michaln

You probably can't easily verify that S10u2 successfully boots up on your physical host in 64-bit mode? Chances are it doesn't...

This could be relevant:  http://www.os2museum.com/wp/64-bit-trouble-with-solaris-10-u4-and-earlier/

comment:2 Changed 5 years ago by michaln

It's also worth pointing out that a problem with 64-bit S10 pre-U5 is documented in the VirtualBox manual: https://www.virtualbox.org/manual/ch12.html#idp98284160

comment:3 Changed 5 years ago by attila75

(Sorry for being this late with the answer) Well, the original host is still doing fine so it boots up in 64 bit mode and operates without troubles. While it was retired from service it had several hundred days of uptime in the past with the same OS/patch revision. If I recall correctly these PE1800 serve were even certified for Solaris but not sure. Anyways we didn't have any troubles with it :)

As for the second link, thanks, I will take a look. OTOH I could work around the problem by offering a 32bit VM for the guest and it operates fine since then.

comment:4 Changed 5 years ago by michaln

I'm sure it works fine on the PowerEdge 1800... but that's not where you're running the VM :) As far as I can tell, the PE1800 uses an older P4-based Xeon, so it wouldn't have the problem. That's something which only shows up on newer Intel Core processors released some time after the initial Solaris 10 release.

comment:5 Changed 5 years ago by attila75

Aha, I think I got your point :) Yes, the PE1800 uses a Netburst Xeon, whereas the host I run VBox on has a Sandy Bridge i7. I thought you meant the original hardware by "physical host". Thanks for the help and the pointers! :)

comment:6 Changed 5 years ago by michaln

  • Status changed from new to closed
  • Resolution set to invalid

Yes, that is what I meant (Solaris behaves differently because it sees a Sandy Bridge CPU, not a P4-class CPU).

Anyway, I think I'll close this ticket as invalid ("not a bug"), since it is really a Solaris bug.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use