VirtualBox

Ticket #13780 (closed defect: duplicate)

Opened 5 years ago

Last modified 5 years ago

IntegrityError: (1062, "Duplicate entry 'macleodg53@gmail.com' for key 'PRIMARY'")

Reported by: macleodg Owned by:
Component: other Version: VirtualBox 4.3.20
Keywords: Cc:
Guest type: other Host type: other

Description

How to Reproduce

While doing a POST operation on /login, Trac issued an internal error.

I am trying to login for the first time. I entered a Nickname and got the error

Request parameters:

{'__FORM_TOKEN': u'376ce73912f0a1da1860b46d',
 'nick': u'Gordon MacLeod',
 'referer': u'https://www.virtualbox.org/login'}

User agent: Mozilla/5.0 (Windows NT 6.3; WOW64; Trident/7.0; Touch; .NET4.0E; .NET4.0C; Tablet PC 2.0; .NET CLR 3.5.30729; .NET CLR 2.0.50727; .NET CLR 3.0.30729; rv:11.0) like Gecko

System Information

System information not available

Enabled Plugins

Plugin information not available

Python Traceback

Traceback (most recent call last):
  File "/usr/lib/python2.4/site-packages/trac/web/main.py", line 513, in _dispatch_request
    dispatcher.dispatch(req)
  File "/usr/lib/python2.4/site-packages/trac/web/main.py", line 235, in dispatch
    resp = chosen_handler.process_request(req)
  File "/usr/lib/python2.4/site-packages/trac/web/auth.py", line 126, in process_request
    ret = self._do_login(req)
  File "/usr/lib/python2.4/site-packages/trac/web/auth.py", line 231, in _do_login
    @self.env.with_transaction()
  File "/usr/lib/python2.4/site-packages/trac/db/api.py", line 77, in transaction_wrapper
    fn(ldb)
  File "/usr/lib/python2.4/site-packages/trac/web/auth.py", line 236, in store_authnick
    (remote_user, nick))
  File "/usr/lib/python2.4/site-packages/trac/db/util.py", line 65, in execute
    return self.cursor.execute(sql_escape_percent(sql), args)
  File "/usr/lib64/python2.4/site-packages/MySQL_python-1.2.4b4-py2.4-linux-x86_64.egg/MySQLdb/cursors.py", line 202, in execute
    self.errorhandler(self, exc, value)
  File "/usr/lib64/python2.4/site-packages/MySQL_python-1.2.4b4-py2.4-linux-x86_64.egg/MySQLdb/connections.py", line 36, in defaulterrorhandler
    raise errorclass, errorvalue
IntegrityError: (1062, "Duplicate entry 'macleodg53@gmail.com' for key 'PRIMARY'")

Change History

comment:1 Changed 5 years ago by frank

  • Status changed from new to closed
  • Resolution set to duplicate

Duplicate of #12460.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use