VirtualBox

Ticket #13728 (new defect)

Opened 7 years ago

Last modified 7 years ago

Win 7 Guest/Linux host - integrated webcam on Dell 5520 laptop - black display

Reported by: H0wdy Owned by:
Component: USB Version: VirtualBox 4.3.20
Keywords: webcam camera black screen Cc:
Guest type: Windows Host type: Linux

Description

On a Dell 5520 laptop, Fedora 64 bit 21 host, Win 7 64 bit guest, the integrated webcam provides nothing but a black display on passthrough, but on direct connect, the video shows but very slow/choppy.

It works fine on host applications.

An external USB camera works fine passthrough on the same system.

Attached is log.

Attachments

Win7-2015-01-02-10-54-56.log Download (68.1 KB) - added by H0wdy 7 years ago.
VBox.log Download (108.9 KB) - added by kend 7 years ago.
Windows 7-2015-02-23-17-40-15.log.gz Download (451.0 KB) - added by bor 7 years ago.
VBox.2.log Download (60.8 KB) - added by RenoH 7 years ago.

Change History

Changed 7 years ago by H0wdy

comment:1 Changed 7 years ago by sunlover

Which application do you use in the Win7 guest with the webcam?

Please get a debug log:

  • start the Windows 7 VM
  • on the host execute

VBoxManage debugvm Win7 log --release "+USB_WEBCAM.e.l2.l3,-USB_WEBCAM.restrict"

  • attach the integrated webcam to the Win7 VM using webcam passthrough (via Devices/Webcams menu)
  • try to use the webcam in the guest to reproduce the black image

Attach the new VBox.log to this ticket.

comment:2 Changed 7 years ago by kend

I have the same problem with win8.1 gest on gentoo x64 host.

Changed 7 years ago by kend

comment:3 Changed 7 years ago by kend

The log created with your provide debug command.

I'm using Win8.1 setting program to capture user image.

comment:4 Changed 7 years ago by sunlover

kend, according to the log the webcam has been connected using USB passthrough (for example using menu Devices/USB Devices). This does not work reliably, see ticket https://www.virtualbox.org/ticket/242

You could try to use webcam passthrough via Devices/Webcams menu. The debug command from comment 1 is for the webcam passthrough mode.

comment:5 Changed 7 years ago by kend

Hi, sunlover.

The log created with my do this:

  1. Start the Win8.1 VM.
  2. Run the command with debugvm parameter.
  3. Connect the webcam to VM.
  4. Start setting program in VM and using webcam capture function
  5. Setting program display back image and system is very slow.
  6. Exit setting program and shutdown VM.
  7. Upload the log file.

comment:6 Changed 7 years ago by bor

I have the same issue.

Dell Latitude E5540 + Gentoo x64 host + virtualbox 4.3.20 + Win7 + lync = black video screen.

Last edited 7 years ago by bor (previous) (diff)

comment:7 Changed 7 years ago by sunlover

bor, please attach the debug log. See https://www.virtualbox.org/ticket/13728#comment:1

Changed 7 years ago by bor

comment:8 Changed 7 years ago by sunlover

bor, it looks like there is nothing wrong in the log: video frames are delivered to the guest. Please try to disable 2D and 3D acceleration in the VM setting and test again. Thanks.

comment:9 Changed 7 years ago by bor

I've tried to disable 2D & 3D acceleration but no luck :( And one more notice: AFAIR in the previous version of virtualbox (4.2.x) the camera worked fine.

Last edited 7 years ago by bor (previous) (diff)

comment:10 Changed 7 years ago by H0wdy

I tried disabling 2d acceleration, and the same problem occurs.

  1. With passthrough, black screen. I can use some external usb cams with passthrough, though
  2. With usb direct, I get an image, but incredibly slow. usb 2.0 is enabled.

Prior to passthrough, it worked fine with usb 2.0 device mode.

Now, it doesn't work correctly either way(either black screen with passthrough or incredibly slow with USB 2.0 mode)

comment:11 Changed 7 years ago by bor

I don't know if it matters but I have BIOS firmware version A06.

H0wdy, what is yours? did you tried to get the latest one?

Last edited 7 years ago by bor (previous) (diff)

comment:12 Changed 7 years ago by bor

I've installed the new 4.3.28 version and webcam seems to work now!

comment:13 Changed 7 years ago by sunlover

bor, thanks for feedback. Apparently the fix for Linux host backend helped (see changelog "Webcam passthrough improvements for Linux (V4L2) hosts to support more webcam models ").

H0wdy, kend, does VirtualBox 4.3.28 works for you?

comment:14 Changed 7 years ago by H0wdy

Unfortunately, it doesn't :(. Not to mention, I upgraded to an Inspiron 15 5000 series, with F22 64bit, and Win 8.1 guest. I confirmed yesterday that the output is black :(

comment:15 Changed 7 years ago by RenoH

Last edited 7 years ago by RenoH (previous) (diff)

Changed 7 years ago by RenoH

comment:16 Changed 7 years ago by H0wdy

Sunlover, can you please advise? It still is not working for me. I have a new dell, Fedora 22, and windows 8 guest. I still get black display for webcam on passthrough.

comment:17 Changed 7 years ago by H0wdy

UPDATE:

This is fixed for me in VB5rc1.

comment:18 Changed 7 years ago by Vader

Just installed Virtualbox 5.0 on Ubuntu as host and Win 8.1 as client. Camera I'm using is special CCD camera ant not supported on linux, which is the main reason I installed Windows with Virtualbox. Everything else is working great: camera is detected, drivers installed fine, but image contains nothing. I can't use the passthrough since linux doesn't display it as webcam.

Anyone have any suggestions? I can provide some testing data if needed.

comment:19 Changed 7 years ago by frank

My suggestion is that you make your Linux host detect the webcam. Webcams will always have limited support as USB devices because when using the isochronous protocol, there are very strict timing constraints which can't be fulfilled in virtualized environments.

comment:20 Changed 7 years ago by Dhiren Hamal

I've virtualbox 5.0.0_r101573 on Fedora 22 KDE and my guest os are win 8.1 and win 10 but on the both guest os my web cam is not working properly. If I turn on the camera on guest os the guest os runs slowly. I allocated 8 GB memory for the guest os and 4 cpu on process too. I event tested by plugging external usb webcam but still the same problem occur. I have the latest Bios firmware version and I also checked on VirtualBox 4.3.28 but there is no luck for me. Can somebody help me? please...

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use