VirtualBox

Ticket #137 (closed defect: fixed)

Opened 7 years ago

Last modified 7 years ago

mouse cursor wraps around

Reported by: apfr Owned by:
Priority: major Component: other
Version: VirtualBox 1.3.6 Keywords:
Cc: Guest type: other
Host type: other

Description

host OS: Win XP
guest OS: linux 2.6 (openSuse 10.2 wit KDE), guest additios installed

Sometimes after using a fullscreen SDL application, mouse cursor movements cease to be limided to the visible screen. When the mouse is moved beyond a screen border, it reappears on the opposite side. Moreover, the position of the visible cursor is not related to its location on the desktop. This happens when mouse integration is turned off, with active mouse integration the cursor is always where it should be.
The problem does not seem to be caused by the guest system (neither resetting it nor going back to a prevous version of the hd image helps). In virtualbox 1.3.4, removing the system and re-adding it (with the same old hd image) solved the problem, in vb 1.3.6 this does not help any more.

Change History

comment:1 Changed 7 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

This should be fixed in 1.4.2. Please reopen if the problem persists.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use