VirtualBox

Ticket #13665 (closed defect: fixed)

Opened 5 years ago

Last modified 3 years ago

VirtualBox fails to start on Windows 10 9879 [FIXED IN SVN]

Reported by: voltagex Owned by:
Component: other Version: VirtualBox 4.3.20
Keywords: Cc:
Guest type: other Host type: Windows

Description

Also happens with testbuild 97013. Virtualbox.exe crashes on startup on the current Windows 10 preview.

Attachments

VirtualBox.exe_141203_195236.dmp Download (142.8 KB) - added by voltagex 5 years ago.
VirtualBox.exe_141203_201356.dmp Download (142.5 KB) - added by voltagex 5 years ago.

Change History

Changed 5 years ago by voltagex

Changed 5 years ago by voltagex

comment:1 Changed 5 years ago by Jacob Klein

Fyi, I reported the same issue here, with extensive details:  https://forums.virtualbox.org/viewtopic.php?f=6&t=64638 ... and a mod locked it, stopping my ability to track the failure in any meaningful way.

Windows 10 Consumer Preview is right around the corner, coming as early as January. I hope Oracle can figure out this problem, and fix it at some point... and allow us to track it, rather than stifling all feedback about it.

VirtualBox 4.3.21 r97191 Test Build, the most current version, still immediately crashes. I test every single build I come across. If any additional information about the crash is needed, I will help in any way possible.

Thanks! Jacob

comment:2 Changed 5 years ago by Jacob Klein

It looks like the following thread documents the same issue:  https://forums.virtualbox.org/viewtopic.php?f=6&t=65006 ... and is receiving the same "why should we even consider fixing this?" type of response from the community.

It would be helpful to have an official developer response on the matter, rather than seeing threads get locked by mods who "don't speak for the developers". Oh, and I'm available for testing any proposed solution you may have (I'm an experienced alpha tester for various software).

Thanks, Jacob

comment:3 Changed 5 years ago by klaus

It simply doesn't help to try to apply pressure, especially not as you're overinterpreting the forum mods. They never said that there won't be a VirtualBox version which runs on Windows 10 before its (so far unknown) RTM date. It might happen when the developers find time to investigate and fix the problems with Windows 10 Technical Preview. This can't be our top priority, because from previous experience all operating systems (Windows, Linux, Solaris, OSX) undergo significant changes before they are marked as "ready for release", and many times the incompatibilities disappear magically.

As long as Microsoft doesn't announce a release date I'm personally not convinced that the rumors about a rather early release next year contain any truth. The various software vendors need a lot of time to ensure maximum compatibility, and while Microsoft can shorten the time arbitrarily, it won't make their paying customers happier.

comment:4 Changed 5 years ago by Jacob Klein

Regarding Windows 10 timetable: The schedule was to have a Consumer Preview in January. Sources now say that it will be called "January Technical Preview", followed by monthly releases after that, until RTM, which is currently scheduled around August/September 2015.

All of that is a bit irrelevant, though. There is a known incompatibility right now - VirtualBox's hardened security is interfering. And, even if the developers have decided to not put any priority into fixing it until a certain timeframe... That decision should be transparent and public.

Although I'm looking for a fix, I'd be just as happy to hear a response indicating that they acknowledge the bug, and are targeting a certain timetable with a fix. Does that make sense? Other people are asking about this issue - on the forums and here on Bug Tracker - So perhaps there should be a Windows 10 sticky forum post, with the devs' response in it.

Regards, Jacob

comment:5 Changed 5 years ago by frank

Sorry, there will be no ETA for a fix. VirtualBox worked with the previous Windows 10 preview and apparently stopped working with the November update. Nobody can guarantee that another update will not change the behavior again.

comment:6 Changed 5 years ago by Jacob Klein

Thank you for the response, frank. It would be ideal if we had a central place to track the current status of the issue. Is the intent for this Ticket to be that place? (I ask because a mod locked the forum thread I was using to track it).

comment:7 Changed 5 years ago by Jacob Klein

This comment added for informational purposes.

"Oracle VirtualBox v4.3.21 Test Build 97569", which was released today, does not work on Windows 10 x64 Technical Preview Build 9879. It still immediately crashes on startup, triggering the Windows Error Reporting (WerFault.exe) process.

Current error and offset is:

Problem Event Name:	APPCRASH
Application Name:	VirtualBox.exe
Exception Code:		c0000005
Exception Offset:	0000000000015602
OS Version:		6.4.9879.2.0.0.256.48
Locale ID:		1033
Additional Information 1:	8cd9
Additional Information 2:	8cd9d69e75f25e211e2539f6f5ffc020
Additional Information 3:	119a
Additional Information 4:	119a0824836fcb9abe7c9c7b599cd5ed

Thanks, Jacob Klein

Last edited 5 years ago by Jacob Klein (previous) (diff)

comment:8 follow-up: ↓ 19 Changed 5 years ago by Yirkha

Hi, the cause of the current crash is that we -ahem, they! have added some new stuff to the IMAGE_LOAD_CONFIG_DIRECTORY32 and IMAGE_LOAD_CONFIG_DIRECTORY64 structures again, changing their size (to 0x68 and 0xA0 bytes, respectively). rtldrPEValidateDirectoriesAndRememberStuff() therefore fails for ntdll.dll as shown above and other system DLLs.

When I temporarily disabled this check in Virtual Box, I was able to launch the default UI, the VM and my guest OS fine and I have not encountered any other issues so far.

You will be able to alter the code properly when the next Windows SDK comes out, of course. However I think it might be desirable to have a temporary fix in place, even if just to spit out a test build. As other people have already pointed out before, the "Consumer Preview" is coming out soon and with its much wider audience, all those people might be already using VBox and finding any more obscure incompatibilities instead of being blocked out by this unintuitive crash upon startup.

comment:9 Changed 5 years ago by bird

  • Status changed from new to closed
  • Host type changed from other to Windows
  • Resolution set to fixed
  • Summary changed from VirtualBox fails to start on Windows 10 9879 to VirtualBox fails to start on Windows 10 9879 [FIXED IN SVN]

Thanks a bunch for debugging it. The changes to the IMAGE_LOAD_CONFIG_DIRECTORY32 & IMAGE_LOAD_CONFIG_DIRECTORY64 structures can for example be found in the WinTypes.pdb file (en_windows_technical_preview_symbols_9879_x64_5933167.msi). r53877 updates our structures and the code using them.

comment:10 Changed 5 years ago by Jacob Klein

bird,

This is excellent news! I can't wait to see a Test Build where I can try it out! :) https://www.virtualbox.org/wiki/Testbuilds

comment:11 Changed 5 years ago by Jacob Klein

For reference only, Oracle VirtualBox v4.3.21 Test Build 97569, crashes on Windows 10 Technical Preview Build 9926 (released today). It still immediately crashes on startup, triggering the Windows Error Reporting (WerFault.exe) process... with the same Exception Code/Offset, and matching Additional Info for parts 1 and 2 (but not 3 and 4).

I'm hopeful that your checkin will resolve the issue in the next Test Build.

Details of the crash are here:

Problem Event Name:	APPCRASH
Application Name:	VirtualBox.exe
Exception Code:		c0000005
Exception Offset:	0000000000015602
OS Version:		10.0.9926.2.0.0.256.48
Locale ID:		1033
Additional Information 1:	8cd9
Additional Information 2:	8cd9d69e75f25e211e2539f6f5ffc020
Additional Information 3:	27a2
Additional Information 4:	27a2cc1af7d50a80df6b53295994c6c1

Thanks, Jacob Klein

comment:12 Changed 5 years ago by frank

We didn't test this build yet but this build should at least work with the previous Windows 10 preview.

comment:13 Changed 5 years ago by Yirkha

Verified working with Windows 10 Pro TP build 9926. Thanks for the quick fix guys!

comment:14 Changed 5 years ago by Jacob Klein

"Quick"... reported October 23 2014 :) ... a mere 3 months ago.  https://forums.virtualbox.org/viewtopic.php?f=6&t=64279&p=302352#p302352

I'll give it a go. Hopefully it works on Build 9926. Special thanks to frank, bird, and Yirkha.

Last edited 5 years ago by Jacob Klein (previous) (diff)

comment:15 Changed 5 years ago by Jacob Klein

So far, things are going well for me using 4.3.21 R97845, on Windows 10 Technical Preview Build 9926. I transplanted my 4 old RNA World VMs (with months of calculations on each VM), and it started right up just fine, and taking snapshots appears to be working also.

Awesome! Thanks again!

comment:16 Changed 5 years ago by atomi

Installing 4.3.21 R97845 on Windows 10 9926 installs without error but causes network driver issues - crippling the OS.

On fresh new Windows 10 9926 installs:

If I install VirtualBox (either 4.3.12 or 4.3.21 R97845) after installing my wifi drivers, Windows refuses to boot to the desktop (instead of the desktop I get a black screen with a working pointer and nothing else).

If I install VirtualBox before installing my wifi drivers, Windows refuses to install the wifi drivers and won't let me delete the VirtualBox host-only network adapter.

Last edited 5 years ago by atomi (previous) (diff)

comment:17 Changed 5 years ago by blonkel

Hey I installed 4.3.21 R97845 on a Windows 10 9926 TP (German edition).

The Manager doesnt start, can i help to contribute with logs or something?

comment:18 Changed 5 years ago by slhawkins

I installed Windows 10 9926 on top of a fresh copy of Windows 8.1 Pro last week... I have an Intel Dual Band Wireless-AC 7260 WiFi adapter. Immediately after installing build 97963 my WiFi quits working. It shows that I'm still connected but that I have no internet (and can't browse anything). I had the same problem with restarting, it gives me a black screen with a cursor and I originally had to do a system restore, but with this latest build I just disabled the VBox drivers before restarting.

Anyways, here's the event log entry after the install.

Miniport Intel(R) Dual Band Wireless-AC 7260 - VirtualBox Bridged Networking Driver Miniport, {e90cbf06-3961-4858-b317-50c9f75daef5}, had event Fatal error: The IM miniport has failed to initialize

I'm not sure what it means but hopefully it helps!

comment:19 in reply to: ↑ 8 Changed 4 years ago by sepecat

For those using VirtualBox 4.3.x for Vagrant or other reasons: this issue cropped up again after this week's major Windows 10 update if you were running 4.3.30 rev 101610. Don't be like me and run numerous diagnostics and write a long post before realizing that the latest test build at https://www.virtualbox.org/wiki/Testbuilds (build rev 103933) takes care of the problem.

Replying to Yirkha:

Hi, the cause of the current crash is that we -ahem, they! have added some new stuff to the IMAGE_LOAD_CONFIG_DIRECTORY32 and IMAGE_LOAD_CONFIG_DIRECTORY64 structures again, changing their size (to 0x68 and 0xA0 bytes, respectively). rtldrPEValidateDirectoriesAndRememberStuff() therefore fails for ntdll.dll as shown above and other system DLLs.

When I temporarily disabled this check in Virtual Box, I was able to launch the default UI, the VM and my guest OS fine and I have not encountered any other issues so far.

You will be able to alter the code properly when the next Windows SDK comes out, of course. However I think it might be desirable to have a temporary fix in place, even if just to spit out a test build. As other people have already pointed out before, the "Consumer Preview" is coming out soon and with its much wider audience, all those people might be already using VBox and finding any more obscure incompatibilities instead of being blocked out by this unintuitive crash upon startup.

Last edited 4 years ago by sepecat (previous) (diff)

comment:20 Changed 3 years ago by sintetic

I know the answer for this issue. Just download the latest version of Oracle VM, and install it. The old VM will be replaced and the latest version will be with no issue for the Windows(with all the changes from the old VM).

I had the same problem, so I installed the latest VM from here: https://www.virtualbox.org/wiki/Testbuilds (for windows).

I think that this is the best and simple solution for everyone.

comment:21 Changed 3 years ago by tage

Yep, just the thing that solved the problem. Thank You so much :-)

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use