VirtualBox

Ticket #13627 (closed defect: fixed)

Opened 5 years ago

Last modified 5 years ago

filespec_add: conflicting specifications for /opt/VBoxGuestAdditions-4.3.18/lib/VBoxGuestAdditions/98vboxadd-xclient and /opt/VBoxGuestAdditions-4.3.18/bin/VBoxClient-all, using system_u:object_r:bin_t:s0. -> fixed in 4.3.x and later releases after 24 Nov 2014

Reported by: robatino Owned by:
Component: other Version: VirtualBox 4.3.18
Keywords: Cc:
Guest type: Linux Host type: other

Description

In both my Fedora 21 and Rawhide VirtualBox guests, with guest additions installed, if I do an SELinux relabel, I get the error message in the Summary. I originally reported this to Fedora's Bugzilla as  https://bugzilla.redhat.com/show_bug.cgi?id=1164050 which was closed as NOTABUG as they believe the bug is in VirtualBox. I'm attaching a VBox.log file for my Rawhide guest, though I did not do a relabel with this particular run. (The error is 100% reproducible.)

Attachments

VBox.log Download (114.0 KB) - added by robatino 5 years ago.
VBox.log for Fedora Rawhide guest

Change History

Changed 5 years ago by robatino

VBox.log for Fedora Rawhide guest

comment:2 Changed 5 years ago by robatino

Issue also exists in VirtualBox 4.3.20 (with 4.3.18 replaced by 4.3.20 in the error message, of course). I don't appear to have permission to edit the ticket accordingly (either the Version, or the Summary).

comment:3 follow-up: ↓ 4 Changed 5 years ago by frank

No need to update the ticket for every version. Fix is planned for the next maintenance release.

comment:4 in reply to: ↑ 3 Changed 5 years ago by robatino

Replying to frank:

No need to update the ticket for every version. Fix is planned for the next maintenance release.

Thanks. I wasn't even sure if it was a bug or due to some kind of nonstandard configuration on my system.

comment:5 follow-up: ↓ 6 Changed 5 years ago by michael

I was actually waiting for some sort of response from you before committing the fix. Based on the Gentoo wiki link above, could you try removing /opt/VBoxGuestAdditions-4.3.18/bin/VBoxClient-all on the guest and replacing it with a symbolic link to /opt/VBoxGuestAdditions-4.3.18/lib/VBoxGuestAdditions/98vboxadd-xclient to see if that fixes the issue? Thanks.

comment:6 in reply to: ↑ 5 Changed 5 years ago by robatino

Replying to michael:

I was actually waiting for some sort of response from you before committing the fix. Based on the Gentoo wiki link above, could you try removing /opt/VBoxGuestAdditions-4.3.18/bin/VBoxClient-all on the guest and replacing it with a symbolic link to /opt/VBoxGuestAdditions-4.3.18/lib/VBoxGuestAdditions/98vboxadd-xclient to see if that fixes the issue? Thanks.

Replacing the 4.3.20 file with the symlink does appear to fix the issue.

comment:7 Changed 5 years ago by michael

  • Summary changed from filespec_add: conflicting specifications for /opt/VBoxGuestAdditions-4.3.18/lib/VBoxGuestAdditions/98vboxadd-xclient and /opt/VBoxGuestAdditions-4.3.18/bin/VBoxClient-all, using system_u:object_r:bin_t:s0. to filespec_add: conflicting specifications for /opt/VBoxGuestAdditions-4.3.18/lib/VBoxGuestAdditions/98vboxadd-xclient and /opt/VBoxGuestAdditions-4.3.18/bin/VBoxClient-all, using system_u:object_r:bin_t:s0. -> fixed in 4.3.x and later releases after 24 Nov 2014

I uploaded test builds<1> where this issue should be fixed. (Actually the OS X test build is currently at revision 97013, which is two too early, but the others should be good, as should the separate Additions download.)

Version 0, edited 5 years ago by michael (next)

comment:8 Changed 5 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Fix is part of VBox 4.3.22.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use