VirtualBox

Ticket #13615 (closed defect: invalid)

Opened 4 years ago

Last modified 11 months ago

Ubuntu 14.10 ISO live boot ends up with a corrupted display -> guest OS issue, see Launchpad #1443853

Reported by: piotrjurkiewicz Owned by:
Priority: major Component: GUI
Version: VirtualBox 4.3.18 Keywords:
Cc: lothario Guest type: X11
Host type: all

Description

Booting up live session of Ubuntu MATE 14.10 and Ubuntu Gnome 14.10 from ISO ends up with a corrupted screen. See the screenshot:

https://launchpadlibrarian.net/186864347/ubu.png

Switching back and forth to the tty7 (ctrl+alt+F1 and then alt+F7) fixes the display.

I think that this might be a problem with resolution setting:

00:00:31.226379 Display::handleDisplayResize(): uScreenId = 0, pvVRAM=0000000000000000 w=1152 h=400 bpp=0 cbLine=0x0, flags=0x1
00:00:31.226399 UIFrameBuffer::RequestResize: Screen=0, Format=0, BitsPerPixel=0, BytesPerLine=0, Size=1152x400, Sending to async-handler..
00:00:31.226457 UIFrameBufferQImage::resizeEvent: Format=0, BitsPerPixel=0, BytesPerLine=0, Size=1152x400
00:00:31.226467 UIFrameBufferQImage::resizeEvent: Resizing to FALLBACK buffer due to format is invalid..

After switching back and forth to the tty7 (what fixes the display) the log says:

00:00:31.226379 Display::handleDisplayResize(): uScreenId = 0, pvVRAM=0000000000000000 w=1152 h=400 bpp=0 cbLine=0x0, flags=0x1
00:00:31.226399 UIFrameBuffer::RequestResize: Screen=0, Format=0, BitsPerPixel=0, BytesPerLine=0, Size=1152x400, Sending to async-handler..
00:00:31.226457 UIFrameBufferQImage::resizeEvent: Format=0, BitsPerPixel=0, BytesPerLine=0, Size=1152x400
00:00:31.226467 UIFrameBufferQImage::resizeEvent: Resizing to FALLBACK buffer due to format is invalid..
00:01:37.584616 Display::handleDisplayResize(): uScreenId = 0, pvVRAM=0000000000000000 w=720 h=400 bpp=0 cbLine=0x0, flags=0x1
00:01:37.584634 UIFrameBuffer::RequestResize: Screen=0, Format=0, BitsPerPixel=0, BytesPerLine=0, Size=720x400, Sending to async-handler..
00:01:37.584680 UIFrameBufferQImage::resizeEvent: Format=0, BitsPerPixel=0, BytesPerLine=0, Size=720x400
00:01:37.584692 UIFrameBufferQImage::resizeEvent: Resizing to FALLBACK buffer due to format is invalid..
00:01:39.055475 Display::handleDisplayResize(): uScreenId = 0, pvVRAM=000000000a7f0000 w=1024 h=768 bpp=32 cbLine=0x1000, flags=0x1
00:01:39.055495 UIFrameBuffer::RequestResize: Screen=0, Format=843204434, BitsPerPixel=32, BytesPerLine=4096, Size=1024x768, Sending to async-handler..
00:01:39.055559 UIFrameBufferQImage::resizeEvent: Format=843204434, BitsPerPixel=32, BytesPerLine=4096, Size=1024x768
00:01:39.055568 UIFrameBufferQImage::resizeEvent: Resizing to directly use VGA device content..

I have tested 4.3.18 and also the testbuild 4.3.19 r96825, it happens on both of them.

You can download the ISO images of these two systems here:

 https://ubuntu-mate.r.worldssl.net/download/ubuntu-mate-14.10-desktop-amd64.iso

 http://cdimage.ubuntu.com/ubuntu-gnome/releases/14.10/release/ubuntu-gnome-14.10-desktop-amd64.iso

Attachments

VBox.log Download (52.7 KB) - added by piotrjurkiewicz 4 years ago.
Ubuntu 14.10 64-bit-2015-04-23-23-30-11.log Download (92.7 KB) - added by Technologov 4 years ago.
vbox.log by Technologov, for comparison

Change History

Changed 4 years ago by piotrjurkiewicz

comment:1 Changed 4 years ago by michael

We once investigated something similar and found it to be a bug in Ubuntu, which called the following sequence during boot on all virtual terminals from /lib/udev/console-setup-tty:

# setfont -C terminal fontname

Executing that manually triggered the screen corruption as well. You might investigate to see if that is what is causing your issue.

comment:2 Changed 4 years ago by StephaneCharette

I've recently been plagued by this as well. I can no longer install Ubuntu in a clean VM because when I boot the 64-bit Ubuntu 14.10 Desktop .iso file, it boots into this corrupted 1152x400x32 windows.

I've tried giving it more video memory and toggling the 3D Acceleration checkbox, but no change.

My host is 64-bit Ubuntu 14.10, running VB 4.3.20r96996. The machine log also shows the same line even though the window size on the host is much larger than 1152x400:

00:00:29.718869 Display::handleDisplayResize(): uScreenId = 0, pvVRAM=0000000000000000 w=1152 h=400 bpp=0 cbLine=0x0, flags=0x1

Last edited 4 years ago by StephaneCharette (previous) (diff)

comment:3 Changed 4 years ago by StephaneCharette

Just figured out that "white spot" in the middle of the screenshot above is the mouse. When I move my mouse around in the very top-left corner of the screen, I can see the blurred white arrow shape moving around in the VM. So the VM really is up and running, the only problem is the display is corrupted and unusable.

Because I cannot insert CTRL+ALT+F1 into the VM (see bug #13702) I have no means of working around this bug. At the moment, I unfortunately have no means by which to install the vanilla version of Ubuntu 14.10 as a guest in VirtualBox.

comment:4 Changed 4 years ago by StephaneCharette

comment:5 follow-up: ↓ 6 Changed 4 years ago by michael

Please see comment 1.

comment:6 in reply to: ↑ 5 Changed 4 years ago by StephaneCharette

Replying to michael:

Please see comment 1.

I saw that comment. Doesn't prevent the fact that many people are running into this problem, and the solution is non-obvious. This prevents even the plain Ubuntu .iso from first booting up, thus preventing the installation of Ubuntu. Not a good experience.

comment:7 Changed 4 years ago by michael

In that case, did you try some investigation to see if it is the same issue, and if you did and it is, wouldn't it be better to open a bug on Launchpad?

comment:8 Changed 4 years ago by StephaneCharette

How do I investigate? All I know is the Ubuntu .iso files no longer boot in VirtualBox. At least for me, and for all those people at the link in comment #4. I searched on Google, and found this bug ticket, which also shows I'm not the only one with this problem. Your comment #1 only shows that this problem happens in Virtualbox in other ways as well. I'm willing to help where I can, but let me know exactly what you want me to try to fix this problem so I can boot and install Ubuntu in VirtualBox.

comment:9 Changed 4 years ago by michael

It was a while since I saw this, and I don't have time to look at it just now, but I found notes saying that executing "setfont -C terminal <fontname>", possible from an X terminal when there is no corruption visible triggers this. A bit of internet searching says that setfont manipulates the graphics card directly, and I believe that it switches it into text mode as part of that. Chances are that in VirtualBox, due to different timing, setfont executes after the X server has already loaded, whereas on physical hardware it executes earlier.

comment:10 Changed 4 years ago by HaroldFinch

This bug hit me too today when I tried to install Xubuntu 14.10 using the very latest stable VirtualBox (4.3.22 r98236).

Other people are encountering it too:  http://askubuntu.com/questions/541006/ubuntu-14-10-does-not-install-in-virtualbox

comment:11 follow-up: ↓ 13 Changed 4 years ago by michael

Did you do the test I mentioned above? If that triggers then you should probably be talking to Ubuntu about this and not to us.

comment:12 Changed 4 years ago by michael

The picture on that "ask Ubuntu" link looks exactly like what that setfont bug produces (or perhaps the bug is that Ubuntu are using setfont the way they do).

comment:13 in reply to: ↑ 11 Changed 4 years ago by StephaneCharette

Replying to michael:

you should probably be talking to Ubuntu about this and not to us.

I disagree. The Ubuntu .iso files from Canonical's download page work fine on metal, but they don't work in VirtualBox. I'd say us filing a bug against VirtualBox is the right thing to do.

Now whether VirtualBox wants to bring this to Canonical's attention is up to you. But regardless, we have a very serious problem that prevents VirtualBox from working with Ubuntu.

comment:14 Changed 4 years ago by michael

This seems to be the same problem on OpenSUSE by the way:

 https://bugzilla.novell.com/show_bug.cgi?id=302010#c60

comment:15 Changed 4 years ago by frank

Having different behavior as VirtualBox guest comparing to bare metal is not an evidence that this is a VirtualBox bug. You opened this bug against VirtualBox, that's fine, but at the same time please be aware that further investigation is not the top priority for us. And it's not the first time we asked the Ubuntu or Fedora guys to fix a bug. Everything takes time.

comment:16 Changed 4 years ago by mvniekerk

To circumvent this bug temporarily:

ALT+CTRL+F1

sudo stop lightdm

sudo start lightdm

comment:17 Changed 4 years ago by michael

Marked ticket #13923 a duplicate of this one. The problem can actually be circumvented just by doing Host+F1 to switch to a virtual terminal and then Host+F7 to switch back without re-starting lightdm.

Once again, I realise that this is annoying, but we are sufficiently convinced that this is a problem in Ubuntu that we will not spend limited development time on it. If someone can convince us otherwise we might take a look at it. That would begin though with opening a bug report with Ubuntu (I would be happy to add explanations on it and talk to the Ubuntu people) and taking the time to follow that through with them.

Since no one has taken the time to do that yet I assume that this issue is not particularly important to anyone.

comment:18 Changed 4 years ago by 林博仁(Buo-Ren Lin)

Hi everyone, I've redirected the bug to Ubuntu's Launchpad bug tracker:

[Bug #1443853 “Ubuntu 14.10 ISO live boot in VirtualBox ends up with a corrupted display” : Bugs : console-setup package : Ubuntu]( https://bugs.launchpad.net/ubuntu/+source/console-setup/+bug/1443853)

Please consider it particularly important ;)

Last edited 4 years ago by 林博仁(Buo-Ren Lin) (previous) (diff)

comment:19 Changed 4 years ago by michael

Updated that, let's see what happens now.

comment:20 Changed 4 years ago by PGab

I just encountered the same problem (guest Ubuntu 14.10), after the third straight try to boot the machine it seems to work. My host is Xubuntu 14.04.

comment:21 Changed 4 years ago by Technologov

Same problem here

Broken hosts:

Intel Core i7 2600K, Debian 6 x64 + VBox 5.0.0-BETA2

Intel Core i7 2600K, Windows 7 x64 + VBox 5.0.0-BETA2

Intel Core i7 2600K, Debian 6 x64 + VBox 4.3.26 and 4.3.0

Intel Core i7 2600K, Debian 6 x64 + VBox 4.2.0 and 4.2.28 -- sometimes work, non-deterministic !!!

Intel Core i7 4600U, Windows 7 x64 + VBox 5.0.0-BETA2 -- sometimes work, non-deterministic !!!

Working hosts:

Intel Core i7 2600K, Debian 6 x64 + Qemu/KVM (shipped with Debian)

-Technologov, 27.04.2015

comment:22 Changed 4 years ago by michael

I suggest that any further discussion of this should happen on Launchpad until something new emerges there. Please do not add comments here in the mean-time so that people read the present comment.

Changed 4 years ago by Technologov

vbox.log by Technologov, for comparison

comment:23 Changed 3 years ago by nouknouk

Don't miss to read the previous comment, but I think it is also usefull to provide right here a simple workaround, as this page raises on Google searchs.

During the installation, after the screen becomes corrupted:

  • hit RIGHT Ctrl+F1 (to switch to a console display).
  • then, switch back to the graphical display, with RIGHT Ctrl + F7.

My 2 cents.

Last edited 3 years ago by nouknouk (previous) (diff)

comment:24 Changed 3 years ago by michael

  • Status changed from new to closed
  • Resolution set to invalid
  • Summary changed from Ubuntu 14.10 ISO live boot ends up with a corrupted display to Ubuntu 14.10 ISO live boot ends up with a corrupted display -> guest OS issue, see Launchpad #1443853

I will close this as a guest OS issue.

Update: Ubuntu fixed this in 16.10 by including a driver for vboxvideo. It seems that the driver is not always loaded early enough in the boot process though, and sometimes X.Org may start to access the graphics device while the driver is still loading.

Last edited 11 months ago by michael (previous) (diff)

comment:25 Changed 11 months ago by StephaneCharette

I think deleting recent comments and attachments from this ticket is pretty low for VirtualBox staff to do. I understand you feel the problem is not in VirtualBox, and you'd rather see it fixed elsewhere by someone else, but censorship doesn't seem right.

comment:26 Changed 11 months ago by michael

This is in line with the policy on the bug tracker page<1> and with past practice. If you would like to talk about that, I suggest we do it on the developer mailing list or by e-mail (michael thayer at oracle) rather than here.

  1. https://www.virtualbox.org/newticket

comment:27 Changed 11 months ago by michael

  • Cc lothario added

Putting lothario on CC. In fact, the Lubuntu 17.10 bug is a different one (I did take time to reproduce it). The Lubuntu live ISO starts loading the VirtualBox graphics driver and X.Org at the same time, and if X.Org happens to be slightly faster it starts accessing the graphics hardware without using the driver, while the driver is also accessing it. This is also a bug in Lubuntu though. It should make sure that the graphics driver is loaded before it needs to use it.

You should probably open a new bug at Launchpad for this.

Edit: I updated the existing Launchpad bug regarding this issue.

Last edited 11 months ago by michael (previous) (diff)
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use