VirtualBox

Ticket #1357 (closed defect: fixed)

Opened 6 years ago

Last modified 6 years ago

Wrong test for file in debian/vboxdrv.init.in

Reported by: blueyed Owned by:
Priority: trivial Component: other
Version: VirtualBox 1.5.6 Keywords:
Cc: Guest type: other
Host type: other

Description

The test, which checks for an existing kernel module will never fail, because of a missing "-f" in the test. Therefore, "No suitable module for running kernel found." will never get displayed.

The following patch fixes this:

--- debian/vboxdrv.init.in      (Revision 7486)
+++ debian/vboxdrv.init.in      (Arbeitskopie)
@@ -88,7 +88,7 @@
   log_daemon_msg "Starting VirtualBox kernel module" "$MODNAME";
   # ensure the module is loaded
   if ! running; then
-    if [ ! -f "$KDIR/$MODNAME.o" -a ! "$KDIR/$MODNAME.ko" ]; then
+    if [ ! -f "$KDIR/$MODNAME.o" -a ! -f "$KDIR/$MODNAME.ko" ]; then
       failure "No suitable module for running kernel found."
     fi
     if ! modprobe $MODNAME > /dev/null 2>&1; then

Change History

comment:1 Changed 6 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Thanks for this report. Already fixed in svn.

comment:2 Changed 6 years ago by blueyed

Huh? Do you mean that you have just applied it?

Because my patch is against current SVN ( http://virtualbox.org/svn/vbox/trunk).

In case you've just applied it and only wanted to mention it, a copy'n'paste of the revision id would help others to find a patch. But I see that it may be diffcult, because of the sync process.

Thanks for a great product!

comment:3 Changed 6 years ago by frank

Note that the SVN repository of the virtualbox.org is usually some days behind our internal SVN repository. This has several reasons, one of them is that we synchronize the external SVN only if we are quite sure that no critical regressions were introduced. Furtherore I cannot tell you the revision number as the numbers of both repositories are different (not all changesets of the internal repository are synchronized to the external repository).

As this is a small fix it is easier for us to close this defect as soon as the fix (in this case we changed much more) was committed to the internal repository.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use