VirtualBox

Ticket #1350 (new defect)

Opened 6 years ago

Last modified 5 years ago

Adobe Flash in guest causes 100% CPU in host

Reported by: ariel Owned by:
Priority: major Component: VMM
Version: VirtualBox 1.5.6 Keywords:
Cc: Guest type: other
Host type: other

Description

Win-XP SP2 guest running under Ubuntu 7.10 (2.6.22-14-generic, x86)

The guest runs fine; however when opening a browser (Firefox or IE7), and navigating to a site with flash content (such as wiley.ca), the host CPU utilization shoots up to 100% in one the CPUs of my core2duo machine. "top" shows:

PID USER PR NI VIRT RES SHR S %CPU %MEM TIME+ COMMAND

7975 ariel 15 0 1140m 1.1g 16m R 97 53.9 117:44.55 VirtualBox

Weirdly enough, the WinXP guest Task Manager shows 0% CPU activity while this happens.

However, the whole virtual machine turns slow and unresponsive when this is happening. There are no hangs, but the VM is barely usable.

This has been a long standing problem. I'm currently running 1.5.6, but this happened in 1.54 as well.

The host has 2GB of RAM and the virtualmachine is configured to use 964 megs, which never fills up.

The issue shows up in two different machines; both are Core 2 Duo, one is a desktop, the other a laptop. Enabling or disabling VT-x extensions in VB configuration and in the machines' BIOS produces no change.

Other people are reporting the same problem, this is the discussion thread:  http://forums.virtualbox.org/viewtopic.php?t=3137

Change History

comment:1 Changed 6 years ago by frank

  • Component changed from other to VMM

comment:2 Changed 5 years ago by spiffytech

I can confirm this bug with: VBox 2.1.4 Host: Ubuntu 8.10 x86 Guest: Fedora 10 Thinkpad T61

comment:3 Changed 5 years ago by jmspaggi

Samething here.

I installed 2 Virtual Machines. 2 times i386 Debian OS hosted on a AMD64 Debian OS.

On one of the 2 boxes, Flash is working fine, but on the 2nd one, when using Flash 10, the Virtual Machine get very slow until I can kill Firefox (IceWeasel). If I take to much time, them I have to kill the VBox itself. Tried to play with all the parameters with no success.

On VBox 3.0.6 r52128.

Can reproduce it. So can provide details if required.

comment:4 Changed 5 years ago by jmspaggi

More information:

I tried to play with taskset as I read in the forum with no success.

Also, I duplicated the Virtual Hard Drive to have the 2 VM running exactly the same image, and the 2nd VM I start also get stuck when I start flash.

So I don't know why, but only one VM can run flash at a time.

Very strange.

Mouse is getting very flow, and everything seems to be stuck until I close the browser.

Any clue?

comment:5 Changed 5 years ago by jmspaggi

FYI, if you don't install the additionnal tools on the guest, you will not have this issue. So I re-installed my 3 guests and everything is now working fine. Also installed last update (r53138)

My 2¢.

JM

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use