VirtualBox

Ticket #135 (closed defect: fixed)

Opened 7 years ago

Last modified 6 years ago

PCLinuxOS Mouse Problem

Reported by: joealwine Owned by:
Priority: major Component: other
Version: VirtualBox 1.3.6 Keywords:
Cc: Guest type: other
Host type: other

Description

Mouse seems to be stuck at the bottom right of the screen on startup. Mouse is ok for the host, but never seems to switch to the guest. Using Linux-Safe settings option from startup menu, desktop is 1024 X 768 and mouse is ok! Host is Ubuntu 6.10, Guest is PCLinuxOS2007TestRelease2.

Change History

comment:1 Changed 7 years ago by michael

What host and guest combination? To me, it sounds like a mouse setup problem in the guest - try using the guest additions or configuring the guest to use a PS/2 mouse. Was the Linux-Safe settings option in the guest?

comment:2 Changed 7 years ago by coubi64

Same problem for me with VBOX 1.3.6 and Ubuntu Edgy as Host and Feisty Fawn as Guest.

With this condition to reproduce: closing the vm with "state saved". If i restart the vm, i see the cursor of the mouse in the window but I can't move it.... It happen's often but not always.

comment:3 follow-up: ↓ 4 Changed 7 years ago by coubi64

I think this is the same pb here:

 http://www.virtualbox.org/ticket/79

comment:4 in reply to: ↑ 3 Changed 7 years ago by coubi64

Replying to coubi64:

I think this is the same pb here:

 http://www.virtualbox.org/ticket/79

Sorry it is not linked I think...

comment:5 Changed 7 years ago by joealwine

Host is Ubuntu 6.10, Guest is PCLinuxOS2007TR2. Guest additions 1.3.6 are installed. Problem with mouse started after installing guest additions. Safe settings options in in startup menu on Guest.

comment:6 Changed 7 years ago by michael

I did a test installation (PCLinuxOS) to see what was going wrong. The problem was the line

InputDevice "Mouse2" "SendCoreEvents"

in /etc/X11/xorg.conf. If you comment that line out and restart the X server (log out and log back in), it should work fine.

This probably does not apply to the Feisty problem. (But try Alt-Tab if the mouse stops reacting in a Ubuntu guest).

comment:7 Changed 7 years ago by joealwine

Thanks Michael. Mouse problem is solved. I commented out the line in the ServerLayout section of the PClinuxOS Guest system.

Section "ServerLayout"

Identifier "layout1" InputDevice "Keyboard1" "CoreKeyboard" InputDevice "Mouse1" "CorePointer"

# InputDevice "Mouse2" "SendCoreEvents"

Screen "screen1"

EndSection

comment:8 Changed 7 years ago by michael

  • Status changed from new to closed
  • Resolution set to fixed

I will close this bug. Please open a separate one for the Feisty issue.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use