VirtualBox

Ticket #1349 (closed defect: fixed)

Opened 6 years ago

Last modified 5 years ago

Using NAT with XP Pro (WinALL?) guests corrupts some downloads.

Reported by: silverdark Owned by:
Priority: minor Component: network/NAT
Version: VirtualBox 1.5.6 Keywords:
Cc: Guest type: other
Host type: other

Description

I tried this on 2 seperare XP Pro VirtualBox VMs, the first was using XP SP3 RC2.

Summary of Testing:
Guests: Windows XP Pro (SP3 and SP2)
Host: Windows Vista Ultimate (Running SP1) on Dell Inspiron 1720
Host NICs: Kensington Port Replicator 10/100 nic attached via USB - Builtin Dell 10/100 nic - builtin Dell 802.11N adapter
Downloads: inno setup (installation), istool (installation), flashget (installation)
Sources: Filehippo, sourceforge

Downloads would appear to complete successfully but when run I would receive "Setup file corrupt" type messages during installation. I eliminated SP3 as a possability through rolling back to a pre-sp3-install snapshot - no luck. I tried a 2nd VirtualBox virtual machine with a base install of XP Pro SP2 (no updates or apps of any kind installed after XP Pro install - used for testing our installation packages) with the same results. I tried downloading and installing the same files (to eliminate the unlikely possability that the actual distributions WERE corrupt to start)on an XP VM on one of our ESX servers and had no issues. I tried changing my host NIC and ended up using all three (listed above) to no avail.

One thing to mention - and I will verify this tongiht - I was not seeing this issue when connected to my home network. I connect directly to a common internet gateway\modem device using NAT at home, at work we use Routing and Remote Access on a Win2K3 Server as a NAT Gateway.

I marked this incident as minor because I was able to resolve my issue by switching to "Host interface" and setting up a bridge to the Kensington Port-Rep adapter. It's inconvenient however for moving the VM among various hosts within my develpoment workspace, where NAT just transparently works when a VM is moved.

Change History

comment:1 Changed 6 years ago by frank

  • Component changed from other to network

comment:2 Changed 5 years ago by frank

  • Component changed from network to network/NAT

comment:3 Changed 5 years ago by bughunter2

I can confirm that I have noticed corruption to occur as well.

I'm hosting an HTTP server on the host system and when the guest system downloads some files, they are sometimes corrupt.

FYI: I'm using my own HTTP server (Mereo, can be found on Assembla, -not spam-...). Anyway, I debugged both the running 'firefox' process inside the guest, and the running process of my server on the host. It seems that the data sent through the socket is fine, just not everything is received by the guest.

comment:4 Changed 5 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

This one should be fixed with VBox version 2.1.4.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use