VirtualBox

Ticket #13487 (closed defect: fixed)

Opened 3 years ago

Last modified 2 years ago

Ubuntu Desktop 14.04.1 freezes when restarting from saved state (3D)

Reported by: persep Owned by:
Priority: major Component: 3D support
Version: VirtualBox 4.3.16 Keywords: ubuntu, freezes, save, restore
Cc: Guest type: Linux
Host type: Windows

Description

Hi, my set-up is as a host Windows 7 64 sp1 with VirtualBox 4.3.16r95972 and as a guest with Ubuntu Desktop 14.04.1 32 bits and Guest Additions installed.

The problem is that when I save the state (not turn-off but save) of the vm and then when I restart it the ubuntu vm freezes up, sometimes with a black screen and sometimes showing the desktop but you can't click on anything leaving me the only option to turn of the vm. Virtualbox works ok its only the ubuntu vm.

I've tried the latest VirtualBox test versions 4.3.17-96342 and extension pack version 4.3.17-96238 but it still fails to restore properly.

I also tried installing a clean Ubuntu Desktop 14.04.1 32 bits and Ubuntu Desktop 14.04.1 64 bits but it still fails to restore properly with both images.

Also tried installing XUbuntu Desktop 14.04.1 32 bits and it does restore properly.

My setting with virtualbox are 3d Acceleration on and 256MB Graphics memory (I have a Nvidia GeForce GT240 1GB video card) and it does run with the 3d accelaration turned on in unity. Checked with the command

/usr/lib/nux/unity_support_test -p

It reports On.

But if I disable the 3D Acceleration in Virtualbox and save the vm when I restore it restores properly but off course like that ubuntu is unusable slow. So I think it's related to the unity 3d desktop and virtualbox 3d support

Attachments

VBox.log.3 Download (97.4 KB) - added by persep 3 years ago.
VBoxStartup.zip Download (28.4 KB) - added by persep 3 years ago.
UbuntuDesktop64.vbox Download (8.8 KB) - added by persep 3 years ago.
VBox.log Download (132.8 KB) - added by randy1024 3 years ago.
Ubuntu (NanoBone)-2015-10-08-09-03-07.log Download (104.2 KB) - added by mpfj 2 years ago.

Change History

Changed 3 years ago by persep

Changed 3 years ago by persep

Changed 3 years ago by persep

comment:1 Changed 3 years ago by Thomas_123

Same observation with

Host: Windows 7 64-bit VBox: 4.3.18 Guest: Ubuntu 14.04 LTS (3D acc enabled)

comment:2 follow-up: ↓ 3 Changed 3 years ago by persep

I've just installed the latest version 4.3.18r96516 and I updated the extension pack and the Guest Additions on the Ubuntu 14.0.4 LTS VM and I noticed what Thomas_123 says. The screen of the Ubuntu VM still freezes when restoring from the saved state.

But then I discovered something. I run the Ubuntu VM in a window and it occur to me to resize the VM window which causes a re-draw of the contents of the VM window and then the Ubuntu VM becomes usable again.

So try resizing the window to make it work again.

Last edited 3 years ago by persep (previous) (diff)

comment:3 in reply to: ↑ 2 Changed 3 years ago by Thomas_123

I confirm the observation made by persep: resizing the window of the VM enables to resume working with it.

comment:4 Changed 3 years ago by tzahreddin

it is possible to log into the saved machine, after resizing the window, but it is not possible to work with this state since the screen is totaly cluttered with fragments of the open applications.

comment:5 Changed 3 years ago by persep

At least in my case I'm able to work after resizing. I maximize, resotre size and get on working

comment:6 Changed 3 years ago by persep

Problem persists in latest VB build version 4.3.20r96997 but the resizing solutions seems to still work

comment:7 follow-up: ↓ 10 Changed 3 years ago by galitsyn

This is know issue. We are currently working on fix.

comment:8 Changed 3 years ago by dad

Not fixed yet? I observe the same in 4.3.24 r98716 (windows 7 64 bit host/Ubuntu 14.10 guest 64 bit/full screen, 3D acc is ON): X/GUI freezes(no screen updates at least) after save state and then start. If I switch to text console/vt - it works. Switching to window mode and then back to full screen - gui starts to update properly, so the workaround is still there.

Last edited 3 years ago by dad (previous) (diff)

Changed 3 years ago by randy1024

comment:9 Changed 3 years ago by randy1024

I am getting the same problem with 4.3.24 and 4.3.26, Win 8.1 Pro 64-bit host, Ubuntu 14.04 64-bit guest. Turning off 3D acceleration fixes it. The "workaround" does not work reliably - about 50% of the time the screen goes black and I have to reset.

comment:10 in reply to: ↑ 7 Changed 3 years ago by mpfj

Replying to galitsyn:

This is know issue. We are currently working on fix.

5 months later ... problem still exists (using 4.3.26 r98988)

Is there any update on the big ? Maybe a "nightly" build we could try that might fix the problem ?

I'm using Ubuntu 64bit 14.04.2 LTS host and Ubuntu 64bit 14.04.2 LTS guest.

It's definitely the guest that's at fault (as it's a reported fault with Win7, Win8.1 and Ubuntu hosts).

However, I'm unable to fix it by resizing the window, or switching between window / fullscreen modes.

comment:11 Changed 3 years ago by mpfj

Out of interest, I have also noticed that if I suspend / resume when at the login prompt, then there are no problems with the screen freezing.

It's only when you log in and then suspend, you get the freeze issue.

Don't know if that's any help in tracking things down ??

comment:12 Changed 3 years ago by mpfj

This is know issue. We are currently working on fix.

Another release (4.3.28 r100309) ... and it's still not fixed.

Can we get an update on this from someone ?

comment:13 Changed 3 years ago by galitsyn

We still investigating. Once issue will be fixed, we will post information about that here.

comment:14 Changed 3 years ago by frank

A bit more verbose: Resolving this problem requires much more work. One problem is that display lists are not part of the saved state but there are also other problems. 3D is a complex topic and it's not just a single-liner which would fix your problem here.

comment:15 Changed 3 years ago by mhanor

.

comment:16 Changed 2 years ago by Perryg

Adding name to track ticket

comment:17 follow-up: ↓ 18 Changed 2 years ago by oldium

Just a note for others - 5.0 has the same bug.

comment:18 in reply to: ↑ 17 Changed 2 years ago by mpfj

Replying to oldium:

Just a note for others - 5.0 has the same bug.

Confirmed for me too ...

C'mon guys ... 9 months later and still no fix ?

comment:19 Changed 2 years ago by ubentobox

I encountered this same error while using a different distribution of Linux (Debian core). I tried the re-sizing method, and while I cannot rule out just giving it time, I left the client running while I was researching this error and it eventually recovered.

When the system recovered the error notification I received was the following:

Could not switch the monitor configuration could not set the configuration for CRTC 62

The system is now working normal. When I had the system save state was logged in and full screened on one of my 3 monitors.

comment:20 Changed 2 years ago by weibelt

Last version that is working for me: 4.3.10 (I think you shouldn't use that version for production since it contains security issues)

comment:21 Changed 2 years ago by plarkin

Problem persists with Ubuntu 14.04 LTS (Unity DE)

in VBox 4.3.30 r101610 atop Win7 Dell Lattitude E6530

NOT present in VBox 5.0.0 atop Win8.1 Dell Lattitude 3550 (VBox guest additions usually die though - related? Who knows, but I need to fix that anyway.)

Editing: After fixing the guest additions, the issue IS PRESENT in 5.0.0

Last edited 2 years ago by plarkin (previous) (diff)

comment:22 Changed 2 years ago by mpfj

Still present in 5.0.4 ... :-(

comment:23 Changed 2 years ago by weibelt

On 5.0.0 I set one day "Paravirtualization Interface" to KVM and since then it works.

comment:24 Changed 2 years ago by mpfj

Well, I tried KVM (I'm running on Linux) and it made no difference :-(

comment:25 Changed 2 years ago by oldium

I also see no difference with KVM running on Win 7 host - problem persists.

Changed 2 years ago by mpfj

comment:26 Changed 2 years ago by mpfj

Still present in 5.0.6 ... :-(

I've attached my latest log file if that helps ... hint, hint !!

comment:27 Changed 2 years ago by frank

  • Summary changed from Ubuntu Desktop 14.04.1 freezes when restarting from saved state to Ubuntu Desktop 14.04.1 freezes when restarting from saved state (3D)

comment:28 Changed 2 years ago by mpfj

Sigh ... still present in 5.0.8 ... :-(

comment:29 Changed 2 years ago by mpfj

Just tried a new install of 15.10 and it has the same issue.

comment:30 Changed 2 years ago by mpfj

Quick update ...

Still broken on 5.0.10

comment:31 Changed 2 years ago by ecerulm

I would be good to disable / grey out the save machine state if VirtualBox knows that the guest is Ubuntu Desktop 14.04 and 3d acceleration is on. Al least until the bug is resolved.

EDIT: Just for the record if I do a sudo pm-hibernate I get the same result when I power up the VM again (blank screen).

Last edited 2 years ago by ecerulm (previous) (diff)

comment:32 Changed 2 years ago by sunlover

Fixed in latest (104393+) VBox 5.0.x builds from https://www.virtualbox.org/wiki/Testbuilds Please test. Guest additions update is not required. Thanks.

comment:33 Changed 2 years ago by mhanor

I can't reproduce the issue with the 104393 build. Host Windows 8.1 x64, HD6850.

comment:34 Changed 2 years ago by oldium

Confirming, 104393 build with host Windows 7 64bit, guest latest Ubuntu 14.04 LTS 64bit. It works. Thanks!

comment:35 Changed 2 years ago by mpfj

Also confirmed fixed.

r104602 on Ubuntu 14.04 64bit host, Ubuntu 14.04 64bit guest

Cheers

comment:36 Changed 2 years ago by sunlover

Thank you all for testing.

comment:37 Changed 2 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Fis is part of VBox 5.0.12.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use