VirtualBox

Ticket #1348 (closed defect: fixed)

Opened 6 years ago

Last modified 6 years ago

Guest will not start: Assertion Failed

Reported by: Gtoo4 Owned by:
Priority: major Component: other
Version: VirtualBox 1.5.6 Keywords: Assertion Failed
Cc: Guest type: other
Host type: other

Description

I get this error whether starting or clicking on settings. The directory mentioned does not exist. This is version 1.56 on Gentoo x86_64 w/2.6.24 kernel. The vdi image was used in Kubuntu 7.10 32bit, so I tried cloning also but received the same result. Thanks!

Assertion failed: [mIPCSem >= 0] at '/home2/vbox/vbox/1.5-lnx64-rel/src/VBox/Main/MachineImpl.cpp' (8058) in nsresult SessionMachine::init(Machine*). Cannot create IPC semaphore, errno=38. Please contact the product vendor!.

Result Code: 0x80004005

Change History

comment:1 Changed 6 years ago by frank

Were you ever able to start that VM? How did you create the VM? Does it help creating a new VM and attaching the .vdi image there?

comment:2 Changed 6 years ago by Gtoo4

The VM was created witn VirtualBox 1.54 on Kubuntu. I tried also to create a new machine and the same error came up. I have reinstalled a couple of times also. It doesnt help to create a new machine and then attach to the .vdi image either as I did this with the clone. It seems to me (but no idea why) there is something going on with the false directory-- I have no /home2 directory anywhere on my system. Could this be a permissions issue?

comment:3 Changed 6 years ago by Gtoo4

The problem here was SYSVIPC, which must be enabled in the kernel. I did so and recompiled my kernel for a successful start of the VM. Not a bug, just my kernel configuration....

comment:4 Changed 6 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Yes, the error code of the assertion was quite clear (38=ENOSYS). I've improved the error message to clearly state that the host kernel lacks support for SysV IPC in that case.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use