VirtualBox

Ticket #1332 (closed defect: fixed)

Opened 6 years ago

Last modified 4 years ago

Internal network does not work for OpenSolaris guests

Reported by: manoj Owned by:
Priority: major Component: network
Version: VirtualBox Solaris Beta 1 Keywords:
Cc: Guest type: other
Host type: other

Description

Summary Virtual machines running OpenSolaris are unable to connect to other virtual machines over an InternalNetwork. The issue is seen on a host running OpenSolaris build 79a.

manoj@mowgli:~$ uname -a
SunOS mowgli 5.11 snv_79a i86pc i386 i86pc Solaris

VirtualBox version: VirtualBox-opensolaris-x86-1.5.51-r28414-beta1


Details I have two Virtual Machines - one running OpenSolaris build 84 another running CentOS 4.4. I set up NAT and InternalNetwork on both the VMs. InternalNetwork is configured with static IPs. But one VM is unable to reach the other.

Here's what I did.

manoj@mowgli:/vm/Machines/osol$ VBoxManage modifyvm osol -nic2 intnet
VirtualBox Command Line Management Interface Version 1.5.51
(C) 2005-2008 innotek GmbH
All rights reserved.

manoj@mowgli:/vm/Machines/osol$ VBoxManage modifyvm osol -intnet2 intnet
VirtualBox Command Line Management Interface Version 1.5.51
(C) 2005-2008 innotek GmbH
All rights reserved.

manoj@mowgli:/vm/Machines/osol$ VBoxManage modifyvm rhel -nic2 intnet
VirtualBox Command Line Management Interface Version 1.5.51
(C) 2005-2008 innotek GmbH
All rights reserved.

manoj@mowgli:/vm/Machines/osol$ VBoxManage modifyvm rhel -intnet2 intnet
VirtualBox Command Line Management Interface Version 1.5.51
(C) 2005-2008 innotek GmbH
All rights reserved.

And here's how the network is configured on the VMs.

centos 4.4

[root@localhost ~]# uname -a
Linux localhost.localdomain 2.6.9-42.EL #1 Sat Aug 12 09:17:58 CDT 2006
i686 i686 i386 GNU/Linux
[root@localhost ~]# ifconfig eth1
eth1      Link encap:Ethernet  HWaddr 08:00:27:5B:4B:43
          inet addr:172.16.90.2  Bcast:172.16.255.255  Mask:255.255.0.0
          inet6 addr: fe80::a00:27ff:fe5b:4b43/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:41 errors:0 dropped:0 overruns:0 frame:0
          TX packets:50 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:2624 (2.5 KiB)  TX bytes:2268 (2.2 KiB)
          Interrupt:10 Base address:0xc060

[root@localhost ~]# route
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use
Iface
10.0.2.0        *               255.255.255.0   U     0      0        0 eth0
172.16.0.0      *               255.255.0.0     U     0      0        0 eth1
169.254.0.0     *               255.255.0.0     U     0      0        0 eth1
default         172.16.255.254  0.0.0.0         UG    0      0        0 eth1
[root@localhost ~]# ping 172.16.90.1
PING 172.16.90.1 (172.16.90.1) 56(84) bytes of data.
From 172.16.90.2 icmp_seq=1 Destination Host Unreachable
From 172.16.90.2 icmp_seq=2 Destination Host Unreachable

opensolaris 79a

-bash-3.2# uname -a
SunOS solaris 5.11 snv_84 i86pc i386 i86pc
-bash-3.2# ifconfig pcn1
pcn1: flags=201000843<UP,BROADCAST,RUNNING,MULTICAST,IPv4,CoS> mtu 1500
index 3
        inet 192.168.2.1 netmask ffffff00 broadcast 192.168.2.255
        ether 8:0:27:dc:98:7c
-bash-3.2# netstat -rn

Routing Table: IPv4
  Destination           Gateway           Flags  Ref     Use     Interface
-------------------- -------------------- ----- ----- ---------- ---------
default              10.0.2.2             UG        1          0 pcn0
10.0.2.0             10.0.2.15            U         1          2 pcn0
192.168.2.0          192.168.2.1          U         1          0 pcn1
127.0.0.1            127.0.0.1            UH        1         41 lo0

Routing Table: IPv6
  Destination/Mask            Gateway                   Flags Ref   Use    If   
--------------------------- --------------------------- ----- --- ------- ----- 
::1                         ::1                         UH      1      21 lo0   

-bash-3.2# ping 192.168.2.2
no answer from 192.168.2.2
 

I tried this with two VMs running CentOS and it worked fine. I also tried with two VMs running opensolaris and hit the above issue. Issue seems to be specific to OpenSolaris.

Change History

comment:1 follow-up: ↓ 2 Changed 6 years ago by manoj

I verified that this issue does not exist on my Linux installation. Seems to be OpenSolaris specific issue.

comment:2 in reply to: ↑ 1 Changed 6 years ago by manoj

Replying to manoj:

I verified that this issue does not exist on my Linux installation. Seems to be OpenSolaris specific issue.

To be clear, I am referring to a Linux host - virtual box running on Linux.

virtual box 1.5.5 running on Linux does not have this issue. virtual box beta running on Opensolaris has this issue.

comment:3 follow-up: ↓ 4 Changed 6 years ago by ramshankar

I can verify that internal networking between linux guests on OpenSolaris host is working fine.

Guests should use IPs on the same subnet I think you seem to be using different class IPs. On the linux host that you tried were you using the same IPs?

So either that or OpenSolaris guest might be causing the problem. Will test it more shortly and post back here.

comment:4 in reply to: ↑ 3 Changed 6 years ago by manoj

Replying to ramshankar:

I can verify that internal networking between linux guests on OpenSolaris host is working fine.

I have verified this too.

Guests should use IPs on the same subnet I think you seem to be using different class IPs. On the linux host that you tried were you using the same IPs?

No. I tried with addresses 172.16.90.1, 172.16.90.2 once and 192.168.2.1 and 192.168.2.2 the second time. Copy pasting mixed things up.

No, I did use IP addresses in the same subnet.

So either that or OpenSolaris guest might be causing the problem. Will test it more shortly and post back here.

Thanks. Appreciate this!

comment:5 Changed 6 years ago by manoj

Can someone confirm if this is a bug? Is there a workaround for this?

comment:6 Changed 6 years ago by ramshankar

Yes this seems to be a bug with OpenSolaris guests. Currently no workarounds for this, we'll look into it.

comment:7 Changed 6 years ago by frank

  • Component changed from other to network

comment:8 Changed 4 years ago by Technologov

Is this still relevant for VBox v3.x ?

-Technologov

comment:9 Changed 4 years ago by sandervl73

  • Status changed from new to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use