VirtualBox

Ticket #133 (closed defect: fixed)

Opened 7 years ago

Last modified 5 years ago

Guest Windows starvation and halt

Reported by: Technologov Owned by:
Priority: major Component: other
Version: VirtualBox 1.3.6 Keywords:
Cc: Guest type: other
Host type: other

Description

Windows XP Guest can be easily starved, and put to total halt, by massive networking exchange.

to reproduce:

  1. Setup Windows XP host and guest
  1. Download IP traffic generator:

 http://www.roadkil.net/CommTest.html

  1. enable host-networking.
  1. Run CommTest (either direction)
  1. Guest Windows will be halted, probably because I/O overload, until you stop this test manually (from host).

This bug might be, or be not, connected to bug #21.

Software: Windows XP Pro SP2 Eng, no extra patches, VirtualBox 1.3.6 Full.

-Alexey Eremenko

Change History

comment:1 Changed 7 years ago by sandervl73

I'm not convinced that this is a bug. Does the same happen with VMWare?

comment:2 Changed 7 years ago by Technologov

a) try to reproduce my steps

b) It does not happens with Virtual PC

comment:3 Changed 7 years ago by sandervl73

  • Priority changed from critical to major

comment:4 Changed 7 years ago by peremen

I think this problem is related to network-intensive application. For example, when I fire up my Windows XP virtual machine on Kubuntu 7.04, CPU usage looks good. However, when I tried to fire application such as web folders or download managers, host CPU usage hits 100%. Those programs work flawlessly in real(not virtual) windows.

comment:5 Changed 5 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Please reopen this bug if this is still relevant with VirtualBox 2.0.6.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use